Bug 46773 - beep: Multiple issues (4.3)
beep: Multiple issues (4.3)
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Security updates
UCS 4.3
All Linux
: P3 normal (vote)
: UCS 4.3-0-errata
Assigned To: Philipp Hahn
Arvid Requate
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-04-04 17:12 CEST by Philipp Hahn
Modified: 2018-05-16 17:04 CEST (History)
1 user (show)

See Also:
What kind of report is it?: Security Issue
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score: 0.0 () NVD


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Hahn univentionstaff 2018-04-04 17:12:31 CEST
New Debian beep 1.3-4+deb9u1 fixes:
This update addresses the following issue:
* beep, if setuid, has a race condition that allows local privilege
  escalation. (CVE-2018-0492)

Johnathan Nightingale beep through 1.3.4, if setuid, has a race condition that allows local privilege escalation.
Comment 1 Philipp Hahn univentionstaff 2018-04-04 17:21:01 CEST
[4.3-0] fb3bb4f94b Bug #46773: beep_1.3-4+deb9u1
Comment 2 Quality Assurance univentionstaff 2018-05-04 16:43:31 CEST
--- mirror/ftp/4.3/unmaintained/4.3-0/source/beep_1.3-4.dsc
+++ apt/ucs_4.3-0-errata4.3-0/source/beep_1.3-4+deb9u1.dsc
@@ -1,3 +1,7 @@
+1.3-4+deb9u1 [Sun, 25 Mar 2018 19:25:00 +0200] Moritz Muehlenhoff <jmm@debian.org>:
+
+  * CVE-2018-0492
+
 1.3-4 [Mon, 04 Jan 2016 13:34:37 +0100] Rhonda D'Vine <rhonda@debian.org>:
 
   * Update my name.
Comment 3 Arvid Requate univentionstaff 2018-05-14 18:52:03 CEST
* No UCS specific patches
* Comparison to previously shipped version ok
* Binary package update Ok
* Advisory Ok
Comment 4 Arvid Requate univentionstaff 2018-05-16 17:04:18 CEST
<http://errata.software-univention.de/ucs/4.3/43.html>