Bug 46828 - perl: Multiple issues (4.3)
perl: Multiple issues (4.3)
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Security updates
UCS 4.3
All Linux
: P3 normal (vote)
: UCS 4.3-0-errata
Assigned To: Philipp Hahn
Arvid Requate
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-04-16 16:22 CEST by Philipp Hahn
Modified: 2018-05-16 17:04 CEST (History)
1 user (show)

See Also:
What kind of report is it?: Security Issue
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score: 6.5 (CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Hahn univentionstaff 2018-04-16 16:22:09 CEST
New Debian perl 5.24.1-3+deb9u3 fixes:
This update addresses the following issues:
* CVE-2018-6797: buffer overflow related to regex unicode semantics.
* CVE-2018-6798: heap buffer overflow when matching malformed UTF-8 characters.
* CVE-2018-6913: heap buffer overflow with large data blocks.

CVE-2018-6797 perl: heap write overflow in regcomp.c
CVE-2018-6798 perl: heap read overflow in regexec.c
CVE-2018-6913 perl: heap buffer overflow in pp_pack.c
Comment 1 Philipp Hahn univentionstaff 2018-04-16 16:23:22 CEST
f443e9c76d Bug #46828: perl_5.24.1-3+deb9u3
Comment 2 Quality Assurance univentionstaff 2018-05-04 16:43:58 CEST
--- mirror/ftp/4.3/unmaintained/4.3-0/source/perl_5.24.1-3+deb9u2.dsc
+++ apt/ucs_4.3-0-errata4.3-0/source/perl_5.24.1-3+deb9u3.dsc
@@ -1,3 +1,11 @@
+5.24.1-3+deb9u3 [Sat, 10 Mar 2018 20:39:49 +0200] Niko Tyni <ntyni@debian.org>:
+
+  * [SECURITY] CVE-2018-6797: buffer overflow related to regex
+                              unicode semantics.
+  * [SECURITY] CVE-2018-6798: heap buffer overflow when matching
+                              malformed UTF-8 characters.
+  * [SECURITY] CVE-2018-6913: heap buffer overflow with large data blocks.
+
 5.24.1-3+deb9u2 [Tue, 12 Sep 2017 19:37:26 +0300] Niko Tyni <ntyni@debian.org>:
 
   * Update upstream base.pm no-dot-in-inc fix patch description.
Comment 3 Arvid Requate univentionstaff 2018-05-15 11:11:01 CEST
* No UCS specific patches
* Comparison to previously shipped version ok
* Binary package update Ok
* Advisory Ok
Comment 4 Arvid Requate univentionstaff 2018-05-16 17:04:23 CEST
<http://errata.software-univention.de/ucs/4.3/66.html>