Bug 46965 - Support distributions based on Ubuntu in Domain Join Assistant
Support distributions based on Ubuntu in Domain Join Assistant
Status: VERIFIED FIXED
Product: UCS
Classification: Unclassified
Component: Univention Domain Join (Ubuntu)
UCS 4.3
Other Linux
: P5 normal (vote)
: ---
Assigned To: Richard Ulmer
Arvid Requate
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-05-07 10:01 CEST by Erik Damrose
Modified: 2018-07-12 20:16 CEST (History)
1 user (show)

See Also:
What kind of report is it?: Feature Request
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Flags outvoted (downgraded) after PO Review:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Damrose univentionstaff 2018-05-07 10:01:19 CEST
The Univention Domain Join Assistant supports join module code for different distribution variants, we currently ship one named 'ubuntu'. To select the module to use, the script parses 'lsb_release -is'.

Distributions that base on Ubuntu set custom distribution information, e.g. Linux Mint. The Domain Join Assistant can then not be used, because there is no python module with the correct name.

We could add a command line parameter to select the module to be used, or introduce a mapping for compatible distribution ids to the ubuntu python module.
Comment 1 Erik Damrose univentionstaff 2018-05-09 09:24:04 CEST
Traceback when run on LinuxMint

2018-05-08 15:18:07,426 userinfo CRITICAL The used distribution LinuxMint is not supported.
2018-05-08 15:18:07,426 userinfo CRITICAL Traceback (most recent call last):
 File „/usr/sbin/univention-domain-join“, line 467, in run
  raise DomainJoinException()
Comment 2 Arvid Requate univentionstaff 2018-06-25 15:40:59 CEST
We also received this feedback from a Linux Mint 18.3 user:

> When trying to add the ppa it returns an error "PPA does not support xenial".
Comment 3 Richard Ulmer univentionstaff 2018-07-02 14:56:45 CEST
I was not able to reproduce the problem mentioned in Comment #2.

Besides that, it seems like the join process for Linux Mint is the same as for Ubuntu. Thus I just created a link for the Linux Mint join module, that points to the Ubuntu join module's script. I have tested the join process successfully with these distributions:
Linux Mint 18.3 Xfce
Linux Mint 19 Xfce
Linux Mint 19 Mate
Linux Mint 19 Cinnamon

univention-domain-join (1.0-15ubuntu4 / ubuntu14.04)
99b437ad1821 | Bug #46965: Add Support for Linux Mint

univention-domain-join (1.0-15ubuntu3 / ubuntu16.04)
84a202acdd85 | Bug #46965: Add Support for Linux Mint

univention-domain-join (1.0-15ubuntu2 / ubuntu17.10)
6ac2cbfc69b8 | Bug #46965: Add Support for Linux Mint

univention-domain-join (1.0-16ubuntu1 / ubuntu18.04)
34427b48375e | Bug #46965: Add Support for Linux Mint
Comment 4 Arvid Requate univentionstaff 2018-07-12 20:16:27 CEST
Ok. Signed and uploaded.