Bug 46967 - Import Debian-Jessie 8.10 unmaintained packages
Import Debian-Jessie 8.10 unmaintained packages
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: General
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-4
Assigned To: Philipp Hahn
Erik Damrose
:
Depends on:
Blocks: ucs424meta
  Show dependency treegraph
 
Reported: 2018-05-07 14:00 CEST by Philipp Hahn
Modified: 2018-05-15 15:57 CEST (History)
0 users

See Also:
What kind of report is it?: Release Management
What type of bug is this?: 2: Improvement: Would be a product improvement
Who will be affected by this bug?: 3: Will affect average number of installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.069
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Release Goal, Security
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Hahn univentionstaff 2018-05-07 14:00:06 CEST
All pending Debian-Jessie 8.10 packages, which are unmaintained in UCS, should be imported for the UCS-4.2-4 point release. (the maintained packages go through our errata process and imported that way)
Comment 1 Philipp Hahn univentionstaff 2018-05-07 16:26:02 CEST
The following binNMUs were skipped as they fixed Debian-only issues:
 pam: i386!=amd64 multiarch
 libnss-ldap: Rebuild with newer hardening flags
 fetchmail: Rebuild with newer hardening flags


dpkg-deb --fsys-tarfile /mnt/build-storage/upstream/debian/pool/main/p/pam/libpam0g_1.1.8-3.1+deb8u2+b1_amd64.deb | tar xfO - --wildcards ./usr/share/doc/*/changelog.Debian.amd64.gz  | gzip -dc

dpkg-deb --fsys-tarfile /mnt/build-storage/upstream/debian/pool/main/libn/libnss-ldap/libnss-ldap_265-3+b1_amd64.deb | tar xfO - --wildcards ./usr/share/doc/*/changelog.Debian.amd64.gz  | gzip -dc

dpkg-deb --fsys-tarfile /mnt/build-storage/upstream/debian/pool/main/f/fetchmail/fetchmail_6.3.26-1+b1_amd64.deb | tar xfO - --wildcards ./usr/share/doc/*/changelog.Debian.amd64.gz  | gzip -dc
Comment 2 Philipp Hahn univentionstaff 2018-05-09 15:41:53 CEST
[4.2-4] a730224ddd Bug #46967 4.2-4: Import Debian 8.10 unmaintained
[4.2-4] d512370081 Bug #46967 4.2-4: Update changelog

According to <http://jenkins.knut.univention.de:8080/job/UCS-4.2/job/CheckDebianUpdates/lastBuild/consoleFull> all packages are now imported:

4 thunderbird None1:52.7.0-1~deb8u1
  it is imported but not detected as such - have to investigate "debmirror"

4 fetchmail   6.3.26-1A~4.2.0.201703011314+b1
4 libnss-ldap 265-3A~4.2.0.201703031809+b1
4 pam         1.1.8-3.1+deb8u2A~4.2.0.201708031837+b1
  see #comment1
Comment 3 Erik Damrose univentionstaff 2018-05-14 15:43:56 CEST
OK: packages available in 4.2-4
OK: update test
OK: changelog a730224ddd806385613ef80a3fd8dbdc411343eb
Verified
Comment 4 Erik Damrose univentionstaff 2018-05-15 15:57:53 CEST
UCS 4.2-4 has been released.