Bug 47187 - univention-app install $app chooses impossible Apps
univention-app install $app chooses impossible Apps
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: App Center
UCS 4.3
Other Linux
: P5 normal (vote)
: UCS 4.3-1-errata
Assigned To: Dirk Wiesenthal
Felix Botner
:
Depends on:
Blocks: 47207
  Show dependency treegraph
 
Reported: 2018-06-13 14:56 CEST by Dirk Wiesenthal
Modified: 2018-06-20 13:37 CEST (History)
2 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 4: Minor Usability: Impairs usability in secondary scenarios
Who will be affected by this bug?: 1: Will affect a very few installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.046
Enterprise Customer affected?:
School Customer affected?: Yes
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Wiesenthal univentionstaff 2018-06-13 14:56:35 CEST
When using
  univention-app install ucsschool
it may be that the version chosen by the command line parser cannot be installed. The installation routine realizes this and aborts the installation.

Yet, this may be regarded as a usability issue because an "impossible" version was chosen in the first place.

In fact, it stops us from releasing the 4.3 Docker Apps to UCS 4.2 because the command line would then find 4.3/ucsschool.

We could filter those App versions. The CLI should probably still allow any App to be found (and eventually be rejected), but the "default App" should not be one from another UCS version.

On a side note, on a UCS 4.2, this works around the issue:
  univention-app install 4.2/ucsschool

The point of this bug is that this workaround should not be necessary.

Note that the UMC module is not affected.
Comment 1 Dirk Wiesenthal univentionstaff 2018-06-18 19:13:30 CEST
We need to clone this Bug für 4.3-0, 4.2-3, 4.2-4 as soon as this is VERIFIED
Comment 2 Dirk Wiesenthal univentionstaff 2018-06-19 14:38:57 CEST
Fixed in
  univention-appcenter 7.0.2-2A~4.3.0.201806191436

univention-app install ucsschool
  now only considers 4.3

Note that it will be released for 4.3-0, 4.3-1
Comment 3 Felix Botner univentionstaff 2018-06-19 16:30:27 CEST
OK - yaml
OK - univention-appcenter
Comment 4 Arvid Requate univentionstaff 2018-06-20 13:37:37 CEST
<http://errata.software-univention.de/ucs/4.3/114.html>