Bug 47194 - UCS 4.3-1 base system installation fails
UCS 4.3-1 base system installation fails
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: System setup
UCS 4.3
Other Linux
: P5 normal (vote)
: UCS 4.3-1-errata
Assigned To: Philipp Hahn
Felix Botner
:
: 44430 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-06-14 16:46 CEST by Felix Botner
Modified: 2018-10-04 14:28 CEST (History)
2 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 6: Setup Problem: Issue for the setup process
Who will be affected by this bug?: 1: Will affect a very few installed domains
How will those affected feel about the bug?: 5: Blocking further progress on the daily work
User Pain: 0.171
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number: 2018081621000946
Bug group (optional):
Max CVSS v3 score:


Attachments
setup.log (43.31 KB, text/x-log)
2018-06-14 16:47 CEST, Felix Botner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Botner univentionstaff 2018-06-14 16:46:34 CEST
see http://jenkins.knut.univention.de:8080/job/UCS-4.3/job/UCS-4.3-1/job/Installation%20Tests/mode=samba-env/ws/screenshots/error.png

my manual base installation test also failed with the above error message
Comment 1 Felix Botner univentionstaff 2018-06-14 16:47:33 CEST
Created attachment 9557 [details]
setup.log
Comment 2 Felix Botner univentionstaff 2018-06-14 16:55:10 CEST
W should fix this asap, this breaks the install tests.
Comment 3 Philipp Hahn univentionstaff 2018-06-21 08:23:12 CEST
import logging
logging.basicConfig(lebel=logging.DEBUG)
from univention.lib.package_manager import PackageManager
self = PackageManager()
self.autoremove()


# LANG=C dpkg --audit
The following packages are only half configured, probably due to problems
configuring them the first time.  The configuration should be retried using
dpkg --configure <package> or the configure menu option in dselect:
 docker.io            Linux container runtime

The following packages have been triggered, but the trigger processing
has not yet been done.  Trigger processing can be requested using
dselect or dpkg --configure --pending (or dpkg --triggers-only):
 fontconfig           generic font configuration library - support binaries
 libc-bin             GNU C Library: Binaries
 python-support       automated rebuilding support for Python modules
 udev                 /dev/ and hotplug management daemon

# less /var/log/apt/term.log
...
Entfernen von docker.io (1.13.1-0ubuntu6A~4.3.0.201803131344) ...
Running in chroot, ignoring request.
Stopping Docker: dockerNo process in pidfile '/var/run/docker-ssd.pid' found running; none killed.
invoke-rc.d: initscript docker, action "stop" failed.
dpkg: Fehler beim Bearbeiten des Paketes docker.io (--remove):
 Unterprozess installiertes pre-removal-Skript gab den Fehlerwert 1 zurück
dpkg: Fehler beim Aufräumen:
Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück


This happens during installation in the "chroot" environment:
- outside busybox is used as PID-1=init, so "systemd" is not running.
- this leads to "/etc/inid.d/docker" being used.
- inside the environment "/usr/sbin/policy-rc.d" preventing starting any services, so "dockerd" is not running and no PID file xists.
- the stop action does not use "--oknodo":
> start-stop-daemon --stop --pidfile "$DOCKER_SSD_PIDFILE" --retry 10
> log_end_msg $?
- that 1 is treated as an error, which aborts docker.io.postinst, which aborts USS.

By Debian policy any init.d script must handle the situation where an already stopped service is told to stop again gracefully.

Even better would not to install the docker.io package until it is required.

This can be fixed earliest with the next DVD, e.g UCS-4.3-2

repo_admin.py --cherrypick -p docker.io -r 4.3 --releasedest 4.3 --dest errata4.3-1

r18183 | Bug #47194: fix /etc/init.d/docker stop

Package: docker.io
Version: 1.13.1-0ubuntu6A~4.3.1.201806191947
Version: 1.13.1-0ubuntu6A~4.3.1.201806192203
Branch: ucs_4.3-0
Scope: errata4.3-1

[4.3-1] 1ec7e660da Bug #47194: docker.io YAML
 doc/errata/staging/docker.io.yaml | 14 ++++++++++++++
 1 file changed, 14 insertions(+)

OK:
 isoinfo -R -f -i /var/univention/buildsystem2/isotests/ucs_4.3-1-latest-amd64.iso  | grep docker.io
/amd64/docker.io_1.13.1-0ubuntu6A~4.3.1.201806192203_amd64.deb


ucs_4.3-1-20180619-224601-dvd-amd64.iso
Comment 4 Felix Botner univentionstaff 2018-06-21 12:37:59 CEST
OK - basesystem installation
OK - yaml
Comment 5 Felix Botner univentionstaff 2018-06-22 12:04:14 CEST
I can't start containers after the update of docker.io (until i restart the docker daemon)

-> docker run --rm debian uname -a
Linux 8ada045b82cd 4.9.0-6-amd64 #1 SMP Debian 4.9.88-1+deb9u1 (2018-05-07) x86_64 GNU/Linux

install docker.io update

Holen:1 http://192.168.0.10/build2 ucs_4.3-0-errata4.3-1/amd64/ docker.io 1.13.1-0ubuntu6A~4.3.1.201806192203 [17,1 MB

-> docker run --rm debian uname -a
container_linux.go:247: starting container process caused "process_linux.go:334: running prestart hook 0 caused \"fork/exec /usr/bin/dockerd (deleted): no such file or directory\""
docker: Error response from daemon: oci runtime error: container_linux.go:247: starting container process caused "process_linux.go:334: running prestart hook 0 caused \"fork/exec /usr/bin/dockerd (deleted): no such file or directory\"".
ERRO[0000] error getting events from daemon: context canceled 

-> service docker  restart
-> docker run --rm debian uname -a
Linux 5c4a69042fcc 4.9.0-6-amd64 #1 SMP Debian 4.9.88-1+deb9u1 (2018-05-07) x86_64 GNU/Linux

=> better restart dockerd during the update?
Comment 6 Philipp Hahn univentionstaff 2018-06-22 15:08:38 CEST
r18185 | Bug #47194: Restart dockerd after upgrade

Package: docker.io
Version: 1.13.1-0ubuntu6A~4.3.1.201806221455
Branch: ucs_4.3-0
Scope: errata4.3-1

pidof dockerd # 23851
apt-get -q install docker.io=1.13.1-0ubuntu6A~4.3.1.201806221455
pidof dockerd # 23083
docker ps
Comment 7 Felix Botner univentionstaff 2018-06-25 12:51:36 CEST
OK
Comment 8 Erik Damrose univentionstaff 2018-06-27 14:37:27 CEST
<http://errata.software-univention.de/ucs/4.3/117.html>
Comment 9 Felix Botner univentionstaff 2018-07-17 10:15:07 CEST
*** Bug 44430 has been marked as a duplicate of this bug. ***
Comment 10 Johannes Keiser univentionstaff 2018-10-04 14:28:49 CEST
External feedback: Version: 4.3-1 errata202 (Neustadt)

Configuring server role: Autoremove failed

Role: basesystem