Bug 47511 - postgresql-common: Multiple issues (4.3)
postgresql-common: Multiple issues (4.3)
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Security updates
UCS 4.3
All Linux
: P5 normal (vote)
: UCS 4.3-1-errata
Assigned To: Quality Assurance
Philipp Hahn
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-08-08 13:47 CEST by Quality Assurance
Modified: 2018-08-15 13:14 CEST (History)
0 users

See Also:
What kind of report is it?: Security Issue
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score: 0.0 ()


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Quality Assurance univentionstaff 2018-08-08 13:47:43 CEST
New Debian postgresql-common 181+deb9u2A~4.3.1.201808081329 fixes:
This update addresses the following issue(s):
* 

181+deb9u2 (Fri, 08 Jun 2018 11:16:28 +0200) * maintscripts-functions: Use 'deb-systemd-invoke stop "postgresql@$ver-*"' to prevent upgrading/removing server packages from stopping other major version clusters when running systemd. (Use deb-systemd-invoke instead of invoke-rc.d; jessie's invoke-rc.d does not support service patterns.)
Comment 1 Quality Assurance univentionstaff 2018-08-08 19:10:06 CEST
--- mirror/ftp/4.3/unmaintained/4.3-0/source/postgresql-common_181+deb9u1A~4.3.0.201711221953.dsc
+++ apt/ucs_4.3-0-errata4.3-1/source/postgresql-common_181+deb9u2A~4.3.1.201808081329.dsc
@@ -1,8 +1,16 @@
-181+deb9u1A~4.3.0.201711221953 [Wed, 22 Nov 2017 19:59:00 +0100] Univention builddaemon <buildd@univention.de>:
+181+deb9u2A~4.3.1.201808081329 [Wed, 08 Aug 2018 13:47:48 +0200] Univention builddaemon <buildd@univention.de>:
 
   * UCS auto build. The following patches have been applied to the original source package
     01-autostart-setting
     02-emit-supported-postgresql-versions
+
+181+deb9u2 [Fri, 08 Jun 2018 11:16:28 +0200] Christoph Berg <christoph.berg@credativ.de>:
+
+  * maintscripts-functions: Use 'deb-systemd-invoke stop "postgresql@$ver-*"'
+    to prevent upgrading/removing server packages from stopping other major
+    version clusters when running systemd. (Closes: #809811)
+    (Use deb-systemd-invoke instead of invoke-rc.d; jessie's invoke-rc.d does
+    not support service patterns.)
 
 181+deb9u1 [Tue, 07 Nov 2017 20:54:52 +0100] Christoph Berg <myon@debian.org>:
 

<http://10.200.17.11/4.3-1/#7433013409213650989>
Comment 2 Philipp Hahn univentionstaff 2018-08-09 08:57:56 CEST
OK: patches
OK: piuparts
OK: yaml
OK: errata-announce postgresql-common.yaml

[4.3-1] 9ec0fc5a16 Bug #47511: postgresql-common 181+deb9u2A~4.3.1.201808081329
 doc/errata/staging/postgresql-common.yaml | 13 +++++++++++++
 1 file changed, 13 insertions(+)
Comment 3 Arvid Requate univentionstaff 2018-08-15 13:14:53 CEST
<http://errata.software-univention.de/ucs/4.3/191.html>