Bug 47808 - New firefox 60.2.0esr-1~deb9u2 breaks UCS installation and Appliance Tests
New firefox 60.2.0esr-1~deb9u2 breaks UCS installation and Appliance Tests
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UCS Installer
UCS 4.3
Other Linux
: P5 normal (vote)
: UCS 4.3-2-errata
Assigned To: Jürn Brodersen
Erik Damrose
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-09-13 12:12 CEST by Felix Botner
Modified: 2018-09-26 13:24 CEST (History)
3 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 6: Setup Problem: Issue for the setup process
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 5: Blocking further progress on the daily work
User Pain: 0.343
Enterprise Customer affected?:
School Customer affected?:
ISV affected?: Yes
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
app appliance setup (41.13 KB, image/png)
2018-09-17 14:48 CEST, Felix Botner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Botner univentionstaff 2018-09-13 12:12:24 CEST
The installer starts but after installing the base system, i get a black screen (UMC setup expected at this point)

i see lots of these message

GFX1: Failed to lock new back buffer.

All installation tests are broken until this is fixed.
Comment 1 Felix Botner univentionstaff 2018-09-13 12:14:43 CEST
Firefox works as expected after i reboot the machine, so i guess the appliances are not affected.
Comment 2 Jürn Brodersen univentionstaff 2018-09-13 16:04:46 CEST
The problem is that /dev/shm isn't created and mounted with tmpfs.
I can reproduce that firefox works again with a mounted /dev/shm.

Afaik it is mounted through /usr/lib/tmpfiles.d/debian.conf which is handled by systemd which is not active in the debian installer.

Firefox 52esr doesn't seem to need /dev/shm.

https://bugzilla.mozilla.org/show_bug.cgi?format=default&id=1450169
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=887973
Comment 3 Felix Botner univentionstaff 2018-09-17 14:48:53 CEST
Created attachment 9677 [details]
app appliance setup

Also, the "do not show tabs" plugin seems to be broken now, this breaks the app appliance tests.
Comment 4 Felix Botner univentionstaff 2018-09-19 09:54:07 CEST
i have de-activated the UCS 4.3-2 Install Tests, please re-activate if this is fixed.
Comment 5 Felix Botner univentionstaff 2018-09-20 18:11:14 CEST
with something like this

--- a/base/univention-system-setup/debian/di-univention-system-setup.postinst
+++ b/base/univention-system-setup/debian/di-univention-system-setup.postinst
@@ -67,6 +67,10 @@ fi
 
 # start univention-system-setup if in GTK mode
 if [ -n "$DISPLAY" ]; then
+       mkdir -p /dev/shm
+       mkdir -p /target/dev/shm
+       mount -t tmpfs tmpfs /dev/shm
+       mount --bind /dev/shm /target/dev/shm
        chroot /target /usr/share/univention-system-setup/startxwithfirefox --installer
 else
        db_progress SET 4

the firefox works
Comment 6 Jürn Brodersen univentionstaff 2018-09-21 10:44:53 CEST
[4.3-2 95b88e7b63] Bug #47808: Adapt setup for firefox 60
[4.3-2 82a1ecc92e] Bug #47808: remove addon folder from install
[4.3-2 62f23e9b9a] Bug #47808: Fix mounting /dev/shm
[4.3-2 59432f41ed] Bug #47808: YAML

Installer tests are activated again.
Comment 7 Erik Damrose univentionstaff 2018-09-24 15:30:25 CEST
OK: Browser Addon removed
OK: userPref for fullscreen mode
OK: FF in debian installer
OK: FF in appliance mode
OK: yaml
Verified
Comment 8 Erik Damrose univentionstaff 2018-09-26 13:24:49 CEST
<http://errata.software-univention.de/ucs/4.3/245.html>