Bug 47872 - Regression: Changed default category ordering on domain portal
Regression: Changed default category ordering on domain portal
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Portal
UCS 4.3
Other Mac OS X 10.1
: P5 normal (vote)
: UCS 4.3-2-errata
Assigned To: Johannes Keiser
Ole Schwiegert
:
: 48077 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-09-27 11:53 CEST by Erik Damrose
Modified: 2018-11-14 14:40 CET (History)
5 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 5: Major Usability: Impairs usability in key scenarios
Who will be affected by this bug?: 5: Will affect all installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.286
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
Wrong category ordering on domain portal (384.02 KB, image/png)
2018-09-27 11:53 CEST, Erik Damrose
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Damrose univentionstaff 2018-09-27 11:53:01 CEST
Created attachment 9683 [details]
Wrong category ordering on domain portal

Since 4.3-2e250 (Bug #47243), when the first app is installed on UCS, the app category will be displayed below the adminstration category on the domain portal. 

Updated systems with at least one app installed will have the correct order (as the services category was not empty while updating), this applies to new installations.

+++ This bug was initially created as a clone of Bug #47243 +++
Comment 1 Johannes Keiser univentionstaff 2018-10-30 11:56:25 CET
Another problem:

The creation of the univentionblog portal_entry object when installing or upgrading UCS causes the univentionblog portal_entry to be before the UMC portal_entry + overwriting previously saved ordering of portal_entry objects.

- Which portal_entry object is shown on which portal is no longer
  determined via the 'portal' property of settings/portal_entry
  but via the 'content' property of settings/portal.
- In univention-portal.postinst all settings/portal_entry
  entry objects are mapped to the 'content' property of all settings/portal
  objects accordingly (while respecting the 'portalEntriesOrder' property of
  settings/portal).
- But before univention-portal.postinst runs,
  univention-portal.univention-config-registry is installed,
  creating the 'univentionblog' portal entry (if applicable),
  causing 'portalEntriesOrder' to be overwritten,
  breaking the mapping of the previous point.
Comment 2 Johannes Keiser univentionstaff 2018-10-30 12:04:32 CET
86b81054fd Bug #47872: prevent 'Applications' category being before 'Administration' category in the portal
9789cd6350 Bug #47872: prevent univentionblog entry overwriting portalEntriesOrder
48e6e375b9 Bug #47872: Debian changelog entries
0c30159434 Bug #47872: YAML - add entries
7af2a1cd3a Bug #47872: Merge branch 'jkeiser/4.3-2/47872/portal_ordering' into 4.3-2
a449b7ae3e Bug #47872: YAML - update version

Successful build
Package: univention-directory-manager-modules
Version: 13.0.25-7A~4.3.0.201810301158

Successful build
Package: univention-portal
Version: 2.0.2-13A~4.3.0.201810301200
Comment 3 Erik Damrose univentionstaff 2018-11-01 16:58:04 CET
*** Bug 48077 has been marked as a duplicate of this bug. ***
Comment 4 Ole Schwiegert univentionstaff 2018-11-07 08:55:16 CET
Advisory & Changelog: OK
Package installs: OK

Tested with Upgrade from 4.3-2e234 to 4.3-2e298+testing Repo

Old portal with only UMC entry. App install after upgrade: OK
Old portal with only UMC entry. App install before upgrade: OK
Old portal with UMC + custom Entry. App install after upgrade: OK

Categories and the univentionblog entry behave like before. Machines already on an errata level of >=250 cannot benefit from the fix anymore.