Bug 49129 - Migrate base/univention-config-registry to dh_python2
Migrate base/univention-config-registry to dh_python2
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: General
UCS 4.4
All Linux
: P5 normal (vote)
: UCS 4.4-0-errata
Assigned To: Florian Best
Philipp Hahn
:
Depends on: 49665 49136
Blocks: 28497
  Show dependency treegraph
 
Reported: 2019-03-28 10:25 CET by Florian Best
Modified: 2019-07-11 15:11 CEST (History)
2 users (show)

See Also:
What kind of report is it?: Development Internal
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2019-03-28 10:25:26 CET
The package base/univention-config-registry should be migrated to use dh_python instead of python-support.

Migration-Guide: https://hutten.knut.univention.de/mediawiki/index.php/Python_DebHelper_Migration
Comment 1 Florian Best univentionstaff 2019-04-04 15:19:33 CEST
Depdends on:
services/univention-support-info/univention-support-info:»   if os.path.isfile('/usr/share/pyshared/univention/config_registry.py'):
services/univention-support-info/univention-support-info:»   »   config_registry = imp.load_source('config_registry', '/usr/share/pyshared/univention/config_registry.py')
services/univention-support-info/univention-support-info:»   »   sys.path.append('/usr/share/pyshared')
Comment 2 Florian Best univentionstaff 2019-04-16 09:56:11 CEST
Depends on:

base/univention-bootsplash/univention-welcome-screen:»   PYTHONPATH=/usr/lib/pymodules/python2.7/univention/config_registry python2.7 2>/dev/null \
base/univention-lib/shell/base.sh:»   PYTHONPATH=/usr/lib/pymodules/python2.7/univention/config_registry python2.7 2>/dev/null
Comment 3 Florian Best univentionstaff 2019-05-21 12:41:34 CEST
Fixed dependency already:
Package: univention-bootsplash
Version: 10.0.0-3A~4.4.0.201905211238

The rest is currently in the branch: dh-python/49129-univention-config-registry-2
I will merge tomorrow because I hope we are releasing univention-lib tomorrow.
Comment 4 Florian Best univentionstaff 2019-06-03 19:04:45 CEST
Added some more commits which add more python 3 compatibility, so that ucr filter and ucr set works.

univention-config-registry (14.0.0-5)
a567d5fdd66b | Bug #49129: Merge branch 'dh-python/49129-univention-config-registry-2' into 4.4-0
b404923da175 | Bug #49129: migrate package to dh_python2

univention-bootsplash.yaml
650ca9cf98d2 | YAML Bug #49129
1ada9f425a40 | Bug #49129: fix python path

univention-config-registry (14.0.0-6)
a2f42f8a492f | Bug #49129: fix version dependencies
53704f5e6ae9 | Bug #49129: Fix setting or UCR variables
11ab3f9b977b | Bug #49129: python3 compatibility: next()

univention-config-registry (14.0.0-4)
04e6e6d757e8 | Bug #49129: fix decoding of arguments
d450bae9d5ef | Bug #49129: fix missing flush() method
4e93b1639b8d | Bug #49129: configparser import
4b20289b7d0b | Bug #49129: fix wrong variable reference
20c295676b6d | Bug #49129: fix access to univention.config_registry.interfaces
a84bf95cd0c8 | Bug #49129: fix tab indentation
9b1669ee5f41 | Bug #49129: s/cPickle/pickle/g
470ac9d8805b | Bug #49129: futurize -nw --no-diffs -f libfuturize.fixes.fix_print_with_import .
337716b8ff96 | Bug #49129: migrate univention-config-registry to dh_python2

univention-bootsplash (10.0.0-3)
1ada9f425a40 | Bug #49129: fix python path

univention-lib (8.0.1-21)
a567d5fdd66b | Bug #49129: Merge branch 'dh-python/49129-univention-config-registry-2' into 4.4-0
b404923da175 | Bug #49129: migrate package to dh_python2

univention-lib (8.0.1-20)
20c295676b6d | Bug #49129: fix access to univention.config_registry.interfaces

univention-lib.yaml
a567d5fdd66b | Bug #49129: Merge branch 'dh-python/49129-univention-config-registry-2' into 4.4-0
b404923da175 | Bug #49129: migrate package to dh_python2

univention-config-registry.yaml
a567d5fdd66b | Bug #49129: Merge branch 'dh-python/49129-univention-config-registry-2' into 4.4-0
b404923da175 | Bug #49129: migrate package to dh_python2
Comment 5 Florian Best univentionstaff 2019-06-17 18:50:57 CEST
Merged more changes:

univention-config-registry (14.0.0-8)
ef98f1ef3b17 | Bug #49129: Merge branch 'phahn/49129-ucr-python2' into 4.4-0
c7238d553f88 | Bug #49129 ucr: py3: Use Unicode API
05731f8b1d8b | Bug #49129 ucr: mypy: Add missing type check
47168af0f03d | Bug #49129 ucr: mypy: Fix None dereference
1f998c4f285d | Bug #49129 ucr: mypy: Fix return type
b24a79a04aec | Bug #49129 ucr: mypy: Fix invalid regular expression pattern
217b21dd8f6e | Bug #49129 ucr: mypy: Fix constant declarations
0eb853b3dce3 | Bug #49129 ucr: mypy: Fix locking
174f1331fc25 | Bug #49129 ucr: Add mypy type annotations
3c3a0d69084b | Bug #49129 ucr: flake8: Fix unused variable
05446b800f83 | Bug #49129 ucr: flake8: Catch Exception
04db3056e277 | Bug #49129 ucr: Add/update Python DocStrings
a9bb133094d0 | Bug #49129 ucr: Replace Output handling
583f68a05990 | Bug #49129 ucr: Remove unused shell handler
f166876a5832 | Bug #49129 ucr: Use functools.wraps
6086e3077cb9 | Bug #49129 ucr: Define layer priority
cd2c08502354 | Bug #49129 ucs: Join long lines
9561603df5d1 | Bug #49129 ucs: Move __future__ import from header
ba2154e32f9f | Bug #49129 ucs: Fix warning in unit test
9cd4fe03c3dc | Bug #49129 ucr: py3: Fix configparser
85c443999f96 | Bug #49129 ucs: py3: Fix package build and Python3 dependency
Comment 6 Philipp Hahn univentionstaff 2019-06-24 08:44:03 CEST
OK: ucs-test -s base
OK: python3 /usr/sbin/ucr shell dump get info
OK: ( . /usr/share/univention-lib/ucr.sh  ; is_ucr_true xorg/autodetect ; echo $?)
OK: (. /usr/share/univention-lib/base.sh ; get_default_ip_address )
~FAIL: python3-univention-lib -> python3-ldb python3-samba
 Currently there are no Python3 modules for Samba, so the module remains uninstallable.
OK: univention-welcome-screen

OK: Code review
OK: git grep usr/lib/pymodules/python2.7/univention/config
OK: git grep usr/share/pyshared/univention/config
OK: gitlog 'Bug #49129'

OK: errata-announce -V --only univention-lib.yaml univention-config-registry.yaml  univention-bootsplash.yaml
OK: yaml
Comment 8 Florian Best univentionstaff 2019-07-11 15:11:30 CEST
This caused the regression in Bug #49775.