Bug 49170 - Migrate services/univention-celery to dh_python2
Migrate services/univention-celery to dh_python2
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: General
UCS 4.4
All Linux
: P5 normal (vote)
: UCS 4.4-3-errata
Assigned To: Florian Best
UCS maintainers
:
Depends on:
Blocks: 28497
  Show dependency treegraph
 
Reported: 2019-03-28 10:27 CET by Florian Best
Modified: 2019-12-11 16:49 CET (History)
1 user (show)

See Also:
What kind of report is it?: Development Internal
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:
best: Patch_Available+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2019-03-28 10:27:38 CET
The package services/univention-celery should be migrated to use dh_python instead of python-support.

Migration-Guide: https://hutten.knut.univention.de/mediawiki/index.php/Python_DebHelper_Migration
Comment 1 Florian Best univentionstaff 2019-11-12 14:48:13 CET
Patch available in git:dh-python/services
Comment 2 Florian Best univentionstaff 2019-12-03 16:47:45 CET
As discussed with Daniel, the python code is ununsed. Therefore it has been removed.

univention-celery (3.0.0-2)
e43f60ced003 | Bug #49170: remove unused file
9bdb234a1df9 | Bug #49170: remove unused python package
Comment 3 Florian Best univentionstaff 2019-12-03 16:54:44 CET
univention-celery.yaml
d6b5b0e42851 | YAML Bug #49170
Comment 4 Johannes Keiser univentionstaff 2019-12-06 11:17:17 CET
OK: code changes
OK: upgrade
OK: dpk
OK: YAML
-> verified
Comment 5 Erik Damrose univentionstaff 2019-12-11 16:49:37 CET
<http://errata.software-univention.de/ucs/4.4/393.html>