Bug 50062 - apache2: Multiple issues (4.3)
apache2: Multiple issues (4.3)
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Security updates
UCS 4.3
All Linux
: P3 normal (vote)
: UCS 4.3-4-errata
Assigned To: Quality Assurance
Philipp Hahn
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-08-27 13:16 CEST by Philipp Hahn
Modified: 2019-08-28 16:20 CEST (History)
0 users

See Also:
What kind of report is it?: Security Issue
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score: 7.5 (CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Hahn univentionstaff 2019-08-27 13:16:43 CEST
New Debian apache2 2.4.25-3+deb9u8A~4.3.1.201908270838 fixes:
This update addresses the following issues:
* request for large response leads to denial of service (CVE-2019-9517)
* memory corruption on early pushes (CVE-2019-10081)
* read-after-free in h2 connection shutdown (CVE-2019-10082)
* limited cross-site scripting in mod_proxy error page (CVE-2019-10092)
* mod_rewrite potential open redirect (CVE-2019-10098)
Comment 1 Quality Assurance univentionstaff 2019-08-27 15:20:52 CEST
--- mirror/ftp/4.3/unmaintained/4.3-4/source/apache2_2.4.25-3+deb9u7A~4.3.3.201904051131.dsc
+++ apt/ucs_4.3-0-errata4.3-4/source/apache2_2.4.25-3+deb9u8A~4.3.4.201908270838.dsc
@@ -1,9 +1,20 @@
-2.4.25-3+deb9u7A~4.3.3.201904051131 [Fri, 05 Apr 2019 11:31:48 +0200] Univention builddaemon <buildd@univention.de>:
+2.4.25-3+deb9u8A~4.3.4.201908270838 [Tue, 27 Aug 2019 13:14:27 +0200] Univention builddaemon <buildd@univention.de>:
 
   * UCS auto build. The following patches have been applied to the original source package
     05-autostart-setting
     10-apache2-reload
     20-no-proxy
+
+2.4.25-3+deb9u8 [Mon, 19 Aug 2019 21:25:31 +0200] Stefan Fritsch <sf@debian.org>:
+
+  [ Xavier Guimard ]
+  * Add patch to limit cross-site scripting in mod_proxy (Closes: CVE-2019-10092)
+  * Import http2 modules from 2.4.41 (Closes: CVE-2019-9517, CVE-2019-10082, CVE-2019-10081)
+  * Add patch to set PCRE_DOTALL by default (Closes: CVE-2019-10098)
+
+  [ Stefan Fritsch ]
+  * Add -Werror=implicit-function-declaration to compile options to catch
+    problems with backports.
 
 2.4.25-3+deb9u7 [Tue, 02 Apr 2019 21:05:13 +0200] Stefan Fritsch <sf@debian.org>:
 

<http://10.200.17.11/4.3-4/#6930132208258679400>
Comment 2 Philipp Hahn univentionstaff 2019-08-27 16:13:04 CEST
OK: yaml
OK: announce_errata
OK: patch
OK: piuparts

[4.3-4] d8388b9692 Bug #50062: apache2 2.4.25-3+deb9u8A~4.3.4.201908270838
 doc/errata/staging/apache2.yaml | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

[4.3-4] 9820e6fb34 Bug #50062: apache2_2.4.25-3+deb9u8A~4.3.1.201908270838
 doc/errata/staging/apache2.yaml | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
Comment 3 Erik Damrose univentionstaff 2019-08-28 16:20:56 CEST
<http://errata.software-univention.de/ucs/4.3/566.html>