Bug 50164 - glib2.0: Multiple issues (4.3)
glib2.0: Multiple issues (4.3)
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Security updates
UCS 4.3
All Linux
: P3 normal (vote)
: UCS 4.3-4-errata
Assigned To: Quality Assurance
Philipp Hahn
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-09-09 16:03 CEST by Quality Assurance
Modified: 2019-09-11 15:56 CEST (History)
0 users

See Also:
What kind of report is it?: Security Issue
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score: 8.1 (CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Quality Assurance univentionstaff 2019-09-09 16:03:01 CEST
New Debian glib2.0 2.50.3-2+deb9u1 fixes:
This update addresses the following issues:
* Out-of-bounds read in g_markup_parse_context_parse() in gmarkup.c  (CVE-2018-16429)
* file_copy_fallback in gio/gfile.c in GNOME GLib does not properly restrict  file permissions while a copy operation is in progress (CVE-2019-12450)
* insecure permissions for files and directories (CVE-2019-13012)
Comment 1 Quality Assurance univentionstaff 2019-09-09 17:00:46 CEST
--- mirror/ftp/4.3/unmaintained/4.3-0/source/glib2.0_2.50.3-2.dsc
+++ apt/ucs_4.3-0-errata4.3-4/source/glib2.0_2.50.3-2+deb9u1.dsc
@@ -1,3 +1,23 @@
+2.50.3-2+deb9u1 [Tue, 13 Aug 2019 10:46:20 +0100] Simon McVittie <smcv@debian.org>:
+
+  * Team upload
+  * d/gbp.conf: Add GNOME team configuration
+  * d/p/gfile-Limit-access-to-files-when-copying.patch:
+    When copying files, give the temporary partial copy of the file
+    suitably restrictive permissions (Closes: #929753; CVE-2019-12450)
+  * d/p/keyfile-settings-Use-tighter-permissions.patch:
+    Create directory and file with restrictive permissions when using the
+    GKeyfileSettingsBackend. Mitigation: in this version of GLib, the
+    GKeyfileSettingsBackend can only be used explicitly by code, and is
+    never selected automatically. (Closes: #931234; CVE-2019-13012)
+  * d/p/gmarkup-Fix-unvalidated-UTF-8-read-in-markup-parsing-erro.patch,
+    d/p/gmarkup-Avoid-reading-off-the-end-of-a-buffer-when-non-nu.patch:
+    Avoid buffer read overrun when formatting error messages for invalid
+    UTF-8 in GMarkup (CVE-2018-16429)
+  * d/p/gmarkup-Fix-crash-in-error-handling-path-for-closing-elem.patch:
+    Avoid NULL dereference when parsing invalid GMarkup with a malformed
+    closing tag not paired with an opening tag (CVE-2018-16429)
+
 2.50.3-2 [Mon, 20 Mar 2017 00:21:57 +0100] Michael Biebl <biebl@debian.org>:
 
   * debian/patches/tests-gdatetime-Use-a-real-rather-than-invented-time.patch:

<http://10.200.17.11/4.3-4/#8842268695722649019>
Comment 2 Philipp Hahn univentionstaff 2019-09-10 11:36:38 CEST
OK: yaml
OK: announce_errata
OK: patch
OK: piuparts

[4.3-4] c39cc95942 Bug #50164: glib2.0 2.50.3-2+deb9u1
 doc/errata/staging/glib2.0.yaml | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

[4.3-4] 98ae392c78 Bug #50164: glib2.0 2.50.3-2+deb9u1
 doc/errata/staging/glib2.0.yaml | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)
Comment 3 Erik Damrose univentionstaff 2019-09-11 15:56:20 CEST
<http://errata.software-univention.de/ucs/4.3/575.html>