Bug 50196 - ownCloud upgrades fail because of Traceback: StopIteration
ownCloud upgrades fail because of Traceback: StopIteration
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: App Center
UCS 4.4
Other Linux
: P5 normal (vote)
: UCS 4.4-1-errata
Assigned To: Felix Botner
Dirk Wiesenthal
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-09-16 12:26 CEST by Nico Gulden
Modified: 2019-09-18 13:23 CEST (History)
1 user (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 5: Major Usability: Impairs usability in key scenarios
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 4: A User would return the product
User Pain: 0.229
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): External feedback
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nico Gulden univentionstaff 2019-09-16 12:26:08 CEST

    
Comment 1 Nico Gulden univentionstaff 2019-09-16 12:28:36 CEST
https://help.univention.com/t/owncloud-update-failed-from-10-0-10-to-10-2-1/12931

Traceback (most recent call last):
File “/usr/lib/python2.7/dist-packages/univention/appcenter/actions/init.py”, line 226, in call_with_namespace
result = self.main(namespace)
File “/usr/lib/python2.7/dist-packages/univention/appcenter/actions/upgrade.py”, line 81, in main
return self.do_it(args)
File “/usr/lib/python2.7/dist-packages/univention/appcenter/actions/install_base.py”, line 119, in do_it
self._do_it(app, args)
File “/usr/lib/python2.7/dist-packages/univention/appcenter/actions/docker_upgrade.py”, line 125, in _do_it
self._upgrade_image(app, args)
File “/usr/lib/python2.7/dist-packages/univention/appcenter/actions/docker_upgrade.py”, line 162, in _upgrade_image
docker.pull()
File “/usr/lib/python2.7/dist-packages/univention/appcenter/docker.py”, line 439, in pull
self._setup_yml(recreate=True)
File “/usr/lib/python2.7/dist-packages/univention/appcenter/docker.py”, line 497, in _setup_yml
ip_addresses.next() # first one for docker gateway
StopIteration


https://help.univention.com/t/cant-update-owncloud/12928

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/univention/appcenter/actions/__init__.py", line 226, in call_with_namespace
    result = self.main(namespace)
  File "/usr/lib/python2.7/dist-packages/univention/appcenter/actions/upgrade.py", line 81, in main
    return self.do_it(args)
  File "/usr/lib/python2.7/dist-packages/univention/appcenter/actions/install_base.py", line 119, in do_it
    self._do_it(app, args)
  File "/usr/lib/python2.7/dist-packages/univention/appcenter/actions/docker_upgrade.py", line 125, in _do_it
    self._upgrade_image(app, args)
  File "/usr/lib/python2.7/dist-packages/univention/appcenter/actions/docker_upgrade.py", line 162, in _upgrade_image
    docker.pull()
  File "/usr/lib/python2.7/dist-packages/univention/appcenter/docker.py", line 439, in pull
    self._setup_yml(recreate=True)
  File "/usr/lib/python2.7/dist-packages/univention/appcenter/docker.py", line 497, in _setup_yml
    ip_addresses.next()  # first one for docker gateway
StopIteration
Traceback (most recent call last):
  File "/usr/bin/univention-app", line 91, in <module>
    main()
  File "/usr/bin/univention-app", line 78, in main
    ret = args.func(args)
  File "/usr/lib/python2.7/dist-packages/univention/appcenter/actions/__init__.py", line 226, in call_with_namespace
    result = self.main(namespace)
  File "/usr/lib/python2.7/dist-packages/univention/appcenter/actions/upgrade.py", line 81, in main
    return self.do_it(args)
  File "/usr/lib/python2.7/dist-packages/univention/appcenter/actions/install_base.py", line 119, in do_it
    self._do_it(app, args)
  File "/usr/lib/python2.7/dist-packages/univention/appcenter/actions/docker_upgrade.py", line 125, in _do_it
    self._upgrade_image(app, args)
  File "/usr/lib/python2.7/dist-packages/univention/appcenter/actions/docker_upgrade.py", line 162, in _upgrade_image
    docker.pull()
  File "/usr/lib/python2.7/dist-packages/univention/appcenter/docker.py", line 439, in pull
    self._setup_yml(recreate=True)
  File "/usr/lib/python2.7/dist-packages/univention/appcenter/docker.py", line 497, in _setup_yml
    ip_addresses.next()  # first one for docker gatewa
Traceback (most recent call last):
File “/usr/bin/univention-app”, line 91, in
main()
File “/usr/bin/univention-app”, line 78, in main
ret = args.func(args)
File “/usr/lib/python2.7/dist-packages/univention/appcenter/actions/init.py”, line 226, in call_with_namespace
result = self.main(namespace)
File “/usr/lib/python2.7/dist-packages/univention/appcenter/actions/upgrade.py”, line 81, in main
return self.do_it(args)
File “/usr/lib/python2.7/dist-packages/univention/appcenter/actions/install_base.py”, line 119, in do_it
self._do_it(app, args)
File “/usr/lib/python2.7/dist-packages/univention/appcenter/actions/docker_upgrade.py”, line 125, in _do_it
self._upgrade_image(app, args)
File “/usr/lib/python2.7/dist-packages/univention/appcenter/actions/docker_upgrade.py”, line 162, in _upgrade_image
docker.pull()
File “/usr/lib/python2.7/dist-packages/univention/appcenter/docker.py”, line 439, in pull
self._setup_yml(recreate=True)
File “/usr/lib/python2.7/dist-packages/univention/appcenter/docker.py”, line 497, in _setup_yml
ip_addresses.next() # first one for docker gateway
StopIteration
Comment 3 Felix Botner univentionstaff 2019-09-16 14:46:07 CEST
Reproducible:
 * UCS 4.4-0
 * install owncloud=10.0.10-2019-02-18
 * update to 4.4-1 (without app update)
 * app update -> Traceback ip_addresses.next()

The problem is the appcenter uses the old ip value from appcenter/apps/owncloud/ip, which in this case is a address, not a network
Comment 4 Felix Botner univentionstaff 2019-09-16 15:14:39 CEST
Fixed by ignoring appcenter/apps/APPID/ip if it is a address and not a network (Docker._get_app_network()).

univention-appcenter 8.0.11-67
Comment 5 Dirk Wiesenthal univentionstaff 2019-09-16 16:12:20 CEST
OK, works great.
Comment 6 Erik Damrose univentionstaff 2019-09-18 13:23:31 CEST
<http://errata.software-univention.de/ucs/4.4/276.html>