Bug 50355 - UCS 4.3-5: computerroom/room/acquire: ldapError: Insufficient access
UCS 4.3-5: computerroom/room/acquire: ldapError: Insufficient access
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 4.3
Other Linux
: P5 normal (vote)
: UCS 4.3-5-errata
Assigned To: Florian Best
Felix Botner
:
Depends on: 46089
Blocks: 49447
  Show dependency treegraph
 
Reported: 2019-10-11 17:27 CEST by Florian Best
Modified: 2019-10-16 17:36 CEST (History)
2 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 5: Major Usability: Impairs usability in key scenarios
Who will be affected by this bug?: 4: Will affect most installed domains
How will those affected feel about the bug?: 5: Blocking further progress on the daily work
User Pain: 0.571
Enterprise Customer affected?:
School Customer affected?: Yes
ISV affected?:
Waiting Support: Yes
Ticket number: 2019092621000629
Bug group (optional): Error handling, External feedback
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2019-10-11 17:27:24 CEST
Backport to UCS 4.3-5.

+++ This bug was initially created as a clone of Bug #46089 +++

Version: 4.2-3 errata256 (Lesum) - UCS@school 4.2 v6

Die Ausführung des Kommandos computerroom/room/acquire ist fehlgeschlagen:

Traceback (most recent call last):
  File "%PY2.7%/univention/management/console/base.py", line 250, in execute
    function.__func__(self, request, *args, **kwargs)
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 192, in _response
    return function(self, request)
  File "%PY2.7%/ucsschool/lib/schoolldap.py", line 145, in wrapper_func
    return func(*args, **kwargs)
  File "%PY2.7%/univention/management/console/modules/computerroom/__init__.py", line 325, in room_acquire
    room = ComputerRoom.from_dn(roomDN, None, ldap_user_read)
  File "%PY2.7%/ucsschool/lib/models/base.py", line 853, in from_dn
    udm_obj = udm_modules.lookup(cls._meta.udm_module, None, lo, filter=cls._meta.udm_filter, base=dn, scope='base', superordinate=superordinate)[0]
  File "%PY2.7%/univention/admin/modules.py", line 732, in lookup
    tmpres = module.lookup(co, lo, filter, base=base, superordinate=superordinate, scope=scope, unique=unique, required=required, timeout=timeout, sizelimit=sizelimit)
  File "%PY2.7%/univention/admin/handlers/groups/group.py", line 1063, in lookup
    for dn, attrs in lo.search(unicode(filter), base, scope, [], unique, required, timeout, sizelimit):
  File "%PY2.7%/univention/admin/uldap.py", line 437, in search
    raise univention.admin.uexceptions.ldapError(_err2str(msg), original_exception=msg)
ldapError: Insufficient access

Role: domaincontroller_slave
Comment 1 Florian Best univentionstaff 2019-10-11 17:34:38 CEST
Backported the patch:

univention-management-console.yaml
9f6818cafcdc | YAML Bug #50355

univention-management-console (10.0.6-25)
550bcf172808 | Bug #50355: Fix "ldapError: Insufficient access" errors
Comment 2 Stefan Gohmann univentionstaff 2019-10-14 07:32:47 CEST
I increase "How will those affected feel about the bug?" because teachers are unable to start an exam.
Comment 3 Felix Botner univentionstaff 2019-10-14 15:50:43 CEST
OK - reproducible with old packages
OK - fixed with univention-management-console=10.0.6-25A~4.3.0.201910111733
OK - yaml
Comment 4 Arvid Requate univentionstaff 2019-10-16 17:36:29 CEST
<http://errata.software-univention.de/ucs/4.3/600.html>