Bug 50515 - ucs-school-import log files are empty
ucs-school-import log files are empty
Status: CLOSED FIXED
Product: UCS@school
Classification: Unclassified
Component: Import scripts
UCS@school 4.4
Other Linux
: P5 normal (vote)
: UCS@school 4.4 v4-errata
Assigned To: Daniel Tröder
Sönke Schwardt-Krummrich
:
: 50484 (view as bug list)
Depends on: 49037
Blocks:
  Show dependency treegraph
 
Reported: 2019-11-18 17:11 CET by Daniel Tröder
Modified: 2019-12-20 12:38 CET (History)
4 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 5: Major Usability: Impairs usability in key scenarios
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 3: A User would likely not purchase the product
User Pain: 0.171
Enterprise Customer affected?:
School Customer affected?: Yes
ISV affected?:
Waiting Support:
Flags outvoted after Product Owner Review:
Ticket number: 2019121621000614, 2019120421000146
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Tröder univentionstaff 2019-11-18 17:11:41 CET
A regression introduced by Bug #49037 causes the files
/var/lib/ucs-school-import/jobs/*/*/ucs-school-import.log to be created with an owner of "384", for which luckily no user account exists.
This causes the import not to write any logs into that file, as it is running as unprivileged user "uas-import".
"384" is octal for 600 which is the desired file permission for the logfile.
Comment 1 Daniel Tröder univentionstaff 2019-11-18 17:20:34 CET
Fixed in branch dtroeder/50515_logfile_ownership.

Reopen for merge and build.
Comment 2 Daniel Tröder univentionstaff 2019-11-18 17:23:57 CET
*** Bug 50484 has been marked as a duplicate of this bug. ***
Comment 3 Christina Scheinig univentionstaff 2019-12-20 09:54:49 CET
In the customer environment no password file is generated during user-import
Comment 4 Daniel Tröder univentionstaff 2019-12-20 11:21:24 CET
[4.4] 083374d5c Bug #50515: fix bad function calls leading to wrong logfile ownership
[4.4] 0defa1e30 Bug #50515: Merge branch 'dtroeder/50515_logfile_ownership' into 4.4
[4.4] ffe5f8269 Bug #50515: changelog, advisory
[4.4] dd58d14d1 Bug #50515: advisory update

ucs-school-import (17.0.21)
Comment 5 Sönke Schwardt-Krummrich univentionstaff 2019-12-20 11:40:18 CET
OK: code change
OK: functional change
OK: installation
OK: update
--: ucs-test
OK: changelog entry
OK: advisory
OK: package built and installable
Comment 6 Sönke Schwardt-Krummrich univentionstaff 2019-12-20 12:38:31 CET
UCS@school 4.4 v4 has been released.

https://docs.software-univention.de/changelog-ucsschool-4.4v4-de.html

If this error occurs again, please clone this bug.