Bug 50592 - Add command to univention-appcenter-dev to install selenium
Add command to univention-appcenter-dev to install selenium
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: App Center
UCS 4.4
Other Linux
: P5 normal (vote)
: UCS 4.4-3-errata
Assigned To: Johannes Keiser
Dirk Wiesenthal
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-12-04 15:37 CET by Johannes Keiser
Modified: 2019-12-11 16:49 CET (History)
1 user (show)

See Also:
What kind of report is it?: Development Internal
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Keiser univentionstaff 2019-12-04 15:37:17 CET
Add command that installs selenium to make it easier for app providers to
test the apps.
Comment 1 Johannes Keiser univentionstaff 2019-12-04 15:51:07 CET
3dc6b1ecf3 Bug #50592: yaml
d4121f85be Bug #50592: yaml
6c38422176 Bug #50592: debian changelog
2c38694ee7 Bug #50592: add dev-test-setup command

Successful build
Package: univention-appcenter
Version: 8.0.11-94A~4.4.0.201912041545
Comment 2 Johannes Keiser univentionstaff 2019-12-06 15:22:51 CET
a58f10fdd9 Bug #50592: yaml
c6289fda6a Bug #50592: debian changelog
fb9a25e599 Bug #50592: remove python3-pip

Successful build
Package: univention-appcenter
Version: 8.0.11-95A~4.4.0.201912061517
Comment 3 Dirk Wiesenthal univentionstaff 2019-12-06 22:20:54 CET
OK, setup works for a following
  univention-app dev-test $myapp

FYI: I found this if the newest chromium-webdriver was already installed:
  E: Packages were downgraded and -y was used without --allow-downgrades.

As this setup still works, I do not see a problem. But I do think that the explicit version number may be unnecessary.
Comment 4 Erik Damrose univentionstaff 2019-12-11 16:49:42 CET
<http://errata.software-univention.de/ucs/4.4/392.html>