Bug 25189 - object class 'umcOperationSet' requires attribute 'description'
object class 'umcOperationSet' requires attribute 'description'
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UDM (Generic)
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-1-errata
Assigned To: Florian Best
Johannes Keiser
:
: 37382 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-05 16:39 CET by Alexander Kläser
Modified: 2017-07-26 14:39 CEST (History)
2 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 3: Simply Wrong: The implementation doesn't match the docu
Who will be affected by this bug?: 1: Will affect a very few installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.034
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Ticket number:
Bug group (optional): Usability
Max CVSS v3 score:
best: Patch_Available+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kläser univentionstaff 2011-12-05 16:39:53 CET
Wird ein neues UMC-Operationset erzeugt, so ist das Feld "description" in UMC nicht als required markiert. Wird das Feld ausgelassen, so wird allerdings ein LDAP-Fehler beim Speichern angezeigt. In den Logs taucht folgende Fehlermeldung auf:

Failed to create LDAP object: ldapError: Object class violation: object class 'umcOperationSet' requires attribute 'description'
Comment 1 Florian Best univentionstaff 2016-09-24 16:08:14 CEST
*** Bug 37382 has been marked as a duplicate of this bug. ***
Comment 2 Florian Best univentionstaff 2016-09-24 16:08:45 CEST
Patch: attachment 6551 [details]
Comment 3 Florian Best univentionstaff 2017-07-12 16:42:36 CEST
univention-directory-manager-modules (12.0.17-83):                                                                                                                                                                                                                               
r81101 | Bug #25189: the description field of settings/umc_operationset is now required                                                                                                                                                                                                                                                                                                                                                                                     
univention-directory-manager-modules.yaml:                                                                                                                                                                                                                                       
r81105 | YAML Bug #36631, Bug #35074, Bug #25187, Bug #25189
Comment 4 Johannes Keiser univentionstaff 2017-07-13 16:13:25 CEST
OK Description is now marked as required
YAML: OK
-> verified
Comment 5 Erik Damrose univentionstaff 2017-07-26 14:39:03 CEST
<http://errata.software-univention.de/ucs/4.2/115.html>