Bug 36631 - python undefined name in directory-manager-modules
python undefined name in directory-manager-modules
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UDM (Generic)
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-1-errata
Assigned To: Florian Best
Johannes Keiser
:
: 32691 32933 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-13 12:35 CET by Florian Best
Modified: 2017-07-26 14:39 CEST (History)
2 users (show)

See Also:
What kind of report is it?: Development Internal
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Ticket number:
Bug group (optional): Cleanup
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2014-11-13 12:35:32 CET
./management/univention-directory-manager-modules/modules/univention/admin/handlers/container/dc.py:213: undefined name 'iself'
./management/univention-directory-manager-modules/modules/univention/admin/handlers/container/dc.py:259: undefined name 'cryptPassword'
./management/univention-directory-manager-modules/modules/univention/admin/handlers/container/dc.py:261: undefined name 'lmPassword'
./management/univention-directory-manager-modules/modules/univention/admin/handlers/container/dc.py:262: undefined name 'ntPassword'
./management/univention-directory-manager-modules/modules/univention/admin/handlers/users/user.py:1692: undefined name 'uid_list'
./management/univention-directory-manager-modules/modules/univention/admin/handlers/users/user.py:2653: undefined name 'self'
./management/univention-directory-manager-modules/modules/univention/admin/handlers/users/user.py:2654: undefined name 'self'
./management/univention-directory-manager-modules/modules/univention/admin/locking.py:73: undefined name '_'
./management/univention-directory-manager-modules/modules/univention/admin/syntax.d/example.py:1: undefined name 'select'
./management/univention-directory-manager-modules/modules/univention/admin/modules.py:524: undefined name 'pos'
./management/univention-directory-manager-modules/modules/univention/admincli/admin.py:1172: undefined name 'attribute'
./management/univention-directory-manager-modules/test/TestDnsHostRecord.py:65:4: invalid syntax
                as = ['192.168.15.15', '192.168.15.16', '0.8.1.5',]
Comment 1 Florian Best univentionstaff 2014-11-13 16:36:23 CET
*** Bug 32691 has been marked as a duplicate of this bug. ***
Comment 2 Florian Best univentionstaff 2014-11-13 16:36:53 CET
*** Bug 32933 has been marked as a duplicate of this bug. ***
Comment 3 Philipp Hahn univentionstaff 2015-12-16 17:05:19 CET
(In reply to Florian Best from comment #0)
> ./management/univention-directory-manager-modules/test/TestDnsHostRecord.py:
> 65:4: invalid syntax
>                 as = ['192.168.15.15', '192.168.15.16', '0.8.1.5',]

'as' is a reserved key word since Python-2.5: <https://docs.python.org/2.5/ref/keywords.html>

$ python -c 'import keyword;print "as" in keyword.kwlist'
True

The unit test in test/ should be fixed or removed.
Comment 4 Florian Best univentionstaff 2016-09-12 15:58:33 CEST
./scripts/convert-user-base64-photos:49:9: F821 undefined name 'udm_modules'
./scripts/convert-user-base64-photos:83:10: F821 undefined name 'Error'
Comment 5 Florian Best univentionstaff 2017-07-12 16:36:46 CEST
univention-directory-manager-modules (12.0.17-83):
r81103 | Bug #36631: fix undefined python references
r81044 | Bug #36631: fix undefined name

univention-directory-manager-modules.yaml:
r81105 | YAML Bug #36631, Bug #35074, Bug #25187, Bug #25189
Comment 6 Johannes Keiser univentionstaff 2017-07-13 17:05:38 CEST
OK cleanup
YAML: OK (r 81157)
-> verified
Comment 7 Erik Damrose univentionstaff 2017-07-26 14:39:15 CEST
<http://errata.software-univention.de/ucs/4.2/115.html>