Bug 27827 - Verhindern des ungewollten Schließens von umc.dialog.confirm()-Dialogen
Verhindern des ungewollten Schließens von umc.dialog.confirm()-Dialogen
Status: CLOSED DUPLICATE of bug 31639
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 3.0
Other Linux
: P4 minor (vote)
: UCS 3.2
Assigned To: Alexander Kläser
Florian Best
: interim-1
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-04 17:08 CEST by Alexander Kläser
Modified: 2013-11-19 06:41 CET (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Flags outvoted after Product Owner Review:
Ticket number:
Bug group (optional): Usability
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kläser univentionstaff 2012-07-04 17:08:11 CEST
Aus Bug 26235, Comment 14:

> * Der Dialog in dem gefragt wird, ob der UMC(-Web)-Server neugetartet werden
> soll oder nicht, taucht nicht auf, wenn das jeweilige Modul über die Tableiste
> geschlossen wird. Ich denke es ist gar nicht so unwahrscheinlich, dass viele
> Benutzer das Modul direkt in der Tableiste beenden, nachdem z.B. neue Software
> installiert wurde. Das sollte vielleicht noch abgefangen werden, sodass auch
> auf diesem Wege der Dialog erscheint.

Das wäre eine Erweiterung für umc.dialog.confirm() (dies wird an dieser Stelle verwendet). Dort sollte verhindert werden, dass der Dialog über das "x" geschlossen werden kann (oder ggf. über die ESC-Taste).

Code-Beispiel, das genau diese Funktionalität umsetzt:

  var dialog = new dijit.Dialog({
      title: "",
      content: "",
      closable: false,
      // overwrite _onKey to avoid closing via escape
      _onKey: function() {}
  });

  // hide the dialog's close button
  dojo.style(dialog.closeButtonNode, 'display', 'none');
Comment 1 Stefan Gohmann univentionstaff 2012-07-17 17:09:32 CEST
UCS 3.1 will be the next release.
Comment 2 Dirk Wiesenthal univentionstaff 2012-09-28 13:39:35 CEST
Tritt unschön auf in systen-setup: "Apply Changes?" -> ESC -> für immer standby

(Man kann das Modul schließen und dann neu öffnen)
Comment 3 Alexander Kläser univentionstaff 2012-09-28 18:44:31 CEST
Der folgende Traceback wurde nicht korrekt angezeigt (keine Möglichkeit, den Traceback auszuklappen):

> {"status": 591, "message": "Execution of command packages/app_center/get has failed:
> 
> Traceback (most recent call last):
>   File "/usr/lib/pymodules/python2.6/univention/management/console/modules/__init__.py", line 204, in execute
>     func( request )
>   File "/usr/lib/pymodules/python2.6/univention/management/console/modules/decorators.py", line 182, in _response
>     return function(self, request)
>   File "/usr/lib/pymodules/python2.6/univention/management/console/modules/udm/udm_ldap.py", line 142, in wrapper_func
>     ret = func( *args, **kwargs )
>   File "/usr/lib/pymodules/python2.6/univention/management/console/modules/decorators.py", line 288, in _response
>     result = _multi_response(self, request)
>   File "/usr/lib/pymodules/python2.6/univention/management/console/modules/decorators.py", line 390, in _response
>     for res in function(self, iterator, *nones):
>   File "/usr/lib/pymodules/python2.6/univention/management/console/modules/decorators.py", line 272, in _fake_func
>     yield function(self, *args)
>   File "/usr/lib/pymodules/python2.6/univention/management/console/modules/packages/__init__.py", line 120, in app_center_get
>     return application.to_dict_detail(package_manager, udm_license)
> NameError: global name package_manager is not defined
> "}

→ in diesem Fall ist in parseError() error.data.message noch ein String, der von Dojo anscheinend nicht geparset wurde.
Comment 4 Alexander Kläser univentionstaff 2012-09-28 18:45:12 CEST
(In reply to comment #2)
> Tritt unschön auf in systen-setup: "Apply Changes?" -> ESC -> für immer standby
> 
> (Man kann das Modul schließen und dann neu öffnen)

→ Ja. Das wird an Bug 27827 behandelt.
Comment 5 Alexander Kläser univentionstaff 2012-09-28 18:46:21 CEST
(In reply to comment #3)
> Der folgende Traceback wurde nicht korrekt angezeigt (keine Möglichkeit, den
> Traceback auszuklappen):
> ...

(In reply to comment #4)
> → Ja. Das wird an Bug 27827 behandelt.

→ beide Comments sind am falschen Bug :)
Comment 6 Alexander Kläser univentionstaff 2013-07-18 13:56:14 CEST
Das generelle Verhalten von ConfirmDialog wurde über Bug 31639 angepasst, closable (in dijit/Dialog seit Dojo 1.9) wird nun standardmäßig auf false gesetzt.

*** This bug has been marked as a duplicate of bug 31639 ***
Comment 7 Florian Best univentionstaff 2013-07-25 11:50:56 CEST
umc.dialog.confirm und umc.dialog.confirmForm können nicht mehr geschlossen werden (auch nicht mit ESC).
Comment 8 Stefan Gohmann univentionstaff 2013-11-19 06:41:21 CET
UCS 3.2 has been released:
 http://docs.univention.de/release-notes-3.2-en.html
 http://docs.univention.de/release-notes-3.2-de.html

If this error occurs again, please use "Clone This Bug".