Bug 31639 - Update to Dojo 1.9
Update to Dojo 1.9
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 3.1
Other Linux
: P5 normal (vote)
: UCS 3.2
Assigned To: Alexander Kläser
Dirk Wiesenthal
: interim-1
: 25347 27827 32170 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 16:30 CEST by Felix Botner
Modified: 2013-11-19 06:42 CET (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Mobile devices/tablets, Usability
Max CVSS v3 score:


Attachments
Old module (90.27 KB, image/png)
2013-08-19 15:29 CEST, Dirk Wiesenthal
Details
New module (90.37 KB, image/png)
2013-08-19 15:30 CEST, Dirk Wiesenthal
Details
Old license dialog (54.13 KB, image/png)
2013-08-19 15:30 CEST, Dirk Wiesenthal
Details
New license dialog (53.50 KB, image/png)
2013-08-19 15:30 CEST, Dirk Wiesenthal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Botner univentionstaff 2013-06-04 16:30:52 CEST
On the ipad  a umc select box (e.g. computer room module -> select room, is multiple rooms exist) is very hard to use because the virtual keyboard pops up all the  time.
Comment 1 Alexander Kläser univentionstaff 2013-06-08 12:54:44 CEST
This is a generic Dojo problem and has been addressed with Dojo 1.9. We should updated the Dojo sources for UCS 3.2.
Comment 2 Alexander Kläser univentionstaff 2013-06-26 16:25:41 CEST
The sources in the univention-dojo package have been updated. However, UMC frontend package has not yet been rebuilt.


 univention-dojo (7.0.0-1) unstable; urgency=low
 .
   * Bug #31639: updated dojo to verison 1.9 and dgrid, xstyle, put-selector to
     their most recent release version (note: xstyle has been pulled as latest
     release from github due to build problems)
Comment 3 Alexander Kläser univentionstaff 2013-07-18 13:56:14 CEST
*** Bug 27827 has been marked as a duplicate of this bug. ***
Comment 4 Alexander Kläser univentionstaff 2013-07-18 14:17:57 CEST
Dojo 1.9 has been integrated. The less code for the CSS data has been cleaned up and font px values have been converted to em in order to allow for a better rendering in Android tablets.

Current open TODOs:
* Submit buttons and normal buttons are not always horizontally aligned
Comment 5 Dirk Wiesenthal univentionstaff 2013-07-18 14:20:32 CEST
The Grid (e.g. in UDM) now has problems with the menu behind the "more" button. The menu closes immediately.
Comment 6 Dirk Wiesenthal univentionstaff 2013-07-18 18:41:09 CEST
I get a JS warning:

dojox.form.uploader.plugins.IFrame has been removed. You can use Uploader directly and it will contain all necessary functionality.

I guess this has to do with Dojo 1.9? If so, it is quite a good hint.
Comment 7 Dirk Wiesenthal univentionstaff 2013-07-19 15:59:21 CEST
[CSS] When clicking on a TitlePane in FF, the "activate" effect does not make the title green but it switches back to grey this instant.
Comment 8 Dirk Wiesenthal univentionstaff 2013-07-19 16:04:38 CEST
And I think the text at the bottom of the Grid "0 objects selected" is not vertically centered any more (maybe never really was, but now it is very obvious).
Comment 9 Dirk Wiesenthal univentionstaff 2013-07-22 12:11:11 CEST
[CSS] Notes (at least in system setup) that are longer than one line are not surrounded properly by the borders.

  Example: Note: Installing or removing software components may result in restarting or stopping services. This can have severe side-effects when the system is in productive use at the moment.
Comment 10 Alexander Kläser univentionstaff 2013-07-25 12:39:09 CEST
*** Bug 25347 has been marked as a duplicate of this bug. ***
Comment 11 Alexander Kläser univentionstaff 2013-07-25 12:46:20 CEST
(In reply to Alexander Kläser from comment #4)
> ...
> Current open TODOs:
> * Submit buttons and normal buttons are not always horizontally aligned

This has been adapted.

 univention-management-console-frontend (3.0.35-1) unstable; urgency=low
 .
   * Bug #31639: adjusted CSS for button alignment
Comment 12 Alexander Kläser univentionstaff 2013-07-26 17:22:12 CEST
(In reply to Dirk Wiesenthal from comment #5)
> The Grid (e.g. in UDM) now has problems with the menu behind the "more"
> button. The menu closes immediately.

Done. The line "evt.stopPropagation()" was missing in the _onClick handler.

(In reply to Dirk Wiesenthal from comment #6)
> I get a JS warning:
> 
> dojox.form.uploader.plugins.IFrame has been removed. You can use Uploader
> directly and it will contain all necessary functionality.
> 
> I guess this has to do with Dojo 1.9? If so, it is quite a good hint.

Yes, this is since 1.9. I removed the reference.
QA: please check upload functionality with IE.

(In reply to Dirk Wiesenthal from comment #7)
> [CSS] When clicking on a TitlePane in FF, the "activate" effect does not
> make the title green but it switches back to grey this instant.

Good hint, fixed.

(In reply to Dirk Wiesenthal from comment #8)
> And I think the text at the bottom of the Grid "0 objects selected" is not
> vertically centered any more (maybe never really was, but now it is very
> obvious).

Yep, I fixed it.
QA: please also check on tablet devices.

(In reply to Dirk Wiesenthal from comment #9)
> [CSS] Notes (at least in system setup) that are longer than one line are not
> surrounded properly by the borders.
> 
>   Example: Note: Installing or removing software components may result in
> restarting or stopping services. This can have severe side-effects when the
> system is in productive use at the moment.

Good hint! I fixed it.
Maybe this change lets the hints look a bit awkward on the Android tablet.


 univention-management-console-frontend (3.0.40-1) unstable; urgency=low
 .
   * Bug #31639: fixed behaviour of 'more' drop down in grid, fixed some CSS
     issues, removed unnecessary reference to IFrame Uploader plugin
Comment 13 Alexander Kläser univentionstaff 2013-08-06 17:52:26 CEST
I opened a new bug for the small font size of system notifications → Bug 32170.
Comment 14 Alexander Kläser univentionstaff 2013-08-15 11:23:03 CEST
Dojo 1.9.1 has been published and can thus be integrated in univention-dojo.
Comment 15 Alexander Kläser univentionstaff 2013-08-15 13:00:27 CEST
The previously commented LESS/CSS code has been removed.

 univention-management-console-frontend (3.0.54-1) unstable; urgency=low
 .
   * Bug #31639: removed commented LESS/CSS code


(In reply to Alexander Kläser from comment #14)
> Dojo 1.9.1 has been published and can thus be integrated in univention-dojo.

Done

 univention-dojo (7.0.3-1) unstable; urgency=low
 .
   * Bug #31639: update to Dojo 1.9.1 and dgrid 0.3.9
Comment 16 Alexander Kläser univentionstaff 2013-08-16 12:37:27 CEST
Scrolling of combo box drop down menus is not really possible with iPad/TransformerPad. I opened a bug in the Dojo bug tracker:

  https://bugs.dojotoolkit.org/ticket/17388

I removed a previous workaround for focus problems with ComboBoxes on mobile devices. This has been fixed in the 1.9 release:

  https://bugs.dojotoolkit.org/ticket/16730


 univention-management-console-frontend (3.0.57-1) unstable; urgency=low
 .
   * Bug #31376: removed workaround for focus problems with ComboBoxes on mobile
     devices
Comment 17 Dirk Wiesenthal univentionstaff 2013-08-19 15:29:29 CEST
Created attachment 5374 [details]
Old module
Comment 18 Dirk Wiesenthal univentionstaff 2013-08-19 15:30:03 CEST
Created attachment 5375 [details]
New module
Comment 19 Dirk Wiesenthal univentionstaff 2013-08-19 15:30:38 CEST
Created attachment 5376 [details]
Old license dialog
Comment 20 Dirk Wiesenthal univentionstaff 2013-08-19 15:30:53 CEST
Created attachment 5377 [details]
New license dialog
Comment 21 Dirk Wiesenthal univentionstaff 2013-08-19 15:38:24 CEST
Some errors in CSS:
 * The separator between host and user is not long enough
 * Wasting space because of higher padding/margin
   * Around the module title ("Spracheinstellungen")
   * Right of the logout button
   * At the footer of the page
 * Footer of dialog has no margin

Minor flaws:
 * Selected tab has a bold font ("Basis-Einstellungen")

There are some other changes (e.g. bigger buttons, more padding in inputs, slight adjustment in placing of multi input's "+" and "-" buttons), but I like them.
Comment 22 Dirk Wiesenthal univentionstaff 2013-08-19 15:46:14 CEST
This was seen in FF. In Chrome the license dialog does not seem to suffer from the same issue. Instead the font on tabs ("global" and "module internal") is not aligned as in 3.1-1.
Comment 23 Dirk Wiesenthal univentionstaff 2013-08-19 16:39:33 CEST
The toaster of dialog.notify is tiny. Really tiny.
Comment 24 Alexander Kläser univentionstaff 2013-08-19 19:08:00 CEST
(In reply to Alexander Kläser from comment #16)
> Scrolling of combo box drop down menus is not really possible with
> iPad/TransformerPad. I opened a bug in the Dojo bug tracker:
> 
>   https://bugs.dojotoolkit.org/ticket/17388

The bug has just been fixed in the dojo repository. I added Bug 32264 in order not to forget this issue.
Comment 25 Alexander Kläser univentionstaff 2013-08-20 15:51:26 CEST
CSS errors in comment #17 - comment #20
→ fixed

(In reply to Dirk Wiesenthal from comment #21)
> Some errors in CSS:
>  * The separator between host and user is not long enough

→ was a side effect of Bug 30744

>  * Wasting space because of higher padding/margin
>    * Around the module title ("Spracheinstellungen")

→ should be fine now

>    * Right of the logout button

→ fixed

>    * At the footer of the page

→ AFAICS this is now better than in 3.1

>  * Footer of dialog has no margin

→ Same behaviour as in 3.1, it seems to be an FF bug for elements, other browsers render correctly, the 0-margin effect only occurs in case the content is larger than the dialog and scroll bars are shown. For smaller content the margin is there.

> Minor flaws:
>  * Selected tab has a bold font ("Basis-Einstellungen")

→ fixed (the font was not bold, but its color was black)

> There are some other changes (e.g. bigger buttons, more padding in inputs,
> slight adjustment in placing of multi input's "+" and "-" buttons), but I
> like them.

:) … me too!

(In reply to Dirk Wiesenthal from comment #23)
> The toaster of dialog.notify is tiny. Really tiny.

→ fixed (I marked Bug 32170 as duplicate)


 univention-management-console-frontend (3.0.60-1) unstable; urgency=low
 .
   * Bug #31639: adjusted CSS rules
Comment 26 Alexander Kläser univentionstaff 2013-08-20 15:51:50 CEST
*** Bug 32170 has been marked as a duplicate of this bug. ***
Comment 27 Alexander Kläser univentionstaff 2013-08-21 11:36:08 CEST
A disabled button is displayed with white bg color + white text color.
Comment 28 Alexander Kläser univentionstaff 2013-08-21 13:33:02 CEST
The default (=green) button is in FF "much" larger than in Chromium.
Comment 29 Dirk Wiesenthal univentionstaff 2013-08-22 12:15:39 CEST
Mobile: Tapping into an input does (sometimes but) not always show up the touch keyboard. When tapping on the label it seems to work (but it takes some time).
Comment 30 Alexander Kläser univentionstaff 2013-08-22 17:55:51 CEST
(In reply to Alexander Kläser from comment #27)
> A disabled button is displayed with white bg color + white text color.

(In reply to Alexander Kläser from comment #28)
> The default (=green) button is in FF "much" larger than in Chromium.

→ I opened Bug 32318 for these problems and tagged it to MS2.

(In reply to Dirk Wiesenthal from comment #29)
> Mobile: Tapping into an input does (sometimes but) not always show up the
> touch keyboard. When tapping on the label it seems to work (but it takes
> some time).

→ I opened Bug 32319 for this problem.
Comment 31 Alexander Kläser univentionstaff 2013-08-23 15:51:20 CEST
Added changelog entry.
Comment 32 Dirk Wiesenthal univentionstaff 2013-08-23 16:04:33 CEST
(In reply to Alexander Kläser from comment #30)
> → I opened Bug 32319 for this problem.

Dojo 1.9 integrated, changelog exists. Remaining issues outsourced.
Comment 33 Stefan Gohmann univentionstaff 2013-11-19 06:42:09 CET
UCS 3.2 has been released:
 http://docs.univention.de/release-notes-3.2-en.html
 http://docs.univention.de/release-notes-3.2-de.html

If this error occurs again, please use "Clone This Bug".