Bug 30744 - Link to UMC of other UCS systems
Link to UMC of other UCS systems
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 3.1
Other Linux
: P5 enhancement (vote)
: UCS 3.2
Assigned To: Florian Best
Alexander Kläser
: interim-2
: 30619 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-11 15:14 CET by Stefan Gohmann
Modified: 2013-11-19 06:43 CET (History)
5 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Release Goal, Usability
Max CVSS v3 score:


Attachments
Screenshot of error message during appliance mode. (69.23 KB, image/png)
2013-08-02 12:25 CEST, Alexander Kläser
Details
Long host names are truncated (8.86 KB, image/png)
2013-08-19 13:00 CEST, Dirk Wiesenthal
Details
Screenshot of UMC host list menu on IE8 with 2 entries. (14.72 KB, image/png)
2013-09-19 17:50 CEST, Alexander Kläser
Details
Screenshot of UMC host list menu on IE10 (14.59 KB, image/png)
2013-09-19 17:52 CEST, Alexander Kläser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2013-03-11 15:14:45 CET
The hostname link in UMC should be converted to a drop-down list with all UCS systems in the environment. With a click on one list element the browser switches to the UMC of the selected host.

If there are two many hosts, a search field should be shown, like the user selection.
Comment 1 Florian Best univentionstaff 2013-03-11 15:43:06 CET
*** Bug 30619 has been marked as a duplicate of this bug. ***
Comment 2 Moritz Muehlenhoff univentionstaff 2013-05-31 10:45:37 CEST
We will not ship a UCS 3.1-2 release; the next UCS release will be UCS 3.2.

As such, this bug is moved to the new target milestone.
Comment 3 Alexander Kläser univentionstaff 2013-06-13 14:25:04 CEST
See also Bug 24422 for the implementation of Single Sign-on.
Comment 4 Florian Best univentionstaff 2013-07-18 13:36:34 CEST
fixed
univention-management-console-frontend (3.0.28-1)
univention-management-console (6.0.5-1)

QA: Please check also what happens if the environment has ~1000 servers.
Comment 5 Florian Best univentionstaff 2013-07-19 11:08:44 CEST
The replacement of window.location.host = fqdn does not work in Firefox.
Comment 6 Florian Best univentionstaff 2013-07-19 11:39:51 CEST
(In reply to Florian Best from comment #5)
> The replacement of window.location.host = fqdn does not work in Firefox.
fixed in univention-management-console-frontend (3.0.30-1)
Comment 7 Alexander Kläser univentionstaff 2013-07-30 12:32:50 CEST
I always see the following error in the JS console upon initial startup:

  "Error: dojo.data.ItemFileWriteStore: Invalid item argument.
Comment 8 Alexander Kläser univentionstaff 2013-07-30 12:33:58 CEST
The ComboBox should be wider (2x would be ok IMHO) in order to allow longer host names.
Comment 9 Dirk Wiesenthal univentionstaff 2013-07-30 14:42:24 CEST
The input should not be user-writable, currently you can click into the input and change the value of the widget by hand (resulting in a very ugly red exclamation mark).
Comment 10 Alexander Kläser univentionstaff 2013-07-30 15:55:03 CEST
(In reply to Dirk Wiesenthal from comment #9)
> The input should not be user-writable, currently you can click into the
> input and change the value of the widget by hand (resulting in a very ugly
> red exclamation mark).

This could be done by using a different widget: dijit/form/Select.
Comment 11 Alexander Kläser univentionstaff 2013-08-02 12:25:44 CEST
Created attachment 5349 [details]
Screenshot of error message during appliance mode.
Comment 12 Dirk Wiesenthal univentionstaff 2013-08-19 13:00:11 CEST
Created attachment 5372 [details]
Long host names are truncated
Comment 13 Dirk Wiesenthal univentionstaff 2013-08-19 13:02:54 CEST
(In reply to Alexander Kläser from comment #10)
> This could be done by using a different widget: dijit/form/Select.

Given the latest screenshot I suggest not using a real Widget but just an arrow with a drop down menu and render the current host the way it was in 3.1-1.
Comment 14 Florian Best univentionstaff 2013-08-20 12:25:37 CEST
* error message if unjoined/no LDAP connection has been removed
* the DropDown is now styled in the same look as e.g. the help button
* if there is only one host the dropdown will not be displayed
Comment 15 Alexander Kläser univentionstaff 2013-08-23 18:21:03 CEST
topic.publish('/umc/actions', 'switch host')
→ better do not use a space in the action name

IE:
* The menu cannot be opened in IE8
* Disabling the button leads to a shadowed text in IE8/9

Mobile devices: scrolling is not really possible → but that is a Dojo bug and out of scope here.

Please add a UCR variable with a MAX value, i.e., up to which number of entries the menu should be displayed or not. Default could be 100, for instance. This is IMHO important to avoid troubles in larger environments.

CSS:
div[dijitpopupparent=umcMenuSettings],
div[dijitpopupparent=umcMenuHelp] {
    top: 35px !important;
}
→ I would add a selector for umcMenuHost here, as well.

The alignment in FF is not on the same height as in Chrome. Dojo adds the class "has-mozilla" to the body element, with that class you could add a mozilla specific tweak.

Note:
lang.hitch(this, function() {
  this._switchUMC(hostname);
})
→ can also be written as:
lang.hitch(this, '_switchUMC', hostname);

Changelog seems to be missing.

→ REOPENED
Comment 16 Florian Best univentionstaff 2013-08-26 14:01:57 CEST
(In reply to Alexander Kläser from comment #15)
> topic.publish('/umc/actions', 'switch host')
> → better do not use a space in the action name
Changed to "host/switch"

> IE:
> * The menu cannot be opened in IE8
This works for me in IE8

> * Disabling the button leads to a shadowed text in IE8/9
This have been removed for IE

> Please add a UCR variable with a MAX value, i.e., up to which number of
> entries the menu should be displayed or not. Default could be 100, for
> instance. This is IMHO important to avoid troubles in larger environments.
UCRV: umc/web/max_host_entries
default: 100

> CSS:
> div[dijitpopupparent=umcMenuSettings],
> div[dijitpopupparent=umcMenuHelp] {
>     top: 35px !important;
> }
> → I would add a selector for umcMenuHost here, as well.
Yes

> The alignment in FF is not on the same height as in Chrome. Dojo adds the
> class "has-mozilla" to the body element, with that class you could add a
> mozilla specific tweak.
Mozilla specific CSS has been added

> Note:
> lang.hitch(this, function() {
>   this._switchUMC(hostname);
> })
> → can also be written as:
> lang.hitch(this, '_switchUMC', hostname);
OK

> Changelog seems to be missing.
Added Changelog
Comment 17 Moritz Muehlenhoff univentionstaff 2013-09-11 13:25:50 CEST
umc/web/max_host_entries make the user think that it's about a maximum limit of hosts which can be managed in the UMC.

A better name would be something like umc/web/referrallimit
Comment 18 Florian Best univentionstaff 2013-09-13 14:54:39 CEST
(In reply to Moritz Muehlenhoff from comment #17)
> umc/web/max_host_entries make the user think that it's about a maximum limit
> of hosts which can be managed in the UMC.
> 
> A better name would be something like umc/web/referrallimit

Has been renamed into "umc/web/host_referrallimit".
Comment 19 Alexander Kläser univentionstaff 2013-09-19 17:50:42 CEST
Created attachment 5448 [details]
Screenshot of UMC host list menu on IE8 with 2 entries.

(In reply to Florian Best from comment #16)
> (In reply to Alexander Kläser from comment #15)
> > topic.publish('/umc/actions', 'switch host')
> > → better do not use a space in the action name
> Changed to "host/switch"

OK. (FYI: "/" will be converted to "-" for Piwik as it is the default separator).

> > IE:
> > * The menu cannot be opened in IE8
> This works for me in IE8

This is correct. Two observations:
(1) If there is only 1 host available, the little triangle [v] is still visible, i.e., the menu is not disabled.
(2) When opening the host list menu and the first entry is disabled, it has a dark background in IE8 (→ see screenshot).

> > * Disabling the button leads to a shadowed text in IE8/9
> This have been removed for IE

OK. Probably then related to (1) above?

> > Please add a UCR variable with a MAX value, i.e., up to which number of
> > entries the menu should be displayed or not. Default could be 100, for
> > instance. This is IMHO important to avoid troubles in larger environments.
> UCRV: umc/web/max_host_entries
> default: 100

OK. Works as expected.

> > CSS:
> > div[dijitpopupparent=umcMenuSettings],
> > div[dijitpopupparent=umcMenuHelp] {
> >     top: 35px !important;
> > }
> > → I would add a selector for umcMenuHost here, as well.
> Yes

OK. I would add another rule for hiding the arrow when disabling the menu:

umc .umcHeader .dijitDisabled #umcMenuHost .dijitArrowButtonInner {
    width: 0;
}

> > The alignment in FF is not on the same height as in Chrome. Dojo adds the
> > class "has-mozilla" to the body element, with that class you could add a
> > mozilla specific tweak.
> Mozilla specific CSS has been added

OK.

> > Note:
> > lang.hitch(this, function() {
> >   this._switchUMC(hostname);
> > })
> > → can also be written as:
> > lang.hitch(this, '_switchUMC', hostname);
> OK
> 
> > Changelog seems to be missing.
> Added Changelog

I merged the changelog with Bug 24422.
Comment 20 Alexander Kläser univentionstaff 2013-09-19 17:52:50 CEST
Created attachment 5449 [details]
Screenshot of UMC host list menu on IE10

It seems that some browsers (IE10, IE9, Chrome also a bit) display the highlighted and disabled menu entry not correct.
Comment 21 Alexander Kläser univentionstaff 2013-09-19 18:12:49 CEST
(In reply to Alexander Kläser from comment #19)
> ...
> > > * Disabling the button leads to a shadowed text in IE8/9
> > This have been removed for IE
> 
> OK. Probably then related to (1) above?

Your condition is:

> this._hostInfo.set('disabled', empty && !has('ie'))

IE10 is fine. You could do the following:

> this._hostInfo.set('disabled', empty)
> var isIE89 = (has('ie') == 8 || has('ie') == 9);
> if (empty && isIE89) {
>     domAttr.set(this._hostInfo.focusNode, 'disabled', false);
> }

This seems to work in my cases.
Comment 22 Florian Best univentionstaff 2013-09-20 11:57:40 CEST
univention-management-console-frontend (3.0.79-1) 
* Bug #30744: Internet Explorer fixes

→ The rest is done at Bug #32655
Comment 23 Alexander Kläser univentionstaff 2013-09-24 14:49:35 CEST
topic.publish('/umc/actions', 'switch host')
→ OK

Disabled menu & hidden arrow
→ OK

The host drop is one pixel too low on iPad
→ outsourced to Bug 32679

→ VERIFIED
Comment 24 Stefan Gohmann univentionstaff 2013-11-19 06:43:36 CET
UCS 3.2 has been released:
 http://docs.univention.de/release-notes-3.2-en.html
 http://docs.univention.de/release-notes-3.2-de.html

If this error occurs again, please use "Clone This Bug".