Bug 29261 - Kontextmenu im DriveGrid lässt sich nicht öffnen
Kontextmenu im DriveGrid lässt sich nicht öffnen
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - Virtual machines (UVMM)
UCS 3.0
Other Linux
: P5 normal (vote)
: UCS 3.1-1-errata
Assigned To: Jascha Geerds
Philipp Hahn
:
: 29389 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-16 14:19 CET by Jascha Geerds
Modified: 2013-06-13 14:38 CEST (History)
5 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
UVMM patch (1.08 KB, patch)
2013-04-08 13:05 CEST, Alexander Kläser
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jascha Geerds univentionstaff 2012-11-16 14:19:09 CET
Wenn man bei einer VM in den Reiter "Geräte" wechselt und dort bei einem Laufwerk das Kontextmenu mit der linken Maustaste öffnet (über den 'mehr'-Button) so verschwindet das Kontextmenu, sobald man mit dem Mauszeiger drüber fährt.

Das Problem  tritt nur auf, denn die Maschine zu dem Zeitpunkt läuft. Über die rechte Maustaste ist das Kontextmenu ohne Probleme erreichbar. Ich konnte das Problem bei keinem anderen Grid feststellen. Bspw. im UMC-Modul "Systemdienste" wird auch ein Grid verwendet, welches ein Kontextmenu über einen 'mehr'-Button bereitstellt. Dort führt dies zu keinen Problemen.

Aufgefallen ist dies in Bug #27817
Comment 1 Alexander Kläser univentionstaff 2013-04-08 13:05:31 CEST
Created attachment 5163 [details]
UVMM patch

The problem here is that the DomainPage instant is getting disabled when opening a running instance and the DriveGrid gets disabled, as well. As "disabled" means that the item cannot be accessed, the focus behaviour changes assuming DriveGrid cannot be edited (as it is marked as "disabled") and this causes the menu to be closed.

However, in this case, "disabled" does not mean "disabled", as the DriveGrid should still be accessible. Two solutions:
* overwrite _getDisabledAttr() to always return false ? this is a quick, dirty hack (as attached in the patch) and I would discourage as it is making the code less comprehensible in the long run
* do not use the "disabled" attribute, yet use something more meaningful (e.g., domainRunning=true, domainState="RUNNING", ...)
Comment 2 Alexander Kläser univentionstaff 2013-04-08 13:06:34 CEST
BTW, DomainPage.disabled should also be omitted (see patch).
Comment 3 Jascha Geerds univentionstaff 2013-04-09 11:02:29 CEST
This has been fixed with the second solution.

- ucs3.1-1 + YAML
Package: univention-virtual-machine-manager-daemon
Version: 2.0.36-4.439.201304091050

- ucs3.1-2 + Changelog
Package: univention-virtual-machine-manager-daemon
Version: 2.0.37-1.437.201304091014
Comment 4 Jascha Geerds univentionstaff 2013-04-16 11:00:42 CEST
*** Bug 29389 has been marked as a duplicate of this bug. ***
Comment 5 Philipp Hahn univentionstaff 2013-05-21 13:51:05 CEST
OK: 3.1-1 → errata3.1-1 → 3.1-2
OK: svn39911
FIXED: yaml (r40641)

OK: 3.1-1 → ucs3.1-2
OK: svn39908
FIXED: Changelog (r40641)
Comment 6 Janek Walkenhorst univentionstaff 2013-06-13 14:38:24 CEST
http://errata.univention.de/ucs/3.1/125.html