Bug 29707 - PrinterGroup kann mehrere spoolHosts haben - und bringt damit alles durcheinander
PrinterGroup kann mehrere spoolHosts haben - und bringt damit alles durcheina...
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - Printers
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-1-errata
Assigned To: Florian Best
Johannes Keiser
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-10 18:29 CET by Dirk Wiesenthal
Modified: 2017-07-26 14:39 CEST (History)
2 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 3: Simply Wrong: The implementation doesn't match the docu
Who will be affected by this bug?: 1: Will affect a very few installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.034
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Ticket number:
Bug group (optional):
Max CVSS v3 score:
best: Patch_Available+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Wiesenthal univentionstaff 2012-12-10 18:29:59 CET
Es ist möglich, einer PrinterGroup mehrere spoolHosts zuzuweisen. Aber da die Drucker im Frontend von den Servern abhängen, wird bei jeder Änderung beim Server nachgefragt.

Wenn mehr als ein Server ausgewählt wurde, war bei mir die Liste der Drucker leer.
Comment 1 Stefan Gohmann univentionstaff 2012-12-10 18:40:18 CET

*** This bug has been marked as a duplicate of bug 25216 ***
Comment 2 Stefan Gohmann univentionstaff 2012-12-10 19:01:16 CET
(In reply to comment #1)
> *** This bug has been marked as a duplicate of bug 25216 ***

Falscher Bug
Comment 3 Stefan Gohmann univentionstaff 2017-06-16 20:39:12 CEST
This issue has been filed against UCS 3. UCS 3 is out of the normal maintenance and many UCS components have vastly changed in UCS 4.

If this issue is still valid, please change the version to a newer UCS version otherwise this issue will be automatically closed in the next weeks.
Comment 4 Florian Best univentionstaff 2017-07-13 12:42:38 CEST
The Printers and the PrinterNames syntax class build up a broken LDAP filter:

'spoolHost=%s' % '|'.join(options[Printers.depends])

→ resulting in spoolHost=foo|bar|baz instead of (|(spoolHost=foo)(spoolHost=bar)(spoolHost=baz)).
Comment 5 Florian Best univentionstaff 2017-07-13 13:25:43 CEST
Easy fix. To reproduce:
* Have at least two computers/* objects with service=Print.
* Create some (2) printers with spool Host = one of the computers
* Try to create a printer group: Select two computers as spool host
→ The field "Group members" is empty and nothing can be selected.

univention-directory-manager-modules (12.0.17-87):
r81132 | Bug #29707: fix detection of group members in  a printer group if the group has multiple spool hosts

univention-directory-manager-modules.yaml:
r81133 | YAML Bug #29707
Comment 6 Johannes Keiser univentionstaff 2017-07-14 18:33:43 CEST
OK The field 'Group members' shows all printers from the selected spool hosts

YAML: OK
-> verified
Comment 7 Erik Damrose univentionstaff 2017-07-26 14:39:06 CEST
<http://errata.software-univention.de/ucs/4.2/115.html>