Bug 29893 - xrdp and UCC
xrdp and UCC
Status: CLOSED FIXED
Product: Univention Corporate Client (UCC)
Classification: Unclassified
Component: General
unspecified
Other Linux
: P5 enhancement
: UCC 2.0
Assigned To: Moritz Muehlenhoff
Felix Botner
: interim-3
: 19848 30735 31251 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-02 06:51 CET by Stefan Gohmann
Modified: 2014-06-12 09:19 CEST (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Release Goal
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2013-01-02 06:51:09 CET
We should check if xrdp can replace the normal ssh/x-forwarding session.
Comment 1 Moritz Muehlenhoff univentionstaff 2013-03-22 11:16:00 CET
*** Bug 30735 has been marked as a duplicate of this bug. ***
Comment 2 Moritz Muehlenhoff univentionstaff 2013-12-16 12:45:49 CET
If xrdp is integrated into UCC, the work it should be based on the cool solution.

JPEG compression should be enabled, see Bug 31247
Comment 3 Moritz Muehlenhoff univentionstaff 2013-12-16 12:46:11 CET
*** Bug 31251 has been marked as a duplicate of this bug. ***
Comment 4 Moritz Muehlenhoff univentionstaff 2013-12-17 09:40:50 CET
*** Bug 19848 has been marked as a duplicate of this bug. ***
Comment 5 Moritz Muehlenhoff univentionstaff 2013-12-18 09:22:53 CET
Bug 30870 will need to be fixed as well.
Comment 6 Moritz Muehlenhoff univentionstaff 2014-04-15 12:51:03 CEST
The meta package univention-xrdp integrates xrdp 0.8.0 into UCC. It is based on the based cool solution for UCC with some changes on top.

The UCR variable xrdp/logo allows the configuration of the logo displayed in the login screen.

No domain is needed when logging into a system using xrdp. xrdp display it's own login screen instead of lightdm.  After a successful login the session script UCC-KDE is launched. Only a RDP session is offered, for special cases xrdp/sessions can configure additional connections.

Sound redirection is supported using a separate Pulseaudio-Sink. To use it with
freerdp use the following:

xfreerdp --plugin rdpsnd IPADDRESS

Storage redirectoion was successfully tested as well. It's using a FUSE backend:

xfreerdp --plugin rdpdr --data disk:local-drives:/mnt/stick -- IPADDRESS

The directory /mnt/stick is then available in the user's home at ~/xrdp-client
(I asked Jay to switch that to a different name)
Comment 7 Moritz Muehlenhoff univentionstaff 2014-04-15 14:04:29 CEST
Tests with the remote desktop client from Windows 7 were also succesful. Sound redirection was also working fine.

Storage redirection of the C: drive of the notebook wasn't working. But I'm not sure if that's implemented/feasible, need to check with upstream.
Comment 8 Moritz Muehlenhoff univentionstaff 2014-04-17 10:05:54 CEST
First bandwidth tests:

Watching a Youtube video in 640x360 (I used http://www.youtube.com/watch?v=vIu85WQTPRc as a test) results in  average transfer rate of 3 MB/s (with 5.5 in brief peaks and down to less than 1 MB/s for darker scenes (e.g. when the flares are fired)).

In UCC 1.0 we had a massive traffic spike when browsing the KDE system settings menu. This no longer occurs, browsing the system settings results in an average of 100Kb/s.

When opening a web site at 1920x1080 screen resolution in Firefox (as tested
with www.univention.de) scrolling down the full page results in traffic of 2-3 MB/s. Browsing inside the web page (clicking links on the Univention site) is considerably less (200 Kb to 1 MB/s).

Working on a Konsole shell uses at most 100 KB/s.

Browsing the UCS manual in Okular in 1920x1080 uses 200 KB/s to 1 MB/s (the average is approx 300-400 KB/s).


I opened Libre Office Writer in 1920x1080, wrote some text to the document and browsed the menus. That yielded in traffic of up to 100 KB/s (when editing text sometimes only 20-30)


Compared to the values for SSH xforwarding in UCC this is a massive improvement:
https://forge.univention.org/bugzilla/show_bug.cgi?id=22654#c14
Comment 9 Moritz Muehlenhoff univentionstaff 2014-04-25 10:51:51 CEST
Initial work is available in the beta release, but a new xrdp release still needs to be released and integrated, move to interim-3
Comment 10 Moritz Muehlenhoff univentionstaff 2014-05-05 11:47:29 CEST
Bandwidth comparison between xrdp and a Windows terminal server (made by Jay Sorg):

http://www.xrdp.org/index.php?option=com_content&view=article&id=31:bandwidth-compare&catid=2:documents&Itemid=7

Despite running in a bigger screen resolution the xrdp uses less bandwidth than a MS terminal server (The screen resolutions used for Windows and xrdp are not identical since the Windows notebook used for the tests only had a smaller display)
Comment 11 Moritz Muehlenhoff univentionstaff 2014-05-12 09:20:04 CEST
xrdp currently doesn't have PAM integration. For UCC thin clients that's not that an issue since expired passwords or forced password changes are handled within LightDM before logging it.

Upstream plans to work on it, but this will not be available in the xrdp version in UCC 2.0.
Comment 12 Moritz Muehlenhoff univentionstaff 2014-05-13 13:26:41 CEST
xrdp requires a Pulseaudio sound sink. Jay Sorg has written once and it will likely be merged in upstream Pulseaudio in the future. Until now the build is fairly intricate since it needs to be build against a specific Pulseaudio source package:
http://www.xrdp.org/index.php?option=com_content&view=article&id=19:xrdp-pulse-sink&catid=2:documents&Itemid=7

I've created a package pulseaudio-xrdp which automates the build and allows us to build this on the buildsystem.
Comment 13 Moritz Muehlenhoff univentionstaff 2014-05-21 10:00:22 CEST
In univention-xrdp 2.1.0-11 the UCC-KDE session script has been fixed to source /etc/profile to ensure that the language setting is properly configured out of the box.
Comment 14 Felix Botner univentionstaff 2014-05-21 17:03:05 CEST
OK - Sound
OK - Video 
OK - Performance
OK - Session

OK - access via UCC client (sound, device redirection) 
OK - access via win8 client (sound, device redirection) 
OK - access via mac client (sound, device redirection)
 * http://cord.sourceforge.net/ - works
 * Mircosoft Remote Desktop App did not work (ssl/certificate problems)
 * Microsoft Remotedesktopverbinds-Client - works (no fullscree, no sound, etc.)
OK - access via Android (sound)(In reply to Moritz Muehlenhoff from comment #13)


> In univention-xrdp 2.1.0-11 the UCC-KDE session script has been fixed to
> source /etc/profile to ensure that the language setting is properly
> configured out of the box.

OK
Comment 15 Moritz Muehlenhoff univentionstaff 2014-06-12 09:19:49 CEST
UCC 2.0 has been released:
 http://docs.univention.de/release-notes-ucc-2.0.html

If this error occurs again, please use "Clone This Bug".