Bug 30520 - dh-umc-module-install installs files with permission 0755 instead of 0644
dh-umc-module-install installs files with permission 0755 instead of 0644
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 4.1
All Linux
: P5 minor (vote)
: UCS 4.1-0-errata
Assigned To: Florian Best
Daniel Tröder
:
: 29233 36790 (view as bug list)
Depends on:
Blocks: 29233
  Show dependency treegraph
 
Reported: 2013-02-20 14:02 CET by Philipp Hahn
Modified: 2016-01-27 16:26 CET (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Cleanup
Max CVSS v3 score:
hahn: Patch_Available+


Attachments
Add missing -m644 (2.17 KB, patch)
2013-02-20 14:02 CET, Philipp Hahn
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Hahn univentionstaff 2013-02-20 14:02:31 CET
Created attachment 5086 [details]
Add missing -m644

For example lintian on UVMM:

executable-not-elf-or-script
./usr/share/locale/de/LC_MESSAGES/univention-management-console-module-uvmm.mo
executable-not-elf-or-script
./usr/share/univention-management-console/modules/uvmm.xml
executable-not-elf-or-script
./usr/share/univention-management-console-frontend/js/umc/modules/i18n/de/uvmm.json
executable-not-elf-or-script
./usr/share/univention-management-console/i18n/de/uvmm.mo

By default /usr/bin/install installes files as `u=rwx,go=rx,a-s', so for
non-executable files -m644 must be explicitly added.

The other dh-umc-* helpers should be checked for similar problems.
Comment 1 Florian Best univentionstaff 2015-01-09 15:24:58 CET
*** Bug 29233 has been marked as a duplicate of this bug. ***
Comment 2 Philipp Hahn univentionstaff 2015-12-03 13:20:39 CET
*** Bug 36790 has been marked as a duplicate of this bug. ***
Comment 3 Florian Best univentionstaff 2016-01-18 10:48:45 CET
univention-management-console.yaml:
r66834 | YAML Bug #30520

univention-management-console (8.0.28-4):
r66833 | Bug #30520: Bug #40341:
Comment 4 Daniel Tröder univentionstaff 2016-01-25 12:34:46 CET
OK: code
OK: advisory
OK: manual test:

root@ucs26:~/sync/univention-self-service# ls -l /usr/share/univention-management-console-frontend/js/umc/modules/i18n/de/passwordreset.json /usr/share/locale/de/LC_MESSAGES/univention-self-service-passwordreset-umc.mo /usr/share/univention-management-console/i18n/de/passwordreset.mo 
-rwxr-xr-x 1 root root 2592 Jan 15 14:47 /usr/share/locale/de/LC_MESSAGES/univention-self-service-passwordreset-umc.mo
-rwxr-xr-x 1 root root    2 Jan 15 14:47 /usr/share/univention-management-console-frontend/js/umc/modules/i18n/de/passwordreset.json
-rwxr-xr-x 1 root root  602 Jan 15 14:47 /usr/share/univention-management-console/i18n/de/passwordreset.mo


root@ucs26:~/sync/univention-self-service# rm ../*.deb; dpkg-buildpackage -us -uc -b && dpkg -i ../*.deb 

root@ucs26:~/sync/univention-self-service# ls -l /usr/share/univention-management-console-frontend/js/umc/modules/i18n/de/passwordreset.json /usr/share/locale/de/LC_MESSAGES/univention-self-service-passwordreset-umc.mo /usr/share/univention-management-console/i18n/de/passwordreset.mo 
-rw-r--r-- 1 root root 2592 Jan 25 12:23 /usr/share/locale/de/LC_MESSAGES/univention-self-service-passwordreset-umc.mo
-rw-r--r-- 1 root root    2 Jan 25 12:23 /usr/share/univention-management-console-frontend/js/umc/modules/i18n/de/passwordreset.json
-rw-r--r-- 1 root root  602 Jan 25 12:23 /usr/share/univention-management-console/i18n/de/passwordreset.mo
Comment 5 Janek Walkenhorst univentionstaff 2016-01-27 16:26:11 CET
<http://errata.software-univention.de/ucs/4.1/66.html>