Bug 30792 - join into site ignores given samba4-join-dc and fails
join into site ignores given samba4-join-dc and fails
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Samba4
UCS 3.1
Other Linux
: P2 normal (vote)
: UCS 3.1-1-errata
Assigned To: Arvid Requate
Stefan Gohmann
:
: 31555 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-15 11:45 CET by Ingo Steuwer
Modified: 2013-05-30 10:28 CEST (History)
4 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ingo Steuwer univentionstaff 2013-03-15 11:45:18 CET
If the UCS DC Master is no Samba4 DC but a DC Backup, the join of a DC Slave with Samba4 into a AD/Samba4-"site" fails (both samba4/join/site and samba4/dc are set).

In 96univention-samba4.inst the "create_site()"-function ignores the given samba4/dc and tries to search Samba4 on ldap/master, which fails.
Comment 1 Ingo Steuwer univentionstaff 2013-03-15 11:49:13 CET
the join fails completely with an not working but somehow registered Samba4 DC -> higher priority
Comment 2 Arvid Requate univentionstaff 2013-05-07 20:14:45 CEST
Fixed in errata3.1-1 and ucs3.1-2.

Advisory: 2013-05-07-univention-samba4.yaml
Changelog: changelog-3.1-2.tex
Comment 3 Stefan Gohmann univentionstaff 2013-05-28 21:26:40 CEST
Now the join fails, but the scenario S4 on DC Slave and no S4 on DC Master is supported. See also Bug #31555.

As far as I can see, the error was introduced with Bug #27497.

Maybe we could remove the create_site call since the site is created during the provisioning?
Comment 4 Stefan Gohmann univentionstaff 2013-05-28 21:27:03 CEST
*** Bug 31555 has been marked as a duplicate of this bug. ***
Comment 5 Stefan Gohmann univentionstaff 2013-05-28 21:33:18 CEST
(In reply to comment #0)
> If the UCS DC Master is no Samba4 DC but a DC Backup, the join of a DC Slave
> with Samba4 into a AD/Samba4-"site" fails (both samba4/join/site and samba4/dc
> are set).
> 
> In 96univention-samba4.inst the "create_site()"-function ignores the given
> samba4/dc and tries to search Samba4 on ldap/master, which fails.

I was not able to reproduce it. Sure the site creation of the site failed at this point, but the site is created later, see Bug #27497.

Do you have any logs from the system?
Comment 6 Ingo Steuwer univentionstaff 2013-05-29 06:25:37 CEST
(In reply to comment #5)
> (In reply to comment #0)
> > If the UCS DC Master is no Samba4 DC but a DC Backup, the join of a DC Slave
> > with Samba4 into a AD/Samba4-"site" fails (both samba4/join/site and samba4/dc
> > are set).
> > 
> > In 96univention-samba4.inst the "create_site()"-function ignores the given
> > samba4/dc and tries to search Samba4 on ldap/master, which fails.
> 
> I was not able to reproduce it. Sure the site creation of the site failed at
> this point, but the site is created later, see Bug #27497.

In my tests univention-join stopped because 96univention-samba4.inst failed, the issue here is not that the site isn't created but that univention-join failed.

AFAIR the site has been created, but I'm unsure if it worked. We always deleted it an any references to have a "clean" test-scenario.

> Do you have any logs from the system?

No (customer system).

Maybe an Errata in the last 3 month changed the behaviour?
Comment 7 Arvid Requate univentionstaff 2013-05-29 10:44:07 CEST
> Maybe an Errata in the last 3 month changed the behaviour?

Indeed, this one ;-) I removed the "exit 1" again that I added before for the case of failure. Now only a warnig is issued.
Comment 8 Stefan Gohmann univentionstaff 2013-05-29 17:06:52 CEST
3.1-1 errata: OK, I was able to join against the DC Backup (samba4/dc + samba4/join/site)

YAML: OK

3.1-2: OK (Code comparison)

Changelog: OK
Comment 9 Moritz Muehlenhoff univentionstaff 2013-05-30 10:28:37 CEST
http://errata.univention.de/ucs/3.1/114.html