Bug 31302 - required=1 is not enforced on multivalue extended attributes
required=1 is not enforced on multivalue extended attributes
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UDM - Extended Attributes
UCS 3.1
Other Linux
: P5 normal (vote)
: UCS 3.2
Assigned To: Lukas Walter
Felix Botner
: interim-2
Depends on:
Blocks: 21742
  Show dependency treegraph
 
Reported: 2013-05-07 14:53 CEST by Lukas Walter
Modified: 2013-11-19 06:41 CET (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Walter univentionstaff 2013-05-07 14:53:34 CEST
root@mas10:~/ucs-test# udm settings/extended_attribute create \
--set name="sometest" \
--set shortDescription="sometest" \
--set CLIName="sometest" \
--set module="computers/windows" \
--set objectClass="univentionFreeAttributes" \
--set ldapMapping="univentionFreeAttribute15" \
--set valueRequired="1" \
--set multivalue="1" \
--position="cn=custom attributes,cn=univention,dc=lwadev,dc=lwaqa" 
Object created: cn=sometest,cn=custom attributes,cn=univention,dc=lwadev,dc=lwaqa

root@mas10:~/ucs-test# udm computers/windows create --set name="test-win"
Object created: cn=test-win,dc=lwadev,dc=lwaqa
Comment 1 Lukas Walter univentionstaff 2013-06-21 16:20:56 CEST
When this bug is fixed, the test 
"68_udm-extendedattribute/62_check_multivalue_extented_attribute_required" should be enabled again.
Comment 2 Lukas Walter univentionstaff 2013-09-11 14:48:40 CEST
CLI only problem (UMC seems to have an additional mechanism to check whether all required proertpies are given).

Caused by list type properties which are not actually empty, but containing an empty string (['']). Therefore, I have added an other checking routine for which will be used for list types.


Test renabled.
Comment 3 Felix Botner univentionstaff 2013-09-19 14:26:29 CEST
OK 

-> udm computers/windows create --set name="test-win"
E: Insufficient information
The following parameters are missing:
sometest

-> udm computers/windows create --set name="test-win" --set sometest=sada
Object created: cn=test-win,dc=test,dc=fb

-> udm computers/windows list

DN: cn=test-win,dc=test,dc=fb
ARG: None
  domain: None
  sometest: sada
  network: None

OK - Changelog
Comment 4 Stefan Gohmann univentionstaff 2013-11-19 06:41:53 CET
UCS 3.2 has been released:
 http://docs.univention.de/release-notes-3.2-en.html
 http://docs.univention.de/release-notes-3.2-de.html

If this error occurs again, please use "Clone This Bug".