Bug 32627 - Reconsider LSB settings
Reconsider LSB settings
Status: CLOSED FIXED
Product: Univention Corporate Client (UCC)
Classification: Unclassified
Component: General
unspecified
Other Linux
: P5 normal
: UCC 2.0
Assigned To: Moritz Muehlenhoff
Erik Damrose
: interim-1
: 30536 31301 (view as bug list)
Depends on:
Blocks: 30536 31301
  Show dependency treegraph
 
Reported: 2013-09-18 11:24 CEST by Moritz Muehlenhoff
Modified: 2014-06-12 09:19 CEST (History)
4 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Roadmap discussion
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Moritz Muehlenhoff univentionstaff 2013-09-18 11:24:07 CEST
Currently we modify the LSB information in UCC. This breaks all software which tries to detect which Ubuntu release it is running on.

One example is Bug 31301, but there might be more (and some errors might be more subtle than in the PPA case, where a traceback makes things obvious).

For UCC 1.1 we should reconsider the LSB values and use the stock values from Ubuntu.
Comment 1 Stefan Gohmann univentionstaff 2013-11-01 22:08:51 CET
Need to be discussed.
Comment 2 Moritz Muehlenhoff univentionstaff 2014-01-08 12:41:32 CET
UCC 2.0 will use the stock LSB settings from Ubuntu. Keeping this bug open to double-check this as part of the QA
Comment 3 Philipp Hahn univentionstaff 2014-02-03 08:36:51 CET
FYI: Nessus uses different files to detect the OS in nessus/ssh_get_info.nasl:
 RedHat,CentOS: /etc/redhat-release
 Ubuntu: /etc/lsb-release
 Connectiva Linux: /etc/conectiva-release
 TurboLinux: /etc/turbolinux-release
 FreeBSD: `uname`
 Debian: /etc/debian_version
 Slackware: /etc/slackware-version
 SuSE: /etc/SuSE-release
 Trustix: /etc/release, /etc/trustix-release
 Gentoo: /etc/gentoo-release
Since there is no specific test for UCS, UCS is wrongly detected as Debian, which triggers all Debian Security Announcementss, which is not correct, since we do our own security maintenance.
So please be careful in what you put in those files to not fool existing tools.
Comment 4 Moritz Muehlenhoff univentionstaff 2014-03-11 10:49:49 CET
*** Bug 31301 has been marked as a duplicate of this bug. ***
Comment 5 Moritz Muehlenhoff univentionstaff 2014-03-11 10:50:24 CET
*** Bug 30536 has been marked as a duplicate of this bug. ***
Comment 6 Moritz Muehlenhoff univentionstaff 2014-03-26 11:32:41 CET
The duplicated bugs should also be briefly tested; i.e. using the Ubuntu Software Center and including a PPA.
Comment 7 Moritz Muehlenhoff univentionstaff 2014-03-31 11:36:48 CEST
042-keep-original-lsb-values.patch has been added, UCC now uses the stock values from Kubuntu 14.04:

root@test2:~# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu Trusty Tahr (development branch)
Release:        14.04
Codename:       trusty

Adding a PPA worked fine (Bug 31301). 

The Software Center is targeted at the Unity desktop and not used in Kubuntu.
Comment 8 Erik Damrose univentionstaff 2014-04-07 10:21:32 CEST
OK: lsb information matches kubuntu
OK: Add PPA with add-apt-repository (Bug 31301)
OK: Installing from KDE software center (Muon) (Bug 30534)
OK: Changelog
Verified
Comment 9 Moritz Muehlenhoff univentionstaff 2014-06-12 09:19:40 CEST
UCC 2.0 has been released:
 http://docs.univention.de/release-notes-ucc-2.0.html

If this error occurs again, please use "Clone This Bug".