Bug 32628 - Remove /opt/scalix/bin from PATH
Remove /opt/scalix/bin from PATH
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UCR
UCS 3.2
All Linux
: P5 minor (vote)
: UCS 4.0
Assigned To: Felix Botner
Stefan Gohmann
: interim-2
: 39064 39065 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-18 11:43 CEST by Philipp Hahn
Modified: 2015-08-11 15:54 CEST (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Hahn univentionstaff 2013-09-18 11:43:58 CEST
base/univention-base-files/conffiles/etc/cron.d/univention-ucr-cronjobs:45:path = configRegistry.get('cron/path', '/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/opt/scalix/bin')
base/univention-base-files/conffiles/etc/profile:7:  PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/opt/scalix/bin"
base/univention-base-files/debian/univention-base-files.univention-config-registry-variables:509:Description[de]=Mit dieser Variable kann die PATH-Umgebungsvariable für die in UCR definierten Cron-Job (siehe 'cron/JOBNAME/*') gesetzt werden. Ist die Variable nicht gesetzt, gilt '/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/opt/scalix/bin'.
base/univention-base-files/debian/univention-base-files.univention-config-registry-variables:510:Description[en]=This variable allows the configuration of the PATH environment variable for Cron jobs defined in UCR (see 'cron/JOBNAME/*'). If the variable is unset, '/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/opt/scalix/bin' applies.
Comment 1 Dirk Ahrnke 2014-09-23 12:10:44 CEST
given that Bug 28693 is targeted for UCS 4.0 it might be a good idea to clean this up at the same time.
Comment 2 Stefan Gohmann univentionstaff 2014-09-23 12:22:15 CEST
(In reply to Dirk Ahrnke from comment #1)
> given that Bug 28693 is targeted for UCS 4.0 it might be a good idea to
> clean this up at the same time.

Yes. Thanks!
Comment 3 Felix Botner univentionstaff 2014-09-29 10:12:28 CEST
"/opt/scalix/bin" has been removed.
Comment 4 Stefan Gohmann univentionstaff 2014-10-01 14:12:02 CEST
Changelog: OK

Code review: OK (r53984)

Test: OK
Comment 5 Stefan Gohmann univentionstaff 2014-11-26 06:54:14 CET
UCS 4.0-0 has been released:
 http://docs.univention.de/release-notes-4.0-0-en.html
 http://docs.univention.de/release-notes-4.0-0-de.html

If this error occurs again, please use "Clone This Bug".
Comment 6 Philipp Hahn univentionstaff 2015-08-11 15:53:15 CEST
*** Bug 39065 has been marked as a duplicate of this bug. ***
Comment 7 Philipp Hahn univentionstaff 2015-08-11 15:54:38 CEST
*** Bug 39064 has been marked as a duplicate of this bug. ***