Bug 39065 - Remove /opt/scalix/bin from PATH in /etc/profile template
Remove /opt/scalix/bin from PATH in /etc/profile template
Status: RESOLVED DUPLICATE of bug 32628
Product: UCS
Classification: Unclassified
Component: General
UCS 4.0
Other Linux
: P5 minor (vote)
: ---
Assigned To: Philipp Hahn
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-31 18:50 CEST by Kevin Dominik Korte
Modified: 2015-08-11 15:53 CEST (History)
1 user (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Dominik Korte univentionstaff 2015-07-31 18:50:53 CEST
+++ This bug was initially created as a clone of Bug #39064 +++

For some time now we don't include scalix in UCS anymore, but still have /opt/scalix/bin in the PATH in the /etc/profile template.

As this opens up the possibility of a user creating files in the non existing location and thus opens a way to attack the system.

We thus should remove it from the path.
Comment 1 Philipp Hahn univentionstaff 2015-08-11 15:53:14 CEST
Fixed since UCS-4.0 (Bug #32628)

*** This bug has been marked as a duplicate of bug 32628 ***