Bug 32751 - Add important actions as icon button into data row
Add important actions as icon button into data row
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - Virtual machines (UVMM)
UCS 3.2
Other Linux
: P5 normal (vote)
: UCS 3.2
Assigned To: Florian Best
Dirk Wiesenthal
: interim-3
: 32673 (view as bug list)
Depends on: 26418
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-30 11:29 CEST by Alexander Kläser
Modified: 2013-11-19 06:43 CET (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Flags outvoted after Product Owner Review:
Ticket number:
Bug group (optional): Usability
Max CVSS v3 score:


Attachments
Images are not "centered" (12.55 KB, image/png)
2013-11-01 15:02 CET, Dirk Wiesenthal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kläser univentionstaff 2013-09-30 11:29:19 CEST
Actions have been generally removed from data rows (via Bug 26418). Nevertheless, for an effective handling of VMs, we need icon buttons in data rows that allow a quick start and access to VNC.
Comment 1 Alexander Kläser univentionstaff 2013-10-20 22:17:19 CEST
*** Bug 32673 has been marked as a duplicate of this bug. ***
Comment 2 Florian Best univentionstaff 2013-10-21 09:52:09 CEST
Actions for 'View' and 'Start' have been re added to the columns.
Comment 3 Florian Best univentionstaff 2013-10-21 12:18:49 CEST
interim version - no changelog required
Comment 4 Alexander Kläser univentionstaff 2013-10-22 14:13:30 CEST
(In reply to Florian Best from comment #3)
> interim version - no changelog required

I would opt for mentioning this bug along with the generic adaptation of the grid.
Comment 5 Florian Best univentionstaff 2013-10-23 09:55:07 CEST
*** Bug 32673 has been marked as a duplicate of this bug. ***
Comment 6 Dirk Wiesenthal univentionstaff 2013-10-23 13:54:17 CEST
(In reply to Felix Botner from Bug #32673 comment #1)
> Created attachment 5464 [details]
> umc.png
> 
> The cpu usage bar is only half visible

Still an issue with nodes and RAM bar. Seen on Firefox. Generic issue with the grid since 3.0
Comment 7 Florian Best univentionstaff 2013-10-23 14:05:51 CEST
Quoting Alex from Bug #27041 comment #2
"""Das kann zusammen mit Bug 28073 behoben werden. Einen wirklichen Fix für dojox.grid.EnhancedGrid werden wir nicht machen."""
Comment 8 Florian Best univentionstaff 2013-10-23 14:07:15 CEST
(In reply to Florian Best from comment #7)
> Quoting Alex from Bug #27041 comment #2
> """Das kann zusammen mit Bug 28073 behoben werden. Einen wirklichen Fix für
> dojox.grid.EnhancedGrid werden wir nicht machen."""

Bug #28073 changed to Bug #32027
Comment 9 Dirk Wiesenthal univentionstaff 2013-10-23 14:30:40 CEST
The icons look odd. They are not in the middle of the button.
Comment 10 Florian Best univentionstaff 2013-10-25 11:54:56 CEST
(In reply to Dirk Wiesenthal from comment #9)
> The icons look odd. They are not in the middle of the button.
Seems to be fixed by Bug #32218
Comment 11 Dirk Wiesenthal univentionstaff 2013-11-01 15:02:25 CET
Created attachment 5552 [details]
Images are not "centered"

Images do not look right in FF and IE. Chromium works
Comment 12 Dirk Wiesenthal univentionstaff 2013-11-04 09:05:05 CET
See Comment 11
Comment 13 Alexander Kläser univentionstaff 2013-11-04 10:51:51 CET
(In reply to Dirk Wiesenthal from comment #11)
> Created attachment 5552 [details]
> Images are not "centered"
> 
> Images do not look right in FF and IE. Chromium works

Should be fixed now. The font size needed to be adjusted correctly.

 univention-management-console-frontend (3.0.147-1) unstable; urgency=low
 .
   * Bug #32751: adjust font size for buttons in grid rows
Comment 14 Dirk Wiesenthal univentionstaff 2013-11-04 14:49:38 CET
FF: great, IE: acceptable

VERIFIED
Comment 15 Stefan Gohmann univentionstaff 2013-11-19 06:43:52 CET
UCS 3.2 has been released:
 http://docs.univention.de/release-notes-3.2-en.html
 http://docs.univention.de/release-notes-3.2-de.html

If this error occurs again, please use "Clone This Bug".