Bug 34317 - ucs-overview variables only set when joined
ucs-overview variables only set when joined
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 3.2
Other Linux
: P5 enhancement (vote)
: UCS 3.2-2-errata
Assigned To: Alexander Kramer
Alexander Kläser
:
: 35242 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-11 14:36 CET by Tim Petersen
Modified: 2014-07-14 10:50 CEST (History)
7 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Usability
Max CVSS v3 score:
klaeser: Patch_Available+


Attachments
patch: add an link to the umc-overview so you can also login if the system has not joined yet (1.70 KB, patch)
2014-06-02 11:53 CEST, Alexander Kramer
Details | Diff
updated the patch to include the hints (1.82 KB, patch)
2014-06-10 16:17 CEST, Alexander Kramer
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Petersen univentionstaff 2014-03-11 14:36:40 CET
This means that you don't have intuitive access to UMC after installation if you didn't join your, for example, memberserver.
It could be favorable to access the UMC in order to reach the basic settings (for joining ;) )

management/univention-management-console-frontend/34univention-management-console-web-server.inst:
"
eval "$(ucr shell)"

ucr set ucs/web/overview/entries/admin/umc/icon="/univention-management-console/js/dijit/themes/umc/icons/50x50/univention-management-console.png" \
    ucs/web/overview/entries/admin/umc/label="System and domain settings" \
    ucs/web/overview/entries/admin/umc/label/de="System- und Domäneneinstellungen" \
    ucs/web/overview/entries/admin/umc/description="Univention Management Console for administrating the UCS domain $domainname and the system $hostname" \
    ucs/web/overview/entries/admin/umc/description/de="Univention Management Console für die Verwaltung der UCS-Domäne $domainname und des Systems $hostname" \
    ucs/web/overview/entries/admin/umc/link="/univention-management-console" \
    ucs/web/overview/entries/admin/umc/priority="10" 

/etc/init.d/univention-management-console-web-server restart
"

At the moment, ucs-overview is empty after installation (without join).
Tested this with a UCS 3.2-1 memberserver
Comment 1 Philipp Hahn univentionstaff 2014-04-24 17:42:04 CEST
Again noticed in a Technical Training Session: The overview-page should always provide a link to the local UMC to allow "root" to login to join the system.
Currently http://.../univention-management-console/ has to be entered manually.
Comment 2 Alexander Kläser univentionstaff 2014-05-19 17:34:47 CEST
@Alex: Could you provide a patch for a solution (attached to this bug)?
Comment 3 Alexander Kramer univentionstaff 2014-06-02 11:53:27 CEST
Created attachment 5931 [details]
patch: add an link to the umc-overview so you can also login if the system has not joined yet
Comment 4 Alexander Kramer univentionstaff 2014-06-02 11:57:10 CEST
* did not change 34univention-management-console-web-server.inst, so the following patch will be overwritten if the system joines the domain
* the patch will add the following lines to univention-management-console-frontend.postinst:

----
# set ucs-overview variables - only if they aren't set, so the user can also login even the system has not joined the domain yet
# instead of the normal text the user will see: 'Please login as root to join the domain'
# this text will be overwritten if the system joins the master - see: 34univention-management-console-web-server.inst
ucr set ucs/web/overview/entries/admin/umc/icon?"/univention-management-console/js/dijit/themes/umc/icons/50x50/univention-management-console.png" \
    ucs/web/overview/entries/admin/umc/label?"System and domain settings" \
    ucs/web/overview/entries/admin/umc/label/de?"System- und Domäneneinstellungen" \
    ucs/web/overview/entries/admin/umc/description?"Please login as root to join the domain " \
    ucs/web/overview/entries/admin/umc/description/de?"Bitte loggen Sie sich als Nutzer root ein, um der Domaine beizutreten." \
    ucs/web/overview/entries/admin/umc/link?"/univention-management-console" \
    ucs/web/overview/entries/admin/umc/priority?"10"
/etc/init.d/univention-management-console-web-server restart
Comment 5 Alexander Kläser univentionstaff 2014-06-04 15:29:33 CEST
The patch looks fine. I would suggest the following little changes:

>  ucr set ucs/web/overview/entries/admin/umc/icon?"/univention-management-console/js/dijit/themes/umc/icons/50x50/univention-management-console.png" \
>      ucs/web/overview/entries/admin/umc/label?"System and domain settings" \
>      ucs/web/overview/entries/admin/umc/label/de?"System- und Domäneneinstellungen" \
> -    ucs/web/overview/entries/admin/umc/description?"Please login as root to join the domain " \
> -    ucs/web/overview/entries/admin/umc/description/de?"Bitte loggen Sie sich als Nutzer root ein, um der Domaine beizutreten." \
> -    ucs/web/overview/entries/admin/umc/link?"/univention-management-console" \
> +    ucs/web/overview/entries/admin/umc/description?"Please login as <i>root</i> to join the domain" \
> +    ucs/web/overview/entries/admin/umc/description/de?"Bitte loggen Sie sich als Benutzer <i>root</i> ein, um der Domäne beizutreten" \
> +    ucs/web/overview/entries/admin/umc/link?"/univention-management-console?username=root" \
>      ucs/web/overview/entries/admin/umc/priority?"10"
> -/etc/init.d/univention-management-console-web-server restart
Comment 6 Alexander Kramer univentionstaff 2014-06-10 16:17:37 CEST
Created attachment 5948 [details]
updated the patch to include the hints
Comment 7 Alexander Kläser univentionstaff 2014-06-11 14:06:23 CEST
Patch looks good to me. Can you prepare it as erratum, please?
Comment 8 Alexander Kramer univentionstaff 2014-06-13 12:03:01 CEST
Added patch to svn and adapted yaml file. Package has been build.

univention-management-console-frontend (3.0.152-31)
* Bug #34317: set default link to UMC on UCS overview page
Comment 9 Alexander Kläser univentionstaff 2014-06-19 12:17:14 CEST
(In reply to Alexander Kramer from comment #8)
> Added patch to svn and adapted yaml file. Package has been build.
> 
> univention-management-console-frontend (3.0.152-31)
> * Bug #34317: set default link to UMC on UCS overview page

The suggestions from comment 5 have not been added to the SVN → reopen.

YAML file looks fine :) .
Comment 10 Alexander Kramer univentionstaff 2014-06-23 10:03:44 CEST
Added the suggestions from comment 5 to svn.
Also adapted the YAML file and the package has been build.

univention-management-console-frontend (3.0.152-34)
   * Bug #34317: Adapted the default link on UCS overview page.
Comment 11 Alexander Kläser univentionstaff 2014-07-03 22:25:45 CEST
*** Bug 35242 has been marked as a duplicate of this bug. ***
Comment 12 Alexander Kläser univentionstaff 2014-07-09 15:06:15 CEST
Looks fine now :) → VERIFIED
Comment 13 Moritz Muehlenhoff univentionstaff 2014-07-14 10:50:38 CEST
http://errata.univention.de/ucs/3.2/149.html