Bug 34867 - RADIUS blocks UCS updates
RADIUS blocks UCS updates
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Radius
UCS 3.2
Other Linux
: P5 normal (vote)
: UCS 3.2-2-errata
Assigned To: Dirk Wiesenthal
Felix Botner
:
: 35040 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-05-19 11:15 CEST by Ulf Friedel
Modified: 2014-07-02 11:29 CEST (History)
4 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ulf Friedel 2014-05-19 11:15:10 CEST
After installation of RADIUS by using the App Center, it is impossible to update the UCS system from 3.2-0 to 3.2-1 or 3.2-1 to 3.2-2.

root@master:~# univention-upgrade

Starting univention-upgrade. Current UCS version is 3.2-1 errata111

Checking for local repository:                          none
Checking for release updates:                          An update to UCS 3.2 without the component 'radius' is not possible because the component 'radius' is marked as required.
none
Checking for package updates:                           none
An update to UCS 3.2 without the component 'radius' is not possible because the component 'radius' is marked as required.

The UCR variable repository/online/component/radius/version is set to 'current'.

root@master:~# ucr search --brief repository/online/component/radius/
repository/online/component/.*: <empty>
repository/online/component/radius/description: RADIUS
repository/online/component/radius/localmirror: false
repository/online/component/radius/server: appcenter.software-univention.de
repository/online/component/radius/unmaintained: disabled
repository/online/component/radius/version: current

It seems the configuration of the repository is not correct.

root@master:~# cat /etc/apt/sources.list.d/20_ucs-online-component.list | grep radius
# Configuration error: component not found: radius

The directory of the radius component http://appcenter.software-univention.de/univention-repository/3.2/maintained/component/radius/ is empty.
Comment 1 Stefan Gohmann univentionstaff 2014-06-02 19:59:11 CEST
*** Bug 35040 has been marked as a duplicate of this bug. ***
Comment 2 Stefan Gohmann univentionstaff 2014-06-02 20:03:41 CEST
Could you create an app center radius repository for UCS 3.2 and copy the current univention-radius packages into this repository? I think we should also set WithoutRepository=True in the ini file and remove repository/online/component/radius/version=current in the next app center release.
Comment 3 Dirk Wiesenthal univentionstaff 2014-06-03 14:15:01 CEST
Repository created. Remove component with Appcenter Update: TBD
Comment 4 Dirk Wiesenthal univentionstaff 2014-06-03 17:31:36 CEST
Fixed in
  univention-management-console-module-appcenter 3.0.51-17.251.201406031738

radius component is completely removed from UCR during postinst
Comment 5 Felix Botner univentionstaff 2014-06-10 16:08:26 CEST
OK - radius repo on appcenter for UCS 3.2 
     (update works if radius was installed with its own repo)

OK - repo ucr config is removed during update to
     univention-management-console-module-appcenter 3.0.51-17.251.201406031738

OK - new installation (3.2-2, 3.2-0) of radius app uses UCS repos 
     (WithoutRepository=True)

OK - YAML
Comment 6 Moritz Muehlenhoff univentionstaff 2014-07-02 11:29:18 CEST
http://errata.univention.de/ucs/3.2/133.html