Bug 3490 - univention-ldap-listener-ctrl verbessern
univention-ldap-listener-ctrl verbessern
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Listener (univention-directory-listener)
UCS 3.0
i386 Linux
: P3 enhancement (vote)
: UCS 4.1-2-errata
Assigned To: Philipp Hahn
Arvid Requate
:
: 13973 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-01 09:09 CEST by Arne Brix
Modified: 2016-11-24 20:20 CET (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
fix_error_message.patch (606 bytes, patch)
2016-07-15 00:11 CEST, Arvid Requate
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Arne Brix univentionstaff 2005-08-01 09:09:58 CEST
listener-ctrl koennte mit geringem aufwand deutlich benutzerfreundlicher werden:
1. modulname prüfen, bevor der listener herruntergefahren wird
2. liste der verfügbaren modulnamen im fehlerfall bzw. bei aufruf mit --help
oder ohne Parameter
Comment 1 Arvid Requate univentionstaff 2009-12-21 15:35:17 CET
*** Bug 13973 has been marked as a duplicate of this bug. ***
Comment 2 Philipp Hahn univentionstaff 2016-06-07 18:09:03 CEST
r69892 | Bug #3490 UDL: Improve listener-ctrl

Package: univention-directory-listener
Version: 10.0.0-11.315.201606071717
Branch: ucs_4.1-0
Scope: errata4.1-2

r69910 | Bug #22383,Bug #30227,Bug #30263,Bug #34324,Bug #34507,Bug #34738,Bug #3490,Bug #38696,Bug #39509,Bug #40600,Bug #41261: UDL YAML
 univention-directory-listener.yaml
Comment 3 Arvid Requate univentionstaff 2016-07-15 00:11:19 CEST
Created attachment 7805 [details]
fix_error_message.patch

Looks good, just one minor thing: After resync of a module the tool always returns an error message because UDL only writes the handler status files at daemon exit (which may be a debatable behaviour in itself):

====================================================================
root# univention-directory-listener-ctrl resync reset-sysvol-acls
[...]
root# univention-directory-listener-ctrl modules
[...]
cat: /var/lib/univention-directory-listener/handlers/reset-sysvol-acls: Datei oder Verzeichnis nicht gefunden
0       reset-sysvol-acls       /usr/lib/univention-directory-listener/system/reset-sysvol-acls.py
[...]
====================================================================

The attached patch should fix this.

Advisory: Ok
Comment 4 Philipp Hahn univentionstaff 2016-07-18 17:52:59 CEST
r71060 | Bug #3490 UDL: Silence udl-ctrl

Package: univention-directory-listener
Version: 10.0.0-14.325.201607181745
Branch: ucs_4.1-0
Scope: errata4.1-2

r71075 | Bug #40600,Bug #41261,Bug #34324,Bug #3490 UDL: YAML
 univention-directory-listener.yaml
Comment 5 Arvid Requate univentionstaff 2016-07-18 18:22:03 CEST
Code review: Ok
Functional test: Ok
Advisory: Ok
Comment 6 Janek Walkenhorst univentionstaff 2016-07-21 15:15:52 CEST
<http://errata.software-univention.de/ucs/4.1/215.html>