Bug 35138 - Migrate base packages to UCS 4
Migrate base packages to UCS 4
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: General
UCS 3.2
Other Linux
: P5 enhancement (vote)
: UCS 4.0
Assigned To: Stefan Gohmann
Felix Botner
: interim-1
: 35522 (view as bug list)
Depends on:
Blocks: 45325
  Show dependency treegraph
 
Reported: 2014-06-17 13:32 CEST by Stefan Gohmann
Modified: 2017-09-05 12:52 CEST (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2014-06-17 13:32:01 CEST
The following base packages should be migrated to UCS 4:

 - univention-archive-key
 - univention-base-files
 - univention-config-registry
 - univention-debug
 - univention-errata-level
 - univention-firewall
 - univention-grub
 - univention-home-mounter
 - univention-initrd
 - univention-ipcalc
 - univention-lib
 - univention-licence
 - univention-maintenance
 - univention-network-manager
 - univention-newsid
 - univention-pam
 - univention-policy
 - univention-printclient
 - univention-python
 - univention-python-heimdal
 - univention-quota
 - univention-runit
 - univention-server
 - univention-showload
 - univention-skel
 - univention-ssh
 - univention-ssl
Comment 1 Stefan Gohmann univentionstaff 2014-06-18 06:29:19 CEST
The following packages have been migrated and built:

>  - univention-config-registry
>  - univention-debug
>  - univention-lib
>  - univention-policy
>  - univention-python

Still missing:

>  - univention-archive-key
>  - univention-base-files
>  - univention-errata-level
>  - univention-firewall
>  - univention-grub
>  - univention-home-mounter
>  - univention-initrd
>  - univention-ipcalc
>  - univention-licence
>  - univention-maintenance
>  - univention-network-manager
>  - univention-newsid
>  - univention-pam
>  - univention-printclient
>  - univention-python-heimdal
>  - univention-quota
>  - univention-runit
>  - univention-server
>  - univention-showload
>  - univention-skel
>  - univention-ssh
>  - univention-ssl
Comment 2 Stefan Gohmann univentionstaff 2014-06-30 09:20:44 CEST
(In reply to Stefan Gohmann from comment #1)
> The following packages have been migrated and built:
> >  - univention-showload

univention-showload is no longer needed. I've added a changelog note: r51355
Comment 3 Stefan Gohmann univentionstaff 2014-06-30 10:17:29 CEST
These packages have been built:
> >  - univention-base-files
> >  - univention-errata-level
> >  - univention-grub
> >  - univention-home-mounter
> >  - univention-initrd
> >  - univention-ipcalc
> >  - univention-licence
> >  - univention-maintenance
> >  - univention-network-manager
> >  - univention-newsid
> >  - univention-pam
> >  - univention-printclient
> >  - univention-python-heimdal
> >  - univention-runit
> >  - univention-server
> >  - univention-skel
> >  - univention-ssh
> >  - univention-ssl

These packages need univention-managemet-console-dev which has not been built:
> >  - univention-firewall
> >  - univention-quota

Still missing:
> >  - univention-archive-key
Comment 4 Florian Best univentionstaff 2014-07-16 10:44:13 CEST
(In reply to Stefan Gohmann from comment #3)
> These packages need univention-managemet-console-dev which has not been
> built:
> > >  - univention-firewall
> > >  - univention-quota
univention-managemet-console-dev is built now. I built the 2 packages.
Comment 5 Florian Best univentionstaff 2014-07-22 10:08:58 CEST
univention-debootstrap still has debian/compat == 7
Comment 6 Stefan Gohmann univentionstaff 2014-07-23 13:19:24 CEST
(In reply to Stefan Gohmann from comment #3)
> These packages need univention-managemet-console-dev which has not been
> built:
> > >  - univention-firewall
> > >  - univention-quota

univention-quota is currently not installable. I've moved univention-management-console-module-quota from depends to recommends in univention-management-console: r52104
Comment 7 Florian Best univentionstaff 2014-07-28 08:29:38 CEST
base/univention-firewall/debian/control
6:XS-Python-Version: 2.6
base/univention-base-files/debian/control
9:XS-Python-Version: 2.6
→ missing 2.7
Comment 8 Philipp Hahn univentionstaff 2014-08-18 19:51:59 CEST
r52785 | Bug #35138 ipcalc: Fix python2.7 support for UCS-4.0
Package: univention-ipcalc
Version: 6.0.0-2.31.201408181944
Branch: ucs_4.0-0
Comment 9 Philipp Hahn univentionstaff 2014-08-19 08:03:47 CEST
r52786 | Bug #35138 server: Remove dependency on univention-showload
Package: univention-server
Version: 10.0.0-2.205.201408182033
Branch: ucs_4.0-0
Comment 10 Stefan Gohmann univentionstaff 2014-08-20 07:50:01 CEST
*** Bug 35522 has been marked as a duplicate of this bug. ***
Comment 11 Stefan Gohmann univentionstaff 2014-08-21 13:38:45 CEST
univention-server: r52899
 * Don't set specific bootsplash theme for every server role
Comment 12 Stefan Gohmann univentionstaff 2014-08-25 08:31:40 CEST
I've added a changelog for all migrated packages: r52983
Comment 13 Stefan Gohmann univentionstaff 2014-08-26 06:56:57 CEST
I've removed Univention Thin Client from /etc/issue in univention-base-files: r53016
Comment 14 Stefan Gohmann univentionstaff 2014-08-26 17:54:17 CEST
Updated UCR templates:
 r53042: univention-base-files
 r53043: univention-grub
 r53044: univention-pam
 r53046: univention-quota
Comment 15 Stefan Gohmann univentionstaff 2014-08-27 07:50:30 CEST
Base packages have been migrated.
Comment 16 Felix Botner univentionstaff 2014-09-02 12:43:10 CEST
OK - univention-archive-key
OK - univention-base-files
OK - univention-config-registry
OK - univention-debug
OK - univention-errata-level
OK - univention-firewall
OK - univention-grub
OK - univention-home-mounter
OK - univention-initrd
OK - univention-ipcalc
OK - univention-lib
OK - univention-licence
OK - univention-maintenance
OK - univention-network-manager
OK - univention-newsid
OK - univention-pam
 - univention-policy
OK - univention-printclient
OK - univention-python
OK - univention-python-heimdal
OK - univention-quota
OK - univention-runit
OK - univention-server
OK - univention-showload (removed)
OK - univention-skel
OK - univention-ssh
OK - univention-ssl

OK - Changelog
Comment 17 Stefan Gohmann univentionstaff 2014-11-26 06:55:57 CET
UCS 4.0-0 has been released:
 http://docs.univention.de/release-notes-4.0-0-en.html
 http://docs.univention.de/release-notes-4.0-0-de.html

If this error occurs again, please use "Clone This Bug".