Bug 35522 - Update base-files for Update to Debian Wheezy
Update base-files for Update to Debian Wheezy
Status: CLOSED DUPLICATE of bug 35138
Product: UCS
Classification: Unclassified
Component: univention-base-files
UCS 4.0
All Linux
: P5 normal (vote)
: UCS 4.0
Assigned To: Bugzilla Mailingliste
: interim-2
Depends on:
Blocks: 35435
  Show dependency treegraph
 
Reported: 2014-07-30 15:26 CEST by Philipp Hahn
Modified: 2014-11-26 06:54 CET (History)
1 user (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Hahn univentionstaff 2014-07-30 15:26:43 CEST
Several files over-written by univention-base-files have been updated by the Debian Wheezy; the updates Debian files need to be back-merged into out template files.

This for example currently breaks ifupdown, as /etc/network/run -> /run/network is danling, as /run/ is a tmpfs, which is (by design) empty after reboot. Code has been added to several /etc/init.d/ scripts to create those missing files/directories on each start.
Comment 1 Philipp Hahn univentionstaff 2014-07-30 16:55:25 CEST
r52393 | Bug #35522 base-files: Update templates for /etc/init.d/ files
Update init scripts of cron, klogd, networking, openbsd-inetd from Debian Wheezy.

Package: univention-base-files
Version: 4.0.0-4.165.201407301552
User: phahn
Branch: ucs_4.0-0

More to do later...
Comment 2 Stefan Gohmann univentionstaff 2014-08-20 07:50:01 CEST
This is part of Bug #35138

*** This bug has been marked as a duplicate of bug 35138 ***
Comment 3 Stefan Gohmann univentionstaff 2014-09-30 09:46:47 CEST
Duplicate.
Comment 4 Stefan Gohmann univentionstaff 2014-11-26 06:54:04 CET
UCS 4.0-0 has been released:
 http://docs.univention.de/release-notes-4.0-0-en.html
 http://docs.univention.de/release-notes-4.0-0-de.html

If this error occurs again, please use "Clone This Bug".