Bug 35145 - Migrate UMC to UCS 4
Migrate UMC to UCS 4
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 3.2
Other Linux
: P5 enhancement (vote)
: UCS 4.0
Assigned To: Florian Best
Alexander Kramer
: interim-1
: 31098 (view as bug list)
Depends on:
Blocks: 35396
  Show dependency treegraph
 
Reported: 2014-06-18 06:38 CEST by Stefan Gohmann
Modified: 2014-11-26 06:54 CET (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
Patch for build option (986 bytes, patch)
2014-07-17 16:42 CEST, Alexander Kläser
Details | Diff
Modified build_profile.js (1.87 KB, text/plain)
2014-07-18 16:51 CEST, Alexander Kläser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2014-06-18 06:38:40 CEST
The UMC packages should be migrated to UCS 4:

univention-management-console
univention-management-console-frontend
univention-management-console-frontend-doc
univention-management-console-module-adtakeover
univention-management-console-module-appcenter
univention-management-console-module-ipchange
univention-management-console-module-lib
univention-management-console-module-luga
univention-management-console-module-mrtg
univention-management-console-module-reboot
univention-management-console-module-services
univention-management-console-module-top
univention-management-console-module-ucr
univention-management-console-module-udm
univention-management-console-module-vnc

Please consider the package migration list:

https://hutten.knut.univention.de/mediawiki/index.php/UCS-4.0_Univention_Package_Update
Comment 1 Stefan Gohmann univentionstaff 2014-06-18 07:10:23 CEST
These packages should not be migrated in the first step:

> univention-management-console-frontend-doc
> univention-management-console-module-luga
> univention-management-console-module-vnc
Comment 2 Stefan Gohmann univentionstaff 2014-07-09 06:30:51 CEST
(In reply to Stefan Gohmann from comment #0)
> univention-management-console-module-appcenter

We should use the test app center during UCS 4 development.
Comment 3 Stefan Gohmann univentionstaff 2014-07-09 09:27:02 CEST
(In reply to Stefan Gohmann from comment #2)
> (In reply to Stefan Gohmann from comment #0)
> > univention-management-console-module-appcenter
> 
> We should use the test app center during UCS 4 development.

As discussed offline, we will use the normal app center. We should copy our system components to the UCS 4 app center: Bug #35322
Comment 4 Florian Best univentionstaff 2014-07-16 11:09:10 CEST
while installing univention-management-console-server
→ Exception TypeError: "'NoneType' object is not callable" in <function _removeHandlerRef at 0x7fcf5c73ecf8> ignored
Comment 5 Florian Best univentionstaff 2014-07-16 11:47:06 CEST
The following packages have been migrated and built:
> univention-management-console-module-adtakeover
> univention-management-console-module-appcenter
> univention-management-console-module-ipchange
> univention-management-console-module-lib
> univention-management-console-module-mrtg
> univention-management-console-module-reboot
> univention-management-console-module-services
> univention-management-console-module-top
> univention-management-console-module-ucr
> univention-management-console

Pending packages:
> univention-management-console-frontend
→ currently dependency problems to nodejs. Have to decide if we use the version from wheezy-backports or making a own package.
> univention-management-console-module-udm
base/univention-system-setup
base/univention-join
Comment 6 Moritz Muehlenhoff univentionstaff 2014-07-16 13:39:31 CEST
nodejs (along with the reverse deps gyp and libv8-3.14) were imported/built from wheezy-backports. 

They are only used as build dependencies to preprocess CSS files (so they end up in unmaintained).
Comment 7 Florian Best univentionstaff 2014-07-16 14:57:44 CEST
(In reply to Florian Best from comment #5)
> Pending packages:
> > univention-management-console-frontend
> → currently dependency problems to nodejs. Have to decide if we use the
> version from wheezy-backports or making a own package.
→ See comment #6, nodejs has been built

> > univention-management-console-module-udm
> base/univention-join
→ migrated and built

> base/univention-system-setup
→ migrated, not built yet (Bug #34484)
Comment 8 Florian Best univentionstaff 2014-07-17 11:05:47 CEST
All packages have successfully built.

On the initial installation of the appcenter the following traceback occurs:
Entpacken von univention-management-console-module-apps (aus .../univention-management-console-module-apps_4.0.0-1.258.201407161011_all.deb) ...
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: No module named appcenter.app_center

Should we hide it?

The UMC-Server is currently not working, it crashes at startup with the traceback:
17.07.14 11:08:57.449  MAIN        ( ERROR   ) : Traceback (most recent call last):
  File "/usr/sbin/univention-management-console-server", line 209, in <module>
    umc_daemon.do_action()
  File "/usr/lib/pymodules/python2.7/daemon/runner.py", line 186, in do_action
    func(self)
  File "/usr/lib/pymodules/python2.7/daemon/runner.py", line 131, in _start
    self.app.run()
  File "/usr/sbin/univention-management-console-server", line 189, in run
    self.server = Server( port = self.options.port )
  File "/usr/lib/pymodules/python2.7/univention/management/console/protocol/server.py", line 455, in __init__
    notifier.socket_add( self.connection, self._connection )
  File "/usr/lib/pymodules/python2.7/notifier/nf_generic.py", line 93, in socket_add
    raise AttributeError( 'could not get file description: %s' % id )
AttributeError: could not get file description: <OpenSSL.SSL.Connection object at 0x2575ef0>
Comment 9 Florian Best univentionstaff 2014-07-17 11:39:46 CEST
(In reply to Florian Best from comment #8)
> The UMC-Server is currently not working, it crashes at startup with the
> traceback:
> 17.07.14 11:08:57.449  MAIN        ( ERROR   ) : Traceback (most recent call
> last):
>   File "/usr/sbin/univention-management-console-server", line 209, in
> <module>
>     umc_daemon.do_action()
>   File "/usr/lib/pymodules/python2.7/daemon/runner.py", line 186, in
> do_action
>     func(self)
>   File "/usr/lib/pymodules/python2.7/daemon/runner.py", line 131, in _start
>     self.app.run()
>   File "/usr/sbin/univention-management-console-server", line 189, in run
>     self.server = Server( port = self.options.port )
>   File
> "/usr/lib/pymodules/python2.7/univention/management/console/protocol/server.
> py", line 455, in __init__
>     notifier.socket_add( self.connection, self._connection )
>   File "/usr/lib/pymodules/python2.7/notifier/nf_generic.py", line 93, in
> socket_add
>     raise AttributeError( 'could not get file description: %s' % id )
> AttributeError: could not get file description: <OpenSSL.SSL.Connection
> object at 0x2575ef0>
This is a error in python-notifier which doesn't support Python2.7 SSL sockets.
I fixed it and made a pull request on github: https://github.com/crunchy-github/python-notifier/pull/7

Well, I guess we have to make a QA for python-notifiers functionality especially the computeroom module.
Comment 10 Florian Best univentionstaff 2014-07-17 13:59:22 CEST
(In reply to Florian Best from comment #4)
> while installing univention-management-console-server
> → Exception TypeError: "'NoneType' object is not callable" in <function
> _removeHandlerRef at 0x7fcf5c73ecf8> ignored
The exception is printed out 12 times when calling "univention-management-console-server --help". 
When i uncomment the following line in univention/management/console/log.py:
> self._fallbackLogger.addHandler(fallbackLoggingHandler)
the exceptions doesn't occur.
Comment 11 Florian Best univentionstaff 2014-07-17 14:36:35 CEST
(In reply to Florian Best from comment #10)
→ Bug #35396

AppCenter Components → Bug #35322

python-notifier has been fixed.

Every package is migrated and built.
Comment 12 Alexander Kläser univentionstaff 2014-07-17 16:42:17 CEST
Created attachment 5999 [details]
Patch for build option

Florian, could you apply the attached patch for the build process? Setting the build optimizer to closure enables dead code removal and the creation of source map files. The latter one is especially of interest to us as this enables to debug minimized (a.k.a. uglified) JavaScript production code. Source maps offer a mapping between the minimized code and the original code, this works in FF as well as in Chrome(/-ium).

See also: http://www.html5rocks.com/en/tutorials/developertools/sourcemaps/
Comment 13 Florian Best univentionstaff 2014-07-18 08:27:57 CEST
(In reply to Alexander Kläser from comment #12)
> Created attachment 5999 [details]
> Patch for build option
> 
> Florian, could you apply the attached patch for the build process? Setting
> the build optimizer to closure enables dead code removal and the creation of
> source map files. The latter one is especially of interest to us as this
> enables to debug minimized (a.k.a. uglified) JavaScript production code.
> Source maps offer a mapping between the minimized code and the original
> code, this works in FF as well as in Chrome(/-ium).
> 
> See also: http://www.html5rocks.com/en/tutorials/developertools/sourcemaps/

Yes, has been integrated in univention-management-console-frontend 4.0.0-5.843.201407180804.
Comment 14 Alexander Kläser univentionstaff 2014-07-18 16:51:04 CEST
Created attachment 6002 [details]
Modified build_profile.js

(In reply to Florian Best from comment #13)
> Yes, has been integrated in univention-management-console-frontend
> 4.0.0-5.843.201407180804.

dojo.js.map is currently not build, I adjusted the build profile and now it seems to work.
Comment 15 Florian Best univentionstaff 2014-07-21 15:29:44 CEST
(In reply to Alexander Kläser from comment #14)
> Created attachment 6002 [details]
> Modified build_profile.js
> 
> (In reply to Florian Best from comment #13)
> > Yes, has been integrated in univention-management-console-frontend
> > 4.0.0-5.843.201407180804.
> 
> dojo.js.map is currently not build, I adjusted the build profile and now it
> seems to work.
Yes, patch integrated.
Comment 16 Stefan Gohmann univentionstaff 2014-08-25 08:32:40 CEST
I've added a changelog for all migrated packages: r52983
Comment 17 Florian Best univentionstaff 2014-08-29 10:19:07 CEST
/var/www/statistik/.htaccess: Invalid command 'AuthPAM_Service', perhaps misspelled or defined by a module not included in the server configuration
Comment 18 Florian Best univentionstaff 2014-08-29 10:30:51 CEST
(In reply to Florian Best from comment #17)
> /var/www/statistik/.htaccess: Invalid command 'AuthPAM_Service', perhaps
> misspelled or defined by a module not included in the server configuration
Well, this was caused because libapache2-mod-auth-pam was not yet migrated (which now is).
Comment 19 Florian Best univentionstaff 2014-08-29 11:23:44 CEST
some copyrights have been updated.
Comment 20 Alexander Kramer univentionstaff 2014-08-29 15:07:37 CEST
Checked all packages:

OK - hashbang
OK - control
OK - compat
OK - python support
OK - changelog
OK - copyright
OK - conffiles
OK - (re)installation
Comment 21 Florian Best univentionstaff 2014-09-05 13:49:11 CEST
I removed also the category 'system' from the module ipchange as it caused a HTTP 404 error when starting UMC but the module only for backend purposes.
Revision 53399
univention-management-console-module-ipchange (3.0.0-3) 
* Bug #35145: remove module category as this module is only for backend purpose
Comment 22 Florian Best univentionstaff 2014-09-30 18:07:43 CEST
*** Bug 31098 has been marked as a duplicate of this bug. ***
Comment 23 Stefan Gohmann univentionstaff 2014-11-26 06:54:55 CET
UCS 4.0-0 has been released:
 http://docs.univention.de/release-notes-4.0-0-en.html
 http://docs.univention.de/release-notes-4.0-0-de.html

If this error occurs again, please use "Clone This Bug".