Bug 35396 - TypeError: "'NoneType' object is not callable" in <function > _removeHandlerRef at 0x7fcf5c73ecf8> ignored
TypeError: "'NoneType' object is not callable" in <function > _removeHandlerR...
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 4.0
Other Linux
: P5 enhancement (vote)
: UCS 4.0
Assigned To: Dirk Wiesenthal
Florian Best
: interim-3
: 36264 (view as bug list)
Depends on: 35145
Blocks:
  Show dependency treegraph
 
Reported: 2014-07-17 14:32 CEST by Florian Best
Modified: 2014-11-26 06:54 CET (History)
6 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2014-07-17 14:32:40 CEST
(In reply to Florian Best from Bug #35145 comment #4)
> while installing univention-management-console-server
> → Exception TypeError: "'NoneType' object is not callable" in <function
> _removeHandlerRef at 0x7fcf5c73ecf8> ignored
The exception is printed out 12 times when calling
"univention-management-console-server --help". 
When i uncomment the following line in univention/management/console/log.py:
> self._fallbackLogger.addHandler(fallbackLoggingHandler)
the exceptions doesn't occur.

+++ This bug was initially created as a clone of Bug #35145 +++
###################################################################
root@master99:~# univention-management-console-server --help
Usage: univention-management-console-server [options]

Options:
  -h, --help            show this help message and exit
  -n, --no-daemon       if set the process will not fork into the background
  -p PORT, --port=PORT  defines an alternative port number [default 6670]
  -l LANGUAGE, --language=LANGUAGE
                        defines the language to use [default: de_DE.UTF-8]
  -d DEBUG, --debug=DEBUG
                        if given than debugging is activated and set to the
                        specified level [default: 2]
  -L LOGFILE, --log-file=LOGFILE
                        specifies an alternative log file [default:
                        management-console-server]
Exception TypeError: "'NoneType' object is not callable" in <function _removeHandlerRef at 0x7fe46577ced8> ignored
Exception TypeError: "'NoneType' object is not callable" in <function _removeHandlerRef at 0x7fe46577ced8> ignored
Exception TypeError: "'NoneType' object is not callable" in <function _removeHandlerRef at 0x7fe46577ced8> ignored
Exception TypeError: "'NoneType' object is not callable" in <function _removeHandlerRef at 0x7fe46577ced8> ignored
Exception TypeError: "'NoneType' object is not callable" in <function _removeHandlerRef at 0x7fe46577ced8> ignored
Exception TypeError: "'NoneType' object is not callable" in <function _removeHandlerRef at 0x7fe46577ced8> ignored
Exception TypeError: "'NoneType' object is not callable" in <function _removeHandlerRef at 0x7fe46577ced8> ignored
Exception TypeError: "'NoneType' object is not callable" in <function _removeHandlerRef at 0x7fe46577ced8> ignored
Exception TypeError: "'NoneType' object is not callable" in <function _removeHandlerRef at 0x7fe46577ced8> ignored
Exception TypeError: "'NoneType' object is not callable" in <function _removeHandlerRef at 0x7fe46577ced8> ignored
Exception TypeError: "'NoneType' object is not callable" in <function _removeHandlerRef at 0x7fe46577ced8> ignored
#########################################################################
Comment 1 Dirk Wiesenthal univentionstaff 2014-07-21 13:08:33 CEST
/usr/lib/python2.7/logging/__init__.py

def _removeHandlerRef(wr):
    """  
    Remove a handler reference from the internal cleanup list.
    """
    # This function can be called during module teardown, when globals are
    # set to None. If _acquireLock is None, assume this is the case and do
    # nothing.
    if _acquireLock is not None:
        _acquireLock()
        try: 
            if wr in _handlerList:
                _handlerList.remove(wr)
        finally:
            _releaseLock()

Seems like _releaseLock has already been deleted (but not yet _acquireLock)? Not sure how to fix this in our code.
Comment 2 Erik Damrose univentionstaff 2014-09-03 14:36:53 CEST
This also occurs during umc-server reload with 
# invoke-rc.d univention-management-console-server reload
Comment 3 Felix Botner univentionstaff 2014-10-22 10:02:43 CEST
*** Bug 36264 has been marked as a duplicate of this bug. ***
Comment 4 Dirk Wiesenthal univentionstaff 2014-10-28 10:43:37 CET
I think this is purely cosmetical. Fixed in
  univention-management-console-module-top 4.1.0-3.33.201410241612

by just initializing the Logger differently (correctly). No changelog required
Comment 5 Dirk Wiesenthal univentionstaff 2014-10-28 11:07:26 CET
Sorry, I meant
  univention-management-console 7.1.55-2.820.201410281100
Comment 6 Florian Best univentionstaff 2014-11-03 20:39:46 CET
yep
Comment 7 Stefan Gohmann univentionstaff 2014-11-26 06:54:23 CET
UCS 4.0-0 has been released:
 http://docs.univention.de/release-notes-4.0-0-en.html
 http://docs.univention.de/release-notes-4.0-0-de.html

If this error occurs again, please use "Clone This Bug".