Bug 35496 - Skip location setting in USS
Skip location setting in USS
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UCS Installer
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.0
Assigned To: Philipp Hahn
Felix Botner
: interim-1
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-07-28 15:50 CEST by Philipp Hahn
Modified: 2014-11-26 06:54 CET (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
Drop locale/keymap from univention-base-files (10.16 KB, patch)
2014-07-31 16:04 CEST, Philipp Hahn
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Hahn univentionstaff 2014-07-28 15:50:56 CEST
Has already been chosen in d-i
Comment 1 Sönke Schwardt-Krummrich univentionstaff 2014-07-31 12:07:22 CEST
USS should hide this widget if directly started from d-i. But on next reboot (e.g. USS has been stopped via Strg-Q) it should be shown again.
Comment 2 Philipp Hahn univentionstaff 2014-07-31 16:03:53 CEST
r13298: Copy keyboard setting Xkb* from debconf to UCR

Package: console-setup
Version: 1.88.23.201407311431
User: phahn
Branch: ucs_4.0-0

Please note that "install-keymap" is no longer used with Debian-Wheezy and as such the UCRV "locale/keymap" should be deprecated. The new way is to configure the keyboard though "/etc/default/keyboard" by setting the UCRVs "xorg/keyboard/options/Xkb*". This file in then read by both the X11 server and by "setupcon --force --save" for the Linux console.
"univention-base-files" needs to be updated to no longer call "install-keymap" when "locale/keymap" changes, but to call "setupcon --force --save" instead when one of the Xkb UCRVs changes.
But USS still uses a hard-coded list of keyboard layout (./usr/share/univention-system-setup/locale/all-kmaps) and sets "locale/keymap". It would have to be changed too, so skipping that for now.
The original chosen layout is onyl stored in /var/log/installer/cdebconf/questions.dat # keyboard-configuration/layoutcode; there is no mapping back from the Xkb values to it.

USS is currently not updating xorg/keyboard/options/XkbModel=pc105, so setupcon does not work.
Comment 3 Philipp Hahn univentionstaff 2014-07-31 16:04:26 CEST
Created attachment 6033 [details]
Drop locale/keymap from univention-base-files
Comment 4 Stefan Gohmann univentionstaff 2014-08-01 06:51:14 CEST
System setup now starts with an traceback:

Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/univention/management/console/modules/__init__.py", line 218, in execute
    func( request )
  File "/usr/lib/pymodules/python2.7/univention/management/console/modules/decorators.py", line 305, in _response
    result = _multi_response(self, request)
  File "/usr/lib/pymodules/python2.7/univention/management/console/modules/decorators.py", line 432, in _response
    for res in function(self, iterator, *nones):
  File "/usr/lib/pymodules/python2.7/univention/management/console/modules/decorators.py", line 271, in _fake_func
    yield function(self, *args)
  File "/usr/lib/pymodules/python2.7/univention/management/console/modules/setup/__init__.py", line 136, in save_keymap
    xkeymap = util._xkeymap(keymap)
  File "/usr/lib/pymodules/python2.7/univention/management/console/modules/setup/util.py", line 153, in _xkeymap
    xkeymap['layout'] = line_split[2].split(' ')[0]
IndexError: list index out of range
Comment 5 Sönke Schwardt-Krummrich univentionstaff 2014-08-13 16:08:34 CEST
(In reply to Stefan Gohmann from comment #4)
> System setup now starts with an traceback:

Added a temporary workaround by copying the old file "all-kmaps" from UCS 3.2-3 to UCS 4.0-0.
Comment 6 Stefan Gohmann univentionstaff 2014-08-26 18:00:01 CEST

*** This bug has been marked as a duplicate of bug 35685 ***
Comment 7 Philipp Hahn univentionstaff 2014-08-27 10:59:14 CEST
See Bug #35709, where we need to decide how to handle the new keyboard configuration in univention-system-setup
Comment 8 Felix Botner univentionstaff 2014-08-27 11:31:44 CEST
OK - during installation console-setup sets the xorg/keyboard/options/Xkb UCR vars
OK - Changelog
Comment 9 Stefan Gohmann univentionstaff 2014-11-26 06:54:57 CET
UCS 4.0-0 has been released:
 http://docs.univention.de/release-notes-4.0-0-en.html
 http://docs.univention.de/release-notes-4.0-0-de.html

If this error occurs again, please use "Clone This Bug".