Bug 35685 - Disable system setup fields and pages
Disable system setup fields and pages
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: System setup
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.0
Assigned To: Florian Best
Felix Botner
: interim-1
: 35657 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-08-22 07:55 CEST by Stefan Gohmann
Modified: 2014-11-26 06:56 CET (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2014-08-22 07:55:20 CEST
During the installation we need the option to disable the following fields and pages:

- Page: UCS setup (First page)
- Page: Localization settings
- Input field: Password + Password (retype)
- Input fields: network (DHCP, IP address, IP ne mask, Gateway, Nameservers, Proxy)

Currently, we have these UCR variables:
 system/setup/boot/pages/blacklist 
 system/setup/boot/pages/whitelist

I think the whitelist option can be removed with UCS 4 and a variable like system/setup/boot/fiels/blacklist can be added.
Comment 1 Stefan Gohmann univentionstaff 2014-08-22 08:17:46 CEST
*** Bug 35657 has been marked as a duplicate of this bug. ***
Comment 2 Florian Best univentionstaff 2014-08-26 09:15:46 CEST
Why should proxy/http be hidden? It currently cannot be configured in debian-installer so shouldn't it be configurable in USS-wizard?
Comment 3 Stefan Gohmann univentionstaff 2014-08-26 09:28:35 CEST
(In reply to Florian Best from comment #2)
> Why should proxy/http be hidden? It currently cannot be configured in
> debian-installer so shouldn't it be configurable in USS-wizard?

I thought the proxy configuration is part of the debian-installer network configuration. But it seems to be part of the mirror configuration which we removed from the debian-installer. In this case the proxy configuration can be part of the USS wizard.
Comment 4 Florian Best univentionstaff 2014-08-26 11:48:47 CEST
In Bug #34484 was Wizard.isPageVisible introduced which had some functionality missing, fixed in:
univention-management-console-frontend (4.0.3-1) 
* Bug #35685: fix hasPrevious() hasNext() next() and previous() methods for
Wizards which have the first or last page invisible. This fixes also
displaying of back/next buttons.
Comment 5 Florian Best univentionstaff 2014-08-26 14:06:26 CEST
The installer also doesn't ask for dns/forwarder1. I'll add that field, too.
Comment 6 Florian Best univentionstaff 2014-08-26 15:24:53 CEST
(In reply to Florian Best from comment #4)
Code snippet for QA:
w = new require('umc/widgets/Wizard')({
 pages: [{name: 'first'}, {name: 'second'}, {name: 'third'}, {name: 'fourth'}],
 isPageVisible: function(pageName) {
   return {third: true}[pageName];
 }
});
console.log(w.hasNext('first'),w.hasNext('second'),!w.hasNext('third'),!w.hasNext('fourth'));
console.log(!w.hasPrevious('first'),!w.hasPrevious('second'),!w.hasPrevious('third'),w.hasPrevious('fourth'));



Should the first page be visible as it currently is (with all widgets hidden) (maybe with modified text?) or completely hidden?
Comment 7 Florian Best univentionstaff 2014-08-26 15:38:28 CEST
ucr set system/setup/boot/fields/blacklist='password network locale' system/setup/boot/pages/blacklist='locale'

Package: univention-system-setup
Version: 8.0.26-1.645.201408261448
Comment 8 Florian Best univentionstaff 2014-08-26 16:13:21 CEST
The first page is now also hidden.
Comment 9 Stefan Gohmann univentionstaff 2014-08-26 17:59:52 CEST
*** Bug 35498 has been marked as a duplicate of this bug. ***
Comment 10 Stefan Gohmann univentionstaff 2014-08-26 17:59:57 CEST
*** Bug 35497 has been marked as a duplicate of this bug. ***
Comment 11 Stefan Gohmann univentionstaff 2014-08-26 18:00:01 CEST
*** Bug 35496 has been marked as a duplicate of this bug. ***
Comment 12 Florian Best univentionstaff 2014-08-27 14:00:32 CEST
nameserver should be removed again.
Comment 13 Florian Best univentionstaff 2014-08-27 15:04:57 CEST
(In reply to Florian Best from comment #12)
> nameserver should be removed again.
removed in svn r53091. Package currently builds. univention-system-setup (8.0.30-1)
Comment 14 Felix Botner univentionstaff 2014-08-27 16:50:51 CEST
FAIL - Changelog?

OK - installer mode (pages/blacklist fields/blacklist are disable)
OK - appliance mode (everything enabled)
Comment 15 Florian Best univentionstaff 2014-08-27 17:20:31 CEST
(In reply to Felix Botner from comment #14)
> FAIL - Changelog?
> 
> OK - installer mode (pages/blacklist fields/blacklist are disable)
> OK - appliance mode (everything enabled)
Changelog entry has been added.

* The summary should not display values which are hidden
* The domainname for a DC slave,backup,member is correctly guessed if no FQDN was entered.
* If the nameserver is not reachable the FQDN must be entered.
* dns/forwarder[12] should be visible for non-masters
Comment 16 Florian Best univentionstaff 2014-08-27 17:34:53 CEST
* the help texts are also replaced
Comment 17 Felix Botner univentionstaff 2014-08-28 11:05:55 CEST
FAIL - please remove the dns/forwarder for member-servers

OK - master backup/slave/member with dhcp/static network configuration
OK - Changelog
Comment 18 Florian Best univentionstaff 2014-09-01 17:11:48 CEST
forwarder will now be hidden on memberserver
Comment 19 Felix Botner univentionstaff 2014-09-02 16:42:05 CEST
OK
Comment 20 Stefan Gohmann univentionstaff 2014-11-26 06:56:00 CET
UCS 4.0-0 has been released:
 http://docs.univention.de/release-notes-4.0-0-en.html
 http://docs.univention.de/release-notes-4.0-0-de.html

If this error occurs again, please use "Clone This Bug".