Bug 35657 - Skip some setting in USS
Skip some setting in USS
Status: CLOSED DUPLICATE of bug 35685
Product: UCS
Classification: Unclassified
Component: System setup
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.0
Assigned To: UCS maintainers
Felix Botner
: interim-1
Depends on: 35495 35497 35498
Blocks:
  Show dependency treegraph
 
Reported: 2014-08-20 09:42 CEST by Philipp Hahn
Modified: 2018-04-14 13:37 CEST (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Hahn univentionstaff 2014-08-20 09:42:59 CEST
+++ This bug was initially created as a clone of Bug #35495 +++
Has already been chosen in d-i
UMC should skip asking for it.
Comment 1 Philipp Hahn univentionstaff 2014-08-21 18:57:02 CEST
During a fresh installation certain settings are already queries by d-i:
 root-Password: /var/lib/univention-ldap/root-secret
 locale: UCRV locale & locale/default
 location: keyboard-layout in UCRVs xorg/keyboard/options/Xkb{Model,Layout,Variant,Options}
 network: UCRV interfaces/*/*

They should not be queried again by USS when USS is directly invoked by d-i (system/setup/boot/start=false & server/role="" in this case).

In appliance mode (system/setup/boot/start=true) some or all settings may be disabled by the vendor preparing the appliance image, e.g. a cloud-provider may pre-configure and hard-code the network settings; or an app-appliance may want to disable installing additional components.

If a setting is not disabled, the current value should be shown as the current default (as when USS is invoked through the normal UMC and not in USS-boot mode).

Currently we already have (or had with UCS-3) the UCRV system/setup/boot/pages/{black,white}list to disable full pages. With the UCS-4 re-design some previously separate settings appear now on the same page. Therefor we need
1. a possibility to disable certain settings,
2. add new or rename the old UCRVs to reflect the change from page to individual setting.


After that the (new) UCRVs need to be either set by d-i or USS should automatically assume them set when in d-i mode.

Should USS still ask if the setting is disabled but not yet provided?
Comment 2 Stefan Gohmann univentionstaff 2014-08-22 08:17:46 CEST
(In reply to Philipp Hahn from comment #1)
> They should not be queried again by USS when USS is directly invoked by d-i
> (system/setup/boot/start=false & server/role="" in this case).

I think d-i should set the variables and system setup should only check the blacklist UCR variables, see Bug #35685

*** This bug has been marked as a duplicate of bug 35685 ***
Comment 3 Felix Botner univentionstaff 2014-08-26 10:31:43 CEST
OK
Comment 4 Stefan Gohmann univentionstaff 2014-11-26 06:55:55 CET
UCS 4.0-0 has been released:
 http://docs.univention.de/release-notes-4.0-0-en.html
 http://docs.univention.de/release-notes-4.0-0-de.html

If this error occurs again, please use "Clone This Bug".