Bug 35498 - Skip root password in USS
Skip root password in USS
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UCS Installer
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.0
Assigned To: Installer maintainers
Drees Dormann
: interim-1
Depends on:
Blocks: 35657
  Show dependency treegraph
 
Reported: 2014-07-28 15:52 CEST by Philipp Hahn
Modified: 2014-11-26 06:54 CET (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Hahn univentionstaff 2014-07-28 15:52:19 CEST
Has already been chosen in d-i and stored in /var/lib/univention-ldap/root-secret
Comment 1 Sönke Schwardt-Krummrich univentionstaff 2014-07-31 12:07:24 CEST
USS should hide this widget if directly started from d-i. But on next reboot (e.g. USS has been stopped via Strg-Q) it should be shown again.
Comment 2 Sönke Schwardt-Krummrich univentionstaff 2014-07-31 12:09:57 CEST
If started via d-i, USS should not ask for 
- the root password during DC master installation ("domain and host config")
- the local root password during DC backup/slave/memberserver installation
Comment 3 Philipp Hahn univentionstaff 2014-08-22 15:05:25 CEST
For easier remote access it would be useful to have a way to set the password for the __systemsetup__ user to some explicit value instead of getting a random 30 character password:

diff --git a/branches/ucs-4.0/ucs-4.0-0/base/univention-system-setup/usr/share/univention-system-setup/startxwithfirefox b/branches/ucs-4.0/ucs-4.0-0/base/univention-system-setup/usr/share/univention-system-setup/startxwithfirefox
index 2f65c55..7f2f558 100755
--- a/branches/ucs-4.0/ucs-4.0-0/base/univention-system-setup/usr/share/univention-system-setup/startxwithfirefox
+++ b/branches/ucs-4.0/ucs-4.0-0/base/univention-system-setup/usr/share/univention-system-setup/startxwithfirefox
@@ -44,7 +44,12 @@ then # call self in xinit as nobody, then start gdm
        USS_PROFILE="/var/cache/univention-system-setup/profile"
 
        # set random password for system setup user
-       USSPASSWD="$(tr -c -d '[:alnum:]' < /dev/urandom | head -c 30)"
+       if [ -s /var/lib/univention-ldap/root.secret ]
+       then
+               USSPASSWD="$(</var/lib/univention-ldap/root.secret)"
+       else
+               USSPASSWD="$(tr -c -d '[:alnum:]' < /dev/urandom | head -c 30)"
+       fi
        echo "__systemsetup__:$USSPASSWD" | chpasswd
 
        default_locale=en_US
Comment 4 Stefan Gohmann univentionstaff 2014-08-26 17:59:52 CEST

*** This bug has been marked as a duplicate of bug 35685 ***
Comment 5 Drees Dormann univentionstaff 2014-08-28 13:43:39 CEST
ok
Comment 6 Stefan Gohmann univentionstaff 2014-11-26 06:54:05 CET
UCS 4.0-0 has been released:
 http://docs.univention.de/release-notes-4.0-0-en.html
 http://docs.univention.de/release-notes-4.0-0-de.html

If this error occurs again, please use "Clone This Bug".