Bug 36241 - Update to Debian 7.7
Update to Debian 7.7
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: General
UCS 4.0
Other Linux
: P5 enhancement (vote)
: UCS 4.0
Assigned To: Stefan Gohmann
Philipp Hahn
https://www.debian.org/News/2014/2014...
: interim-3
: 36333 (view as bug list)
Depends on: 36277
Blocks:
  Show dependency treegraph
 
Reported: 2014-10-21 09:57 CEST by Stefan Gohmann
Modified: 2014-11-26 06:55 CET (History)
0 users

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2014-10-21 09:57:46 CEST
We should import the latest Debian 7.7 update.
Comment 1 Stefan Gohmann univentionstaff 2014-10-22 20:58:39 CEST
I've imported and built the following packages:
 at
 axis
 base-files
 blender
 ca-certificates
 debsums
 dwm
 eglibc
 exim4
 flashplugin-nonfree
 foremost
 getfem++
 gnubg
 hawtjni
 ipython
 iso-scan
 keyutils
 kvpm
 libdatetime-timezone-perl
 libplack-perl
 libsnmp-session-perl
 live-config
 nana
 net-snmp
 netcfg
 oss-compat
 perl
 php-getid3
 postgresql-8.4
 postgresql-9.1
 proftpd-dfsg
 qlandkartegt
 scotch
 supervisor
 tor
 tzdata
 virtinst
 witty
 xdg-utils

The debian-installer was imported but it cannot be build via our buildsystem. Philipp was able to build a new DVD.

The package wireless-regdb cannot be build within our buildsystem. I've downloaded the packages directly.

The following packages were skipped:
 unattended-upgrades: see Bug #33835#c3
 linux: we are using 3.16, see Bug #33844
 debian-installer-netboot-images: currently not used in UCS 4

Changelog: r54843
Comment 2 Philipp Hahn univentionstaff 2014-10-31 20:20:43 CET
FAIL: The following security updates are part of the Debian 7.7 update, but where not imported: why? Only for lua5.1 we currently have separate Bug #36333.
$ grep -Fwv -f 36241-Debian77.imported -f 36241-Debian77.ignored 36241-Debian77.should |
  while read pkg ver;do echo "$pkg	$ver	$(repo_get_version.py -r 4.0 -p "$pkg"|sed -ne 's/Current version: //p')";done

acpi-support	0.140-5+deb7u3	0.140-5
apache2	2.2.22-13+deb7u3	2.2.22-13+deb7u2
bash	4.2+dfsg-0.1+deb7u3	4.2+dfsg-0.1+deb7u3
bind9	1:9.8.4.dfsg.P1-6+nmu2+deb7u2	1:9.8.4.dfsg.P1-6+nmu2+deb7u1
cacti	0.8.8a+dfsg-5+deb7u4	0.8.8a+dfsg-5+deb7u3
chromium-browser	37.0.2062.120-1~deb7u1	35.0.1916.153-1~deb7u1
cups	1.5.3-5+deb7u4	1.5.3-5+deb7u2
curl	7.26.0-1+wheezy10	7.26.0-1+wheezy9
davfs2	1.4.6-1.1+wheezy1	1.4.6-1.1+deb7u1
dbus	1.6.8-1+deb7u4	1.6.8-1+deb7u3
drupal7	7.14-2+deb7u6	7.14-2+deb7u4
exuberant-ctags	1:5.9~svn20110310-4+deb7u1	1:5.9~svn20110310-4
fail2ban	0.8.6-3wheezy3	0.8.6-3wheezy2
file	5.11-2+deb7u5	5.11-2+deb7u3
gnupg	1.4.12-7+deb7u6	1.4.12-7+deb7u4
gpgme1.0	1.2.0-1.4+deb7u1	1.2.0-1.4
kde4libs	4:4.8.4-4+deb7u1	4:4.8.4-4
krb5	1.10.1+dfsg-5+deb7u2	1.10.1+dfsg-5+deb7u1
libav	6:0.8.16-1	6:0.8.13-1
libstruts1.2-java	1.2.9-5+deb7u1	1.2.9-5
libxml2	2.8.0+dfsg1-7+wheezy1	2.8.0+dfsg1-7+nmu3
lua5.1	5.1.5-4+deb7u1	5.1.5-4
lua5.2	5.2.1-3+deb7u1	5.2.1-3
lzo2	2.06-1+deb7u1	2.06-1
mantis	1.2.11-1.2+deb7u1	1.2.11-1.2
mediawiki	1:1.19.20+dfsg-0+deb7u1	1:1.19.16+dfsg-0+deb7u1
modsecurity-apache	2.6.6-6+deb7u2	2.6.6-6+deb7u1
mysql-5.5	5.5.38-0+wheezy1	5.5.37-0+wheezy1
nginx	1.2.1-2.2+wheezy3	1.2.1-2.2+wheezy2
nss	2:3.14.5-1+deb7u2	2:3.14.5-1
openssl	1.0.1e-2+deb7u12	1.0.1e-2+deb7u11
php-cas	1.3.1-4+deb7u1	1.3.1-4
php5	5.4.4-14+deb7u14	5.4.4-14+deb7u12
phpmyadmin	4:3.4.11.1-2+deb7u1	4:3.4.11.1-2
polarssl	1.2.9-1~deb7u3	1.2.9-1~deb7u2
procmail	3.22-20+deb7u1	3.22-20
python-django	1.4.5-1+deb7u8	1.4.5-1+deb7u7
python-imaging	1.1.7-4+deb7u1	1.1.7-4
rsyslog	5.8.11-3+deb7u2	5.8.11-3
ruby-activerecord-3.2	3.2.6-5+deb7u1	3.2.6-5
s3ql	1.11.1-3+deb7u1	1.11.1-3
squid3	3.1.20-2.2+deb7u2	3.1.20-2.2+deb7u1
transmission	2.52-3+nmu2	2.52-3+nmu1
tryton-server	2.2.4-1+deb7u2	2.2.4-1
vlc	2.0.3-5+deb7u1	2.0.3-5
wireshark	1.8.2-5wheezy11	1.8.2-5wheezy10
wordpress	3.6.1+dfsg-1~deb7u4	3.6.1+dfsg-1~deb7u3
xen	4.1.4-3+deb7u3~deb7u4	4.1.4-3+deb7u2

OK: Skipping the following packages is okay, as UCS-4.0 uses newer versions from Debian-Jessie:
 libvirt
 qemu
 qemu-kmv

OK: Skipping the following packages is okay, as they are not part of UCS:
 debian-archive-keyring
 debian-installer-netboot-images
 reportbug
 unattended-upgrades

OK: The package "apt" was already imported through Bug #36277

OK: The mentioned package were imported and build correctly:
$ grep -Fw -f 36241-Debian77.imported 36241-Debian77.should |
  while read pkg ver;do echo "$pkg     $ver    $(repo_get_version.py -r 4.0 -p "$pkg"|sed -ne 's/Current version: //p')";done

OK: The package "scotch" is missing in Debians <http://ftp.debian.org/debian/dists/wheezy/ChangeLog>, but is listed on <https://www.debian.org/News/2014/20141018>. It was imported correctly into UCS-4.0.

OK: "wireless-regdb" imported directly

FAIL: Several packages were remove from the Debian archive for various reasons - see ChangeLog for details; please remove them from UCS-4 as well:
  repo_admin.py
    rm sr
    ctsim dicomnifti ctn ssdeep libplrpc-perl firecookie freecode-submit whatsnewfm hlbrw hlbr iceape linky iceweasel-linky jclicmoodle dactyl turpial pyxpcom edbrowse chmsee

OK: ChangeLog r54843

FYI: See ~phahn/BUG/36241-Debian77-* if you need my raw data files
Comment 3 Stefan Gohmann univentionstaff 2014-11-01 01:04:29 CET
*** Bug 36333 has been marked as a duplicate of this bug. ***
Comment 4 Stefan Gohmann univentionstaff 2014-11-02 12:13:06 CET
(In reply to Philipp Hahn from comment #2)
> FAIL: The following security updates are part of the Debian 7.7 update, but
> where not imported: why? Only for lua5.1 we currently have separate Bug
> #36333.

Simply forgotten, the sec packages were in another section in my overview.

> acpi-support	0.140-5+deb7u3	0.140-5
> apache2	2.2.22-13+deb7u3	2.2.22-13+deb7u2
> bash	4.2+dfsg-0.1+deb7u3	4.2+dfsg-0.1+deb7u3
> bind9	1:9.8.4.dfsg.P1-6+nmu2+deb7u2	1:9.8.4.dfsg.P1-6+nmu2+deb7u1
> cacti	0.8.8a+dfsg-5+deb7u4	0.8.8a+dfsg-5+deb7u3
> cups	1.5.3-5+deb7u4	1.5.3-5+deb7u2
> curl	7.26.0-1+wheezy10	7.26.0-1+wheezy9
> davfs2	1.4.6-1.1+wheezy1	1.4.6-1.1+deb7u1
> dbus	1.6.8-1+deb7u4	1.6.8-1+deb7u3
> drupal7	7.14-2+deb7u6	7.14-2+deb7u4
> exuberant-ctags	1:5.9~svn20110310-4+deb7u1	1:5.9~svn20110310-4
> fail2ban	0.8.6-3wheezy3	0.8.6-3wheezy2
> file	5.11-2+deb7u5	5.11-2+deb7u3
> gnupg	1.4.12-7+deb7u6	1.4.12-7+deb7u4
> gpgme1.0	1.2.0-1.4+deb7u1	1.2.0-1.4
> kde4libs	4:4.8.4-4+deb7u1	4:4.8.4-4
> krb5	1.10.1+dfsg-5+deb7u2	1.10.1+dfsg-5+deb7u1
> libav	6:0.8.16-1	6:0.8.13-1
> libstruts1.2-java	1.2.9-5+deb7u1	1.2.9-5
> libxml2	2.8.0+dfsg1-7+wheezy1	2.8.0+dfsg1-7+nmu3
> lua5.1	5.1.5-4+deb7u1	5.1.5-4
> lua5.2	5.2.1-3+deb7u1	5.2.1-3
> lzo2	2.06-1+deb7u1	2.06-1
> mantis	1.2.11-1.2+deb7u1	1.2.11-1.2
> mediawiki	1:1.19.20+dfsg-0+deb7u1	1:1.19.16+dfsg-0+deb7u1
> modsecurity-apache	2.6.6-6+deb7u2	2.6.6-6+deb7u1
> mysql-5.5	5.5.38-0+wheezy1	5.5.37-0+wheezy1
> nginx	1.2.1-2.2+wheezy3	1.2.1-2.2+wheezy2
> nss	2:3.14.5-1+deb7u2	2:3.14.5-1
> openssl	1.0.1e-2+deb7u12	1.0.1e-2+deb7u11
> php-cas	1.3.1-4+deb7u1	1.3.1-4
> php5	5.4.4-14+deb7u14	5.4.4-14+deb7u12
> phpmyadmin	4:3.4.11.1-2+deb7u1	4:3.4.11.1-2
> polarssl	1.2.9-1~deb7u3	1.2.9-1~deb7u2
> procmail	3.22-20+deb7u1	3.22-20
> python-django	1.4.5-1+deb7u8	1.4.5-1+deb7u7
> python-imaging	1.1.7-4+deb7u1	1.1.7-4
> rsyslog	5.8.11-3+deb7u2	5.8.11-3
> ruby-activerecord-3.2	3.2.6-5+deb7u1	3.2.6-5
> s3ql	1.11.1-3+deb7u1	1.11.1-3
> squid3	3.1.20-2.2+deb7u2	3.1.20-2.2+deb7u1
> transmission	2.52-3+nmu2	2.52-3+nmu1
> tryton-server	2.2.4-1+deb7u2	2.2.4-1
> vlc	2.0.3-5+deb7u1	2.0.3-5
> wireshark	1.8.2-5wheezy11	1.8.2-5wheezy10
> wordpress	3.6.1+dfsg-1~deb7u4	3.6.1+dfsg-1~deb7u3
> xen	4.1.4-3+deb7u3~deb7u4	4.1.4-3+deb7u2

These packages have been imported and built.
 
I was unable to build the chromium-browser package. I've created a new bug for it: Bug #36382
 
> FAIL: Several packages were remove from the Debian archive for various
> reasons - see ChangeLog for details; please remove them from UCS-4 as well:
>   repo_admin.py
>     rm sr
>     ctsim dicomnifti ctn ssdeep libplrpc-perl firecookie freecode-submit
> whatsnewfm hlbrw hlbr iceape linky iceweasel-linky jclicmoodle dactyl
> turpial pyxpcom edbrowse chmsee

The following packages have been removed:
ctsim, dicomnifti, ctn, ssdeep, firecookie, freecode-submit, whatsnewfm, hlbrw, hlbr

I didn't found these packages:
libplrpc-perl, iceape, linky, iceweasel-linky, jclicmoodle, dactyl, turpial, pyxpcom, edbrowse, chmsee
Comment 5 Philipp Hahn univentionstaff 2014-11-03 15:12:50 CET
OK: Newer packages then in last Debian release:
drupal7 7.14-2+deb7u6   7.14-2+deb7u7
libxml2 2.8.0+dfsg1-7+wheezy1   2.8.0+dfsg1-7+wheezy2
openssl 1.0.1e-2+deb7u12        1.0.1e-2+deb7u13
wireshark       1.8.2-5wheezy11 1.8.2-5wheezy12

FAIL: <https://packages.debian.org/source/wheezy/nss>
nss     2:3.14.5-1+deb7u2       2:3.14.5-1

TODO: check that all packages are build

OK: repo_stat.py ctsim dicomnifti ctn ssdeep libplrpc-perl firecookie freecode-submit  whatsnewfm hlbrw hlbr iceape linky iceweasel-linky jclicmoodle dactyl turpial pyxpcom edbrowse chmsee
Comment 6 Stefan Gohmann univentionstaff 2014-11-03 15:47:38 CET
(In reply to Philipp Hahn from comment #5)
> FAIL: <https://packages.debian.org/source/wheezy/nss>
> nss     2:3.14.5-1+deb7u2       2:3.14.5-1

New version has been imported and built:

stefan@dimma:~$ repo_stat.py nss | tail -n 3
2:3.14.5-1+deb7u2 imported on 2014-11-03 15:27:23.168176
 Included in release tag 4.0-0-0 (70009)
Comment 7 Philipp Hahn univentionstaff 2014-11-04 01:58:03 CET
OK: 36241-Debian77.check

OK: ls -gG net-snmp_5.4.3~dfsg*
-rw-rw-r-- 1    1658 22. Okt 20:25 net-snmp_5.4.3~dfsg+1-2.8.38.201410222022.dsc
-rw-rw-r-- 1    4962 22. Okt 20:28 net-snmp_5.4.3~dfsg+1-2.8.38.201410222022_i386.changes
-rw-rw-r-- 1 4558669 22. Okt 20:25 net-snmp_5.4.3~dfsg+1-2.8.38.201410222022.tar.gz
-rw-rw-r-- 1 4389779 22. Okt 20:28 net-snmp_5.4.3~dfsg.orig.tar.gz
Comment 8 Stefan Gohmann univentionstaff 2014-11-26 06:55:31 CET
UCS 4.0-0 has been released:
 http://docs.univention.de/release-notes-4.0-0-en.html
 http://docs.univention.de/release-notes-4.0-0-de.html

If this error occurs again, please use "Clone This Bug".