Bug 36365 - Update from 2.4 to UCS 4.0
Update from 2.4 to UCS 4.0
Product: UCS
Classification: Unclassified
Component: Update - Release updates
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.0
Assigned To: Felix Botner
Arvid Requate
: interim-3
Depends on:
  Show dependency treegraph
Reported: 2014-10-31 12:11 CET by Felix Botner
Modified: 2014-11-26 06:55 CET (History)
1 user (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Flags outvoted (downgraded) after PO Review:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Note You need to log in before you can comment on or make changes to this bug.
Description Felix Botner univentionstaff 2014-10-31 12:11:34 CET
Fails at the moment. 

The update works better if i run

-> apt-get autoremove and
-> dpkg -P pnm2ppa

before the update but it still fails with

E: Conf Broken xserver-xorg-core:i386
E: Could not perform immediate configuration on 'phonon-backend-vlc'. Please see man 5 apt.conf under APT::Immediate-Configure for details. (2)
Comment 1 Felix Botner univentionstaff 2014-10-31 12:13:37 CET
If i add unmaintained to the sources, the 'phonon-backend-vlc' error is gone
Comment 2 Felix Botner univentionstaff 2014-10-31 14:41:05 CET
An update with unmaintained (and apt-get autoremove, dpkg -P pnm2ppa) works.
Comment 3 Felix Botner univentionstaff 2014-11-03 11:41:20 CET
Added phonon-backend-vlc to maintained.
Comment 4 Felix Botner univentionstaff 2014-11-04 10:48:28 CET
Added amarok to maintained, otherwise the update (if amarok is installed) failes with

E: »phonon-backend-vlc« konnte nicht unmittelbar konfiguriert werden. Lesen Sie »man 5 apt.conf« unter APT::Immediate-Configure bezüglich weiterer Details. (2)
Comment 5 Felix Botner univentionstaff 2014-11-05 12:50:35 CET
Update from 2.4-3 to 4.0-0 works for me now.
Comment 6 Arvid Requate univentionstaff 2014-11-07 15:39:00 CET
My tests failed in the preup step from UCS 3.2-3 -> UCS 4.0:

The preup fails with the message posted in Bug 36455 Comment 6 but from the updater.log it looks like the clamav-daemon package has been left broken by the autoremove: http://hutten.knut.univention.de/pastebin/m44af10d6

running "dpkg -C" directly after the autoremoval sais:
Die folgenden Pakete sind nur halb konfiguriert, wahrscheinlich durch
Probleme während der ersten Konfiguration. Die Konfiguration sollte mit
dpkg --configure <Paket> oder mit dem Konfigurations-Menüeintrag in
dselect erneut versucht werden:
 clamav-daemon        anti-virus utility for Unix - scanner daemon
Comment 7 Felix Botner univentionstaff 2014-11-10 11:23:45 CET
-> apt-get -s autoremove| grep "Remv.*univention"
Remv univention-antivir-mail [5.0.0-4.116.201310291140]
Remv univention-smbencrypt [3.0.0-1.28.201006231118]
Remv univention-spamassassin [5.0.0-2.67.201310291138]
Remv libunivention-debug0 [4.0.0-1.68.201112191254]
Remv univention-client-boot-pxe [5.1.0-2.701.201101251441]
Remv univention-client-kernel-image [1:4.1.0-1.99.201006251236]
Remv univention-client-kernel-image- [1]
Remv univention-dojo [4.0.4-1.36.201108151723]
Remv univention-mail-cyrus-imap [6.0.6-1.194.201403170855]
Remv univention-mail-cyrus-pop [6.0.6-1.194.201403170855]
Remv univention-management-console-system-info [1.0.3-1.21.201102071415]
Remv univention-management-console-themes [3.0.113-1.528.201109281807]
Remv univention-security-update [5.0.0-11.88.201209271046]
Remv univention-session [6.1.0-1.28.201006251154]
Remv univention-thin-client-tools [7.1.5-1.226.201011241646]

Looks like we need to unmarkauto at least these packages

 * univention-antivir-mail
 * univention-spamassassin
 * univention-smbencrypt (?)
 * libunivention-debug0 (?)
 * univention-mail-cyrus-imap
 * univention-mail-cyrus-pop
Comment 8 Felix Botner univentionstaff 2014-11-10 11:50:54 CET
univention-smbencrypt is obsolete and libunivention-debug0 replaced by libunivention-debug1.
Comment 9 Felix Botner univentionstaff 2014-11-10 12:25:21 CET
Added apt-get unmarkauto for
 * univention-antivir-mail
 * univention-spamassassin
 * univention-mail-cyrus-imap
 * univention-mail-cyrus-pop
in preup.sh.
Comment 10 Arvid Requate univentionstaff 2014-11-10 19:09:57 CET
Ok, this works now. Changelog entry for Bug 36265 is enough.
Comment 11 Stefan Gohmann univentionstaff 2014-11-26 06:55:56 CET
UCS 4.0-0 has been released:

If this error occurs again, please use "Clone This Bug".