Bug 36455 - Update from UCS 3.2-3 → 4.0 fails with installed gcc package
Update from UCS 3.2-3 → 4.0 fails with installed gcc package
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Update - Release updates
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.0
Assigned To: Arvid Requate
Felix Botner
: interim-4
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-05 16:00 CET by Alexander Kläser
Modified: 2014-11-26 06:54 CET (History)
1 user (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kläser univentionstaff 2014-11-05 16:00:56 CET
> The following packages have unmet dependencies:
> libc6-dev : Breaks: gcc-4.4 (< 4.4.6-4) but 4.4.5-8.3.201104271833 is to be installed
> libgcc1 : Breaks: gcc-4.4 (< 4.4.6-4) but 4.4.5-8.3.201104271833 is to be installed
> libgomp1 : Breaks: gcc-4.4 (< 4.4.6-4) but 4.4.5-8.3.201104271833 is to be installed
> E: Broken packages
> failed.
> ERROR: Failed to upgrade univention-ldap-config.
> Error: Update aborted by pre-update script of release 4.0-0

After uninstalling gcc, I could update.
Comment 1 Arvid Requate univentionstaff 2014-11-05 17:52:55 CET
Update worked with unmaintained enabled, and looking at what get's downloaded, I'd say gcc-4.4 just needs to be added to the DVD list (like cpp-4-4 and other packages which are already on that list). Let's see in QA after the new DVD has been built tonight (currently the DVD rebuilt is blocked due to ongoing package builds).
Comment 2 Felix Botner univentionstaff 2014-11-06 14:36:55 CET
No, i still get 

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libc6-dev : Beschädigt: gcc-4.4 (< 4.4.6-4) aber 4.4.5-8.3.201104271833 soll installiert werden
 libgcc1 : Beschädigt: gcc-4.4 (< 4.4.6-4) aber 4.4.5-8.3.201104271833 soll installiert werden
 libgomp1 : Beschädigt: gcc-4.4 (< 4.4.6-4) aber 4.4.5-8.3.201104271833 soll installiert werden
E: Beschädigte Pakete
Comment 3 Felix Botner univentionstaff 2014-11-06 14:38:40 CET
gcc was installed during the installation of univention-system-setup-boot
Comment 4 Arvid Requate univentionstaff 2014-11-06 16:37:02 CET
Ok, there is a difference between i386 and amd64. In amd64 it works, in i386 not.
The current theory is this:

Updating univention-ldap-config requires updating univention-ldap-server, as univention-ldap-server has a versioned dependency. univention-ldap-server pulls db5.1-util pulls libdb5.1 which pre-depnds on multiarch-support.
And multiarch-support finally declares versioned dependencies on libc6 which are more strict for i386:

=====================================================================
Package: multiarch-support
Priority: required
Section: libs
Installed-Size: 181
Maintainer: GNU Libc Maintainers <debian-glibc@lists.debian.org>
Architecture: i386
Source: eglibc
Version: 2.13-38.17.201410221243
Depends: libc6 (>= 2.13-5)


Package: multiarch-support
Priority: required
Section: libs
Installed-Size: 181
Maintainer: GNU Libc Maintainers <debian-glibc@lists.debian.org>
Architecture: amd64
Source: eglibc
Version: 2.13-38.17.201410221243
Depends: libc6 (>= 2.3.6-2)
=====================================================================

I added gcc-4.4 to the pre-update list, it only get's updated if it has been installed before. As a result we have two different update paths: Only if gcc-4.4 is installed then libc6 is pre-updated along with it.

Alternatively we could pre-update gcc-4.4-base, which seems to be present by default on all standard UCS installations. Then libc6 would always be pre-updated.

Trying with gcc-4.4 for now. Changelog entry added.
Comment 5 Felix Botner univentionstaff 2014-11-07 09:44:12 CET
OK - update i386 with gcc (gcc-4.4)
OK - update i386 without gcc (gcc-4.4)

OK - update amd64 with gcc (gcc-4.4)
OK - update amd64 without gcc (gcc-4.4)

OK - Changelog
Comment 6 Arvid Requate univentionstaff 2014-11-07 13:25:35 CET
This still fails (on amd64) when upgrading from UCS 2.4-3:

===========================================================================
Starting pre-upgrade of gcc-4.4: Paketlisten werden gelesen...
Abhängigkeitsbaum wird aufgebaut...
Statusinformationen werden eingelesen...
Probieren Sie »apt-get -f install«, um dies zu korrigieren:
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 clamav-daemon : Hängt ab von: libclamav6 (>= 0.98.1+dfsg) soll aber nicht installiert werden
                 Hängt ab von: clamav-base (= 0.98.1+dfsg-1.128.201406171144) soll aber nicht installiert werden
                 Hängt ab von: clamav-freshclam soll aber nicht installiert werden oder
                                clamav-data
 gcc-4.4 : Hängt ab von: gcc-4.4-base (= 4.4.7-2.8.201403121445) aber 4.4.5-8.3.201104271833 soll installiert werden
           Hängt ab von: cpp-4.4 (= 4.4.7-2.8.201403121445) aber 4.4.5-8.3.201104271833 soll installiert werden
           Hängt ab von: libgcc1 (>= 1:4.4.7-2.8.201403121445) aber 1:4.4.5-8.3.201104271833 soll installiert werden
           Hängt ab von: libgomp1 (>= 4.4.7-2.8.201403121445) aber 4.4.5-8.3.201104271833 soll installiert werden
           Empfiehlt: libc6-dev (>= 2.13-5) aber 2.11.3-4.10.201210011626 soll installiert werden
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt-get -f install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).
failed.
ERROR: Failed to upgrade gcc-4.4.
===========================================================================

Looks loke it works when pre-upgrading gcc-4.4-base instead. I adjusted the preup accordingly.
Comment 7 Arvid Requate univentionstaff 2014-11-07 14:00:54 CET
Still not ok.
Comment 8 Arvid Requate univentionstaff 2014-11-07 15:40:27 CET
Ok, the real issue seems to be a broken clamav-daemon package, this will be handled via Bug #36365 Comment 6.
Comment 9 Felix Botner univentionstaff 2014-11-10 20:03:01 CET
OK - update amd64/i386 with gcc-4.4-base
OK - Changelog
Comment 10 Stefan Gohmann univentionstaff 2014-11-26 06:54:42 CET
UCS 4.0-0 has been released:
 http://docs.univention.de/release-notes-4.0-0-en.html
 http://docs.univention.de/release-notes-4.0-0-de.html

If this error occurs again, please use "Clone This Bug".