Bug 36413 - AD member join fails permanently if first AD member setup fails
AD member join fails permanently if first AD member setup fails
Status: VERIFIED WORKSFORME
Product: UCS
Classification: Unclassified
Component: System setup
UCS 4.0
Other Linux
: P5 enhancement (vote)
: UCS 4.0-x
Assigned To: UCS maintainers
Arvid Requate
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-04 11:54 CET by Arvid Requate
Modified: 2018-07-09 19:09 CEST (History)
5 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Flags outvoted (downgraded) after PO Review:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
management-console-module-setup.log (9.94 KB, text/plain)
2014-11-04 11:54 CET, Arvid Requate
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Arvid Requate univentionstaff 2014-11-04 11:54:15 CET
Created attachment 6293 [details]
management-console-module-setup.log

In my test the initial AD member setup failed because the AD clock was behind the UCS clock and I received a message informing about this. I adjusted the time on the AD server and clicked on "reconfigure" in UCS system setup. The same message appears again, blocking the join permanently. The managment-console-module-setup.log shows a message indicating a different issue: The python code detected that the UCS system is already joined and refuses to try it again. See attached log.



+++ This bug was initially created as a clone of Bug #35653 +++

It should be possible to configure the AD member mode in the initial system setup wizard during the installation.
Comment 1 Arvid Requate univentionstaff 2014-11-04 11:57:03 CET
Manually removing /var/univention-join/joined doesn't help much in this case: The error message is replaced by an empty error message.
Comment 2 Stefan Gohmann univentionstaff 2017-04-21 11:10:23 CEST

*** This bug has been marked as a duplicate of bug 44035 ***
Comment 3 Florian Best univentionstaff 2017-05-10 17:24:29 CEST
(In reply to Stefan Gohmann from comment #2)
> 
> *** This bug has been marked as a duplicate of bug 44035 ***

@Stefan: This doesn't seem to be a duplicate. Wrong bug number?
Comment 4 Florian Best univentionstaff 2017-11-30 11:22:28 CET
@Arvid,
I guess this works now. In UCS 4.1 (or so) we added the possibility to start the join process again.