Bug 36562 - no error information in services module
no error information in services module
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - System services
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-1-errata
Assigned To: Florian Best
Johannes Keiser
:
: 9023 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-11 12:51 CET by Florian Best
Modified: 2017-07-05 13:06 CEST (History)
3 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 3: Simply Wrong: The implementation doesn't match the docu
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.069
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Ticket number:
Bug group (optional): Error handling, Troubleshooting, Usability
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2014-11-11 12:51:00 CET
There is no information (neither in logfiles nor in the response) why starting of a service failed (e.g. the init script does not exists). The module should at least log stderr of 'invoke-rc.d' call if the command failed.
Comment 1 Florian Best univentionstaff 2016-08-24 15:13:14 CEST
*** Bug 9023 has been marked as a duplicate of this bug. ***
Comment 2 Florian Best univentionstaff 2017-07-03 14:12:15 CEST
The output of "systemctl status $service" is now attached to the error message, which helps in a lot of cases.

univention-management-console-module-services.yaml:
r80775 | YAML Bug #36563 Bug #36562

univention-management-console-module-services (6.0.0-4):
r80773 | Bug #36562: enhance error messages shown to the user
r80772 | Bug #36562: fix error handling and simplify code
Comment 3 Johannes Keiser univentionstaff 2017-07-04 13:42:12 CEST
OK systemctl status is shown on error

YAML: OK
-> verified
Comment 4 Janek Walkenhorst univentionstaff 2017-07-05 13:06:14 CEST
<http://errata.software-univention.de/ucs/4.2/82.html>