Bug 36563 - 'start' a service which is already started
'start' a service which is already started
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - System services
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-1-errata
Assigned To: Florian Best
Johannes Keiser
:
: 29611 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-11 12:57 CET by Florian Best
Modified: 2017-07-05 13:06 CEST (History)
2 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 2: Improvement: Would be a product improvement
Who will be affected by this bug?: 3: Will affect average number of installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.069
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Ticket number:
Bug group (optional): Usability
Max CVSS v3 score:
best: Patch_Available+


Attachments
patch (2.21 KB, patch)
2014-11-11 13:31 CET, Florian Best
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2014-11-11 12:57:51 CET
The services module offers the grid action to 'automatically start' a service even if the service is already flagged as those. Same applies to all other actions like 'manual start' and 'no start'.
Comment 1 Florian Best univentionstaff 2014-11-11 13:01:07 CET
Oh, the problem applies to every grid action. So also 'start', 'stop' and 'restart' are executable even if the service has that state.
Comment 2 Florian Best univentionstaff 2014-11-11 13:31:23 CET
Created attachment 6341 [details]
patch

Attached a patch which also respects if multiple entries are selected to allow e.g. that multiple services can be stopped even if the selection contains one service which is not running.
Comment 3 Florian Best univentionstaff 2016-08-24 15:48:19 CEST
*** Bug 29611 has been marked as a duplicate of this bug. ***
Comment 4 Florian Best univentionstaff 2017-07-03 14:11:03 CEST
Patch has been applied.

univention-management-console-module-services.yaml:
r80775 | YAML Bug #36563 Bug #36562

univention-management-console-module-services (6.0.0-4):
r80774 | Bug #36563: prevent starting of already started services
Comment 5 Johannes Keiser univentionstaff 2017-07-04 13:26:35 CEST
OK Start/Stop/Start automatically/Start manually/Start never/ actions are only
   executable if they are not currently in that state.
OK Restart is always executable.
OK If e.g. stopping multiple services, services which are already stopped are
   ignored. This applies to all other actions too.

YAML: OK
Comment 6 Janek Walkenhorst univentionstaff 2017-07-05 13:06:15 CEST
<http://errata.software-univention.de/ucs/4.2/82.html>