Bug 36636 - Endless UMC login animation after AUTH login error [401]
Endless UMC login animation after AUTH login error [401]
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.0-0-errata
Assigned To: Florian Best
Alexander Kramer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-13 12:57 CET by Alexander Kläser
Modified: 2015-02-04 15:58 CET (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Error handling, Usability
Max CVSS v3 score:
best: Patch_Available+


Attachments
patch (1.25 KB, patch)
2014-11-13 14:14 CET, Florian Best
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kläser univentionstaff 2014-11-13 12:57:21 CET
This can be reproduced when the UMC server process is not running. The login process appears is endless, although a 401 error is returned upon the auth command. This seems to be an error in the JavaScript handling in LoginDialog:

> ...
> array.forEach(forms, lang.hitch(this, function(ff) {
>   var form = ff[0];
>   var iform = ff[1];
>   this._connections.push(on(iform, 'submit', lang.hitch(this, function(evt) {
> ...

"iform" has the value "null" which causes an exception in the on() function.

An error message should be shown instead.
Maybe we could also add a hint that the server process is not running?
Comment 1 Florian Best univentionstaff 2014-11-13 12:59:26 CET
(In reply to Alexander Kläser from comment #0)
> An error message should be shown instead.
> Maybe we could also add a hint that the server process is not running?
→ I created somewhere a bug for this, the error status in that case is wrong. It should not be 401 but 503 Service Unavailable.
Comment 2 Florian Best univentionstaff 2014-11-13 14:14:59 CET
Created attachment 6363 [details]
patch

The "display: block" attribute wasn't set. Does not happen always. Maybe only when there was a message already shown. Can be easy reproduced if the umc-server is not running.
Comment 3 Florian Best univentionstaff 2015-01-30 10:58:58 CET
Patch applied in svn r57683. The message that the UMC-server is not running was done at Bug #36400.
Package: univention-management-console-frontend
Version: 4.1.106-11.993.201501301040
YAML: 2015-01-30-univention-management-console-frontend.yaml
Comment 4 Alexander Kramer univentionstaff 2015-02-02 12:38:13 CET
OK - Error message guidance instead of endless login screen
OK - debian/changelog
OK - yaml
Comment 5 Janek Walkenhorst univentionstaff 2015-02-04 15:58:03 CET
<http://errata.univention.de/ucs/4.0/76.html>